summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-05-05 05:27:23 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-05-05 05:27:23 +0000
commita04072167eeba58191b29e822822e80edea07b2c (patch)
tree64290b4e2c98d6a1d2bdeed65ff2def51860ec23 /games-util
parentForce python2 fixing bug #312279 (diff)
downloadhistorical-a04072167eeba58191b29e822822e80edea07b2c.tar.gz
historical-a04072167eeba58191b29e822822e80edea07b2c.tar.bz2
historical-a04072167eeba58191b29e822822e80edea07b2c.zip
Force python2 fixing bug #312289
Package-Manager: portage-2.1.8.3/cvs/Linux i686
Diffstat (limited to 'games-util')
-rw-r--r--games-util/mattricks/ChangeLog7
-rw-r--r--games-util/mattricks/mattricks-0.7.ebuild18
2 files changed, 17 insertions, 8 deletions
diff --git a/games-util/mattricks/ChangeLog b/games-util/mattricks/ChangeLog
index 8ebccf9dd1ff..ccc0360545a9 100644
--- a/games-util/mattricks/ChangeLog
+++ b/games-util/mattricks/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-util/mattricks
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/mattricks/ChangeLog,v 1.9 2007/12/07 00:04:32 dirtyepic Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/mattricks/ChangeLog,v 1.10 2010/05/05 05:27:23 tupone Exp $
+
+ 05 May 2010; Tupone Alfredo <tupone@gentoo.org> mattricks-0.7.ebuild:
+ Force python2 fixing bug #312289 by arfrever@gentoo.org
07 Dec 2007; Ryan Hill <dirtyepic@gentoo.org>
+files/mattricks-0.7-wxversion.patch, mattricks-0.7.ebuild:
diff --git a/games-util/mattricks/mattricks-0.7.ebuild b/games-util/mattricks/mattricks-0.7.ebuild
index 4356bc5a1cf6..0b8875b97406 100644
--- a/games-util/mattricks/mattricks-0.7.ebuild
+++ b/games-util/mattricks/mattricks-0.7.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/mattricks/mattricks-0.7.ebuild,v 1.5 2007/12/07 00:04:32 dirtyepic Exp $
-
-inherit distutils eutils
+# $Header: /var/cvsroot/gentoo-x86/games-util/mattricks/mattricks-0.7.ebuild,v 1.6 2010/05/05 05:27:23 tupone Exp $
+EAPI="2"
+PYTHON_DEPEND="2"
+inherit eutils python distutils
MY_P=${P/m/M}
DESCRIPTION="Hattrick Manager"
@@ -19,7 +20,12 @@ DEPEND="<dev-python/wxpython-2.8
S=${WORKDIR}/${MY_P}
-src_unpack() {
- distutils_src_unpack
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ distutils_src_prepare
epatch "${FILESDIR}"/${P}-wxversion.patch
+ python_convert_shebangs -r 2 .
}