summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-09-28 20:57:17 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-09-28 20:57:17 +0000
commit509bbf2baf9566f52412e9d06c709655231a7918 (patch)
treec5cbcef7bfb8caaacfa32dc91ac9d655b8883c2d /gnome-base/libbonoboui
parentVersion bump. (diff)
downloadhistorical-509bbf2baf9566f52412e9d06c709655231a7918.tar.gz
historical-509bbf2baf9566f52412e9d06c709655231a7918.tar.bz2
historical-509bbf2baf9566f52412e9d06c709655231a7918.zip
Version bump. Translation updates.
Package-Manager: portage-2.2_rc88/cvs/Linux x86_64
Diffstat (limited to 'gnome-base/libbonoboui')
-rw-r--r--gnome-base/libbonoboui/ChangeLog8
-rw-r--r--gnome-base/libbonoboui/libbonoboui-2.24.4.ebuild51
2 files changed, 58 insertions, 1 deletions
diff --git a/gnome-base/libbonoboui/ChangeLog b/gnome-base/libbonoboui/ChangeLog
index e0cc67a5d5e7..564bfd55bbe1 100644
--- a/gnome-base/libbonoboui/ChangeLog
+++ b/gnome-base/libbonoboui/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-base/libbonoboui
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/libbonoboui/ChangeLog,v 1.194 2010/09/11 18:39:36 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libbonoboui/ChangeLog,v 1.195 2010/09/28 20:57:17 eva Exp $
+
+*libbonoboui-2.24.4 (28 Sep 2010)
+
+ 28 Sep 2010; Gilles Dartiguelongue <eva@gentoo.org>
+ +libbonoboui-2.24.4.ebuild:
+ Version bump. Translation updates.
11 Sep 2010; Joseph Jezak <josejx@gentoo.org> libbonoboui-2.24.3.ebuild:
Marked ppc for bug #324077.
diff --git a/gnome-base/libbonoboui/libbonoboui-2.24.4.ebuild b/gnome-base/libbonoboui/libbonoboui-2.24.4.ebuild
new file mode 100644
index 000000000000..363f81ab4c2b
--- /dev/null
+++ b/gnome-base/libbonoboui/libbonoboui-2.24.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libbonoboui/libbonoboui-2.24.4.ebuild,v 1.1 2010/09/28 20:57:17 eva Exp $
+
+EAPI="3"
+GCONF_DEBUG="no"
+
+inherit eutils gnome2 virtualx
+
+DESCRIPTION="User Interface part of libbonobo"
+HOMEPAGE="http://developer.gnome.org/arch/gnome/componentmodel/bonobo.html"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE="doc"
+
+# GTK+ dep due to bug #126565
+RDEPEND=">=gnome-base/libgnomecanvas-1.116
+ >=gnome-base/libbonobo-2.22
+ >=gnome-base/libgnome-2.13.7
+ >=dev-libs/libxml2-2.4.20
+ >=gnome-base/gconf-2
+ >=x11-libs/gtk+-2.8.12
+ >=dev-libs/glib-2.6.0
+ >=gnome-base/libglade-1.99.11
+ >=dev-libs/popt-1.5"
+
+DEPEND="${RDEPEND}
+ x11-apps/xrdb
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.20
+ >=dev-util/intltool-0.40
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --disable-maintainer-mode"
+}
+
+src_configure() {
+ addpredict "/root/.gnome2_private"
+
+ gnome2_src_configure
+}
+
+src_test() {
+ addwrite "/root/.gnome2_private"
+ Xemake check || die "tests failed"
+}