summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-03-30 19:23:14 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2013-03-30 19:23:14 +0000
commit039e618ba055a13830610b75d1961658c45406ca (patch)
tree8e46227e978a7c37cc4391b02993537d3446bae4 /gnome-extra/libgsf/libgsf-1.14.26.ebuild
parentPostgreSQL unit testing comes to Gentoo. Initial commit. (diff)
downloadhistorical-039e618ba055a13830610b75d1961658c45406ca.tar.gz
historical-039e618ba055a13830610b75d1961658c45406ca.tar.bz2
historical-039e618ba055a13830610b75d1961658c45406ca.zip
Version bump. Python support is now only provided by introspection.
Package-Manager: portage-2.2.0_alpha170/cvs/Linux x86_64 Manifest-Sign-Key: 0xC6085806
Diffstat (limited to 'gnome-extra/libgsf/libgsf-1.14.26.ebuild')
-rw-r--r--gnome-extra/libgsf/libgsf-1.14.26.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnome-extra/libgsf/libgsf-1.14.26.ebuild b/gnome-extra/libgsf/libgsf-1.14.26.ebuild
new file mode 100644
index 000000000000..2917fd92515a
--- /dev/null
+++ b/gnome-extra/libgsf/libgsf-1.14.26.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgsf/libgsf-1.14.26.ebuild,v 1.1 2013/03/30 19:23:10 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="The GNOME Structured File Library"
+HOMEPAGE="http://projects.gnome.org/libgsf/"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0/114"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="bzip2 gtk +introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.26:2
+ >=dev-libs/libxml2-2.4.16:2
+ sys-libs/zlib
+ bzip2? ( app-arch/bzip2 )
+ gtk? ( x11-libs/gtk+:2 )
+ introspection? ( >=dev-libs/gobject-introspection-1 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+ >=dev-util/intltool-0.35.0
+ dev-libs/gobject-introspection-common
+ virtual/pkgconfig
+"
+
+src_configure() {
+ DOCS="AUTHORS BUGS ChangeLog HACKING NEWS README TODO"
+ gnome2_src_configure \
+ --disable-static \
+ $(use_with bzip2 bz2) \
+ $(use_enable introspection) \
+ $(use_with gtk gdk-pixbuf)
+} \ No newline at end of file