summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2004-03-09 12:27:15 +0000
committerCaleb Tennis <caleb@gentoo.org>2004-03-09 12:27:15 +0000
commitc2343165cce67f69bdd873a115c85377c4ce5ffc (patch)
treeafd3bb9ccc2775ec5b6510baf77863e177b72f75 /kde-base/arts
parentChangeLog fix (diff)
downloadhistorical-c2343165cce67f69bdd873a115c85377c4ce5ffc.tar.gz
historical-c2343165cce67f69bdd873a115c85377c4ce5ffc.tar.bz2
historical-c2343165cce67f69bdd873a115c85377c4ce5ffc.zip
Version bump
Diffstat (limited to 'kde-base/arts')
-rw-r--r--kde-base/arts/ChangeLog7
-rw-r--r--kde-base/arts/arts-1.2.1.ebuild81
-rw-r--r--kde-base/arts/files/digest-arts-1.2.11
3 files changed, 88 insertions, 1 deletions
diff --git a/kde-base/arts/ChangeLog b/kde-base/arts/ChangeLog
index b1d830163e78..35b83f8ab9a2 100644
--- a/kde-base/arts/ChangeLog
+++ b/kde-base/arts/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/arts
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/ChangeLog,v 1.80 2004/02/28 17:08:20 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/ChangeLog,v 1.81 2004/03/09 12:16:08 caleb Exp $
+
+*arts-1.2.1 (09 Mar 2004)
+
+ 09 Mar 2004; Caleb Tennis <caleb@gentoo.org> arts-1.2.1.ebuild:
+ Version bump
28 Feb 2004; Jason Wever <weeve@gentoo.org> arts-1.1.5.ebuild:
Marked stable on sparc.
diff --git a/kde-base/arts/arts-1.2.1.ebuild b/kde-base/arts/arts-1.2.1.ebuild
new file mode 100644
index 000000000000..d584fc104c60
--- /dev/null
+++ b/kde-base/arts/arts-1.2.1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/arts-1.2.1.ebuild,v 1.1 2004/03/09 12:16:08 caleb Exp $
+
+inherit kde flag-o-matic
+set-kdedir 3.2
+
+DESCRIPTION="aRts, the KDE sound (and all-around multimedia) server/output manager"
+HOMEPAGE="http://multimedia.kde.org/"
+SRC_URI="mirror://kde/stable/${PV/1.2.1/3.2.1}/src/${PN}-${PV}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="3.2"
+KEYWORDS="~x86 ~ppc ~sparc ~hppa ~amd64"
+IUSE="alsa oggvorbis esd artswrappersuid mad"
+
+DEPEND="alsa? ( media-libs/alsa-lib virtual/alsa )
+ oggvorbis? ( media-libs/libvorbis media-libs/libogg )
+ esd? ( media-sound/esound )
+ mad? ( media-libs/libmad media-libs/libid3tag )
+ media-libs/audiofile
+ >=dev-libs/glib-2
+ >=x11-libs/qt-3.2
+ >=sys-apps/portage-2.0.49-r8"
+
+# patch to configure.in.in that makes the vorbis, libmad deps optional
+# has no version number in its filename because it's the same for all
+# arts versions - the patched file hasn't changed in a year's time
+# PATCHES="$FILESDIR/optional-deps.diff"
+
+src_unpack() {
+ kde_src_unpack
+ kde_sandbox_patch ${S}/soundserver
+ # for the configure.in.in patch, for some reason it's not automatically picked up
+ # rm -f $S/configure
+}
+
+src_compile() {
+# if [ "${COMPILER}" == "gcc3" ]; then
+# # GCC 3.1 kinda makes arts buggy and prone to crashes when compiled with
+# # these.. Even starting a compile shuts down the arts server
+# filter-flags -fomit-frame-pointer -fstrength-reduce
+# fi
+
+ #fix bug 13453
+ filter-flags -foptimize-sibling-calls
+
+ myconf="$myconf `use_enable alsa`"
+ myconf="$myconf `use_enable oggvorbis vorbis`"
+ myconf="$myconf `use_enable mad libmad`"
+
+ kde_src_compile
+}
+
+src_install() {
+ kde_src_install
+ dodoc ${S}/doc/{NEWS,README,TODO}
+
+ # moved here from kdelibs so that when arts is installed
+ # without kdelibs it's still in the path.
+ dodir /etc/env.d
+echo "PATH=${PREFIX}/bin
+ROOTPATH=${PREFIX}/sbin:${PREFIX}/bin
+LDPATH=${PREFIX}/lib
+CONFIG_PROTECT=${PREFIX}/share/config" > ${D}/etc/env.d/48kdepaths-3.2.0 # number goes down with version upgrade
+
+ echo "KDEDIR=$PREFIX" > ${D}/etc/env.d/57kdedir-3.2.1 # number goes up with version upgrade
+
+ # used for realtime priority, but off by default as it is a security hazard
+ use artswrappersuid && chmod +s ${D}/${PREFIX}/bin/artswrapper
+}
+
+pkg_postinst() {
+ if [ ! `use artswrappersuid` ] ; then
+ einfo "Run chmod +s ${PREFIX}/bin/artswrapper to let artsd use realtime priority"
+ einfo "and so avoid possible skips in sound. However, on untrusted systems this"
+ einfo "creates the possibility of a DoS attack that'll use 100% cpu at realtime"
+ einfo "priority, and so is off by default. See bug #7883."
+ einfo "Or, you can set the local artswrappersuid USE flag to make the ebuild do this."
+ fi
+}
diff --git a/kde-base/arts/files/digest-arts-1.2.1 b/kde-base/arts/files/digest-arts-1.2.1
new file mode 100644
index 000000000000..c0963f093e32
--- /dev/null
+++ b/kde-base/arts/files/digest-arts-1.2.1
@@ -0,0 +1 @@
+MD5 84877632917893438c629803e7b004f3 arts-1.2.1.tar.bz2 1039479