summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-02-09 00:19:07 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-02-09 00:19:07 +0000
commit6b080925ae1cd39b839598d11f25f5f72e17fd75 (patch)
treeedd5c4089bda3abee53fc50b99bd5b31ae1624b2 /kde-base/kalzium
parent[kde-base/klettres] Version bump to KDE SC 4.4.0 (diff)
downloadhistorical-6b080925ae1cd39b839598d11f25f5f72e17fd75.tar.gz
historical-6b080925ae1cd39b839598d11f25f5f72e17fd75.tar.bz2
historical-6b080925ae1cd39b839598d11f25f5f72e17fd75.zip
[kde-base/kalzium] Version bump to KDE SC 4.4.0
Package-Manager: portage-2.2_rc62/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/kalzium')
-rw-r--r--kde-base/kalzium/ChangeLog7
-rw-r--r--kde-base/kalzium/kalzium-4.4.0.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/kde-base/kalzium/ChangeLog b/kde-base/kalzium/ChangeLog
index 739324b4f4e5..7be04cb05b8c 100644
--- a/kde-base/kalzium/ChangeLog
+++ b/kde-base/kalzium/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kalzium
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.156 2010/01/25 14:28:55 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.157 2010/02/09 00:19:04 alexxy Exp $
+
+*kalzium-4.4.0 (08 Feb 2010)
+
+ 08 Feb 2010; Alexey Shvetsov <alexxy@gentoo.org> +kalzium-4.4.0.ebuild:
+ Version bump to KDE SC 4.4.0
*kalzium-4.3.5 (25 Jan 2010)
diff --git a/kde-base/kalzium/kalzium-4.4.0.ebuild b/kde-base/kalzium/kalzium-4.4.0.ebuild
new file mode 100644
index 000000000000..3fdc0f99d904
--- /dev/null
+++ b/kde-base/kalzium/kalzium-4.4.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/kalzium-4.4.0.ebuild,v 1.1 2010/02/09 00:19:04 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdeedu"
+CPPUNIT_REQUIRED="optional"
+OPENGL_REQUIRED="always"
+inherit flag-o-matic kde4-meta
+
+DESCRIPTION="KDE: periodic table of the elements."
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="editor debug +handbook +plasma solver"
+
+RDEPEND="
+ $(add_kdebase_dep libkdeedu)
+ editor? ( >=sci-chemistry/openbabel-2.2 )
+"
+DEPEND="${RDEPEND}
+ editor? ( >=dev-cpp/eigen-2.0.3:2 )
+ solver? ( dev-ml/facile[ocamlopt] )
+"
+
+KMEXTRACTONLY="
+ libkdeedu/kdeeduui/
+ libkdeedu/libscience/
+"
+
+src_configure(){
+ # Fix missing finite()
+ [[ ${CHOST} == *-solaris* ]] && append-cppflags -DHAVE_IEEEFP_H
+
+ mycmakeargs=(
+ $(cmake-utils_use_with editor Eigen2)
+ $(cmake-utils_use_with editor OpenBabel2)
+ $(cmake-utils_use_with editor OpenGL)
+ $(cmake-utils_use_with solver OCaml)
+ $(cmake-utils_use_with solver Libfacile)
+ )
+
+ kde4-meta_src_configure
+}