summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-05-07 10:48:07 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-05-07 10:48:07 +0000
commit4816953d7b880b98d593a026f8417178af0c61d9 (patch)
treef2e62f96dd734dff956565c230831b7cc368b4f5 /kde-base/phonon-kde
parentVersion bump. Remove intermediate version. (diff)
downloadhistorical-4816953d7b880b98d593a026f8417178af0c61d9.tar.gz
historical-4816953d7b880b98d593a026f8417178af0c61d9.tar.bz2
historical-4816953d7b880b98d593a026f8417178af0c61d9.zip
Version bump to KDE SC 4.6.3.
Package-Manager: portage-2.2.0_alpha31/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/phonon-kde')
-rw-r--r--kde-base/phonon-kde/ChangeLog8
-rw-r--r--kde-base/phonon-kde/phonon-kde-4.6.3.ebuild38
2 files changed, 45 insertions, 1 deletions
diff --git a/kde-base/phonon-kde/ChangeLog b/kde-base/phonon-kde/ChangeLog
index 5813f3783995..110818e30802 100644
--- a/kde-base/phonon-kde/ChangeLog
+++ b/kde-base/phonon-kde/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/phonon-kde
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/ChangeLog,v 1.78 2011/04/06 14:19:00 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/ChangeLog,v 1.79 2011/05/07 10:47:45 scarabeus Exp $
+
+*phonon-kde-4.6.3 (07 May 2011)
+
+ 07 May 2011; Tomáš Chvátal <scarabeus@gentoo.org>
+ +phonon-kde-4.6.3.ebuild:
+ Version bump KDE SC 4.6.3
*phonon-kde-4.6.2 (06 Apr 2011)
diff --git a/kde-base/phonon-kde/phonon-kde-4.6.3.ebuild b/kde-base/phonon-kde/phonon-kde-4.6.3.ebuild
new file mode 100644
index 000000000000..2cd880701e9d
--- /dev/null
+++ b/kde-base/phonon-kde/phonon-kde-4.6.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/phonon-kde-4.6.3.ebuild,v 1.1 2011/05/07 10:47:45 scarabeus Exp $
+
+EAPI=4
+
+KMNAME="kdebase-runtime"
+KMMODULE="phonon"
+inherit kde4-meta
+
+DESCRIPTION="Phonon KDE Integration"
+HOMEPAGE="http://phonon.kde.org"
+
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-2"
+IUSE="alsa debug xine pulseaudio"
+
+DEPEND="
+ >=media-libs/phonon-4.4.3[xine?]
+ alsa? ( media-libs/alsa-lib )
+ pulseaudio? (
+ dev-libs/glib:2
+ media-libs/libcanberra
+ >=media-sound/pulseaudio-0.9.21[glib]
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ -DBUILD_tests=OFF
+ $(cmake-utils_use_with alsa)
+ $(cmake-utils_use_with xine)
+ $(cmake-utils_use_with pulseaudio PulseAudio)
+ )
+
+ kde4-meta_src_configure
+}