summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando J. Pereda <ferdy@gentoo.org>2005-08-21 10:39:30 +0000
committerFernando J. Pereda <ferdy@gentoo.org>2005-08-21 10:39:30 +0000
commit32fa941e59792a42aad7386f765bd4970903412b (patch)
treed3330f9fd68283ad49504703d855f4538e546d9e /mail-client/hap
parentAdded patch to fix build when inotify is not enabled (from gamin CVS). (diff)
downloadhistorical-32fa941e59792a42aad7386f765bd4970903412b.tar.gz
historical-32fa941e59792a42aad7386f765bd4970903412b.tar.bz2
historical-32fa941e59792a42aad7386f765bd4970903412b.zip
fix to use our CFLAGS and fix to not use libtermcap wrt bug #103105
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'mail-client/hap')
-rw-r--r--mail-client/hap/ChangeLog7
-rw-r--r--mail-client/hap/Manifest16
-rw-r--r--mail-client/hap/files/digest-hap-3.7-r11
-rw-r--r--mail-client/hap/hap-3.7-r1.ebuild41
4 files changed, 62 insertions, 3 deletions
diff --git a/mail-client/hap/ChangeLog b/mail-client/hap/ChangeLog
index 6748cde5b4b9..a4912576b466 100644
--- a/mail-client/hap/ChangeLog
+++ b/mail-client/hap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-client/hap
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/hap/ChangeLog,v 1.5 2005/06/05 11:50:54 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/hap/ChangeLog,v 1.6 2005/08/21 10:39:30 ferdy Exp $
+
+*hap-3.7-r1 (21 Aug 2005)
+
+ 21 Aug 2005; Fernando J. Pereda <ferdy@gentoo.org> +hap-3.7-r1.ebuild:
+ fix to use our CFLAGS and fix to not use libtermcap wrt bug #103105
05 Jun 2005; Michael Hanselmann <hansmi@gentoo.org> hap-3.7.ebuild:
Stable on ppc.
diff --git a/mail-client/hap/Manifest b/mail-client/hap/Manifest
index 7750f9368e48..133c2fde7c7f 100644
--- a/mail-client/hap/Manifest
+++ b/mail-client/hap/Manifest
@@ -1,4 +1,16 @@
-MD5 5721b86fd871bdfab77231abc6e02f68 metadata.xml 161
-MD5 cbc7978d47124c844d7b2bb0a0574c11 ChangeLog 741
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 0b96463303938dd4cca4694543b032ec hap-3.7-r1.ebuild 1064
MD5 b8fa173f8d1d2d70065486fa30fa54c1 hap-3.7.ebuild 757
+MD5 a41036208e24bcd75211459876f5e4f8 ChangeLog 911
+MD5 5721b86fd871bdfab77231abc6e02f68 metadata.xml 161
+MD5 0b5f7cdf64358d836c97b3546454a8fa files/digest-hap-3.7-r1 56
MD5 0b5f7cdf64358d836c97b3546454a8fa files/digest-hap-3.7 56
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFDCFoJViELBEf1JB0RAr3pAJ415ZvZoc72xOlNqs1tcrTjWE5DVQCZAXF4
+HqB+S4SJe+t9NyNsfSG9w4o=
+=Jr+h
+-----END PGP SIGNATURE-----
diff --git a/mail-client/hap/files/digest-hap-3.7-r1 b/mail-client/hap/files/digest-hap-3.7-r1
new file mode 100644
index 000000000000..d21f61a5f3a5
--- /dev/null
+++ b/mail-client/hap/files/digest-hap-3.7-r1
@@ -0,0 +1 @@
+MD5 8494f766bc8374ddd75e3987db4f0b88 hap-3.7.tar 194560
diff --git a/mail-client/hap/hap-3.7-r1.ebuild b/mail-client/hap/hap-3.7-r1.ebuild
new file mode 100644
index 000000000000..028346e73f83
--- /dev/null
+++ b/mail-client/hap/hap-3.7-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/hap/hap-3.7-r1.ebuild,v 1.1 2005/08/21 10:39:30 ferdy Exp $
+
+IUSE=""
+
+DESCRIPTION="A terminal mail notification program (replacement for biff)"
+HOMEPAGE="http://www.transbay.net/~enf/sw.html"
+SRC_URI="http://www.transbay.net/~enf/hap-3.7.tar"
+
+DEPEND="sys-libs/ncurses
+ sys-devel/autoconf"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~ppc ~x86"
+
+# untars to 'hap/'
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ # Fix configure to use ncurses instead of termcap (bug #103105)
+ sed -i -e '/AC_CHECK_LIB/s~termcap~ncurses~' configure.in
+
+ # Fix Makefile.in to use our CFLAGS
+ sed -i -e "/^CFLAGS=-O/s//CFLAGS=${CFLAGS}/" Makefile.in
+
+ # Rebuild the compilation framework
+ autoconf || die "autoconf failed"
+
+ # The configure script doesn't like --mandir etc., so we call it directly
+ # rather than via econf
+ ./configure || die "configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin hap
+ doman hap.1
+}