summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-26 14:05:29 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-26 14:05:29 +0000
commit9a7974babfcf1139115711d5ae80d94ebd6627b4 (patch)
treed7441692363485a560c878ec1a27237f60b89e16 /media-libs/gd
parentold (diff)
downloadhistorical-9a7974babfcf1139115711d5ae80d94ebd6627b4.tar.gz
historical-9a7974babfcf1139115711d5ae80d94ebd6627b4.tar.bz2
historical-9a7974babfcf1139115711d5ae80d94ebd6627b4.zip
use $(tc-getCC)
Diffstat (limited to 'media-libs/gd')
-rw-r--r--media-libs/gd/gd-1.8.4-r2.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/media-libs/gd/gd-1.8.4-r2.ebuild b/media-libs/gd/gd-1.8.4-r2.ebuild
index 33327d8f412e..5462f575680d 100644
--- a/media-libs/gd/gd-1.8.4-r2.ebuild
+++ b/media-libs/gd/gd-1.8.4-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gd/gd-1.8.4-r2.ebuild,v 1.1 2004/06/30 15:51:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gd/gd-1.8.4-r2.ebuild,v 1.2 2004/10/26 14:02:44 vapier Exp $
-inherit eutils gcc
+inherit eutils toolchain-funcs
DESCRIPTION="A graphics library for fast image creation"
HOMEPAGE="http://www.boutell.com/gd/"
@@ -30,7 +30,7 @@ src_unpack() {
local incopts
use alpha \
- && [ "$(gcc-getCC)" == "ccc" ] \
+ && [ "$(tc-getCC)" == "ccc" ] \
&& epatch ${FILESDIR}/${PV}-dec-alpha-compiler.diff
use X \
@@ -58,7 +58,7 @@ src_unpack() {
-e "s:^\(CFLAGS\)=.*:\1=${CFLAGS} ${compopts} :" \
-e "s:^\(LIBS\)=.*:\1=-lm -lgd -lz ${libsopts}:" \
-e "s:^\(INCLUDEDIRS\)=:\1=${incopts} :" \
- -e "s:\(COMPILER=\)gcc:\1${CC:-gcc}:" \
+ -e "s:\(COMPILER=\)gcc:\1$(tc-getCC):" \
Makefile || die
}