summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-26 07:36:33 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-26 07:36:33 +0000
commitdbf72794f794bc390e67988072cecf04e64f4267 (patch)
treee6d11b17ed8ef31852c41104d8a2e7207719bf04 /media-libs/gltt
parentUpdated to version 1.11.2 (diff)
downloadhistorical-dbf72794f794bc390e67988072cecf04e64f4267.tar.gz
historical-dbf72794f794bc390e67988072cecf04e64f4267.tar.bz2
historical-dbf72794f794bc390e67988072cecf04e64f4267.zip
installing header files in correct location
Diffstat (limited to 'media-libs/gltt')
-rw-r--r--media-libs/gltt/ChangeLog11
-rw-r--r--media-libs/gltt/files/digest-gltt-2.5.2-r11
-rw-r--r--media-libs/gltt/gltt-2.5.2-r1.ebuild36
3 files changed, 47 insertions, 1 deletions
diff --git a/media-libs/gltt/ChangeLog b/media-libs/gltt/ChangeLog
index 6de51eb6d4d0..e9bc627ca383 100644
--- a/media-libs/gltt/ChangeLog
+++ b/media-libs/gltt/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-libs/gltt
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gltt/ChangeLog,v 1.1 2002/02/01 21:53:30 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gltt/ChangeLog,v 1.2 2002/04/26 07:36:33 seemant Exp $
+
+*gltt-2.5.2-r1 (26 Apr 2002)
+
+ 26 Apr 2002; Seemant Kulleen <seemant@gentoo.org> gltt-2.5.2-r1.ebuild
+ files/digest-gltt-2.5.2-r1 :
+
+ Changed DESTDIR to point to ${D} instead of ${D}/usr so that include files
+ are installed in /usr/include instead of /usr/usr/include. This closes bug
+ # 2114 by fraterm@io.com (Michael S Costello (MiscRat))
*gltt-2.5.2 (1 Feb 2002)
diff --git a/media-libs/gltt/files/digest-gltt-2.5.2-r1 b/media-libs/gltt/files/digest-gltt-2.5.2-r1
new file mode 100644
index 000000000000..d5b4031ef967
--- /dev/null
+++ b/media-libs/gltt/files/digest-gltt-2.5.2-r1
@@ -0,0 +1 @@
+MD5 1098121fc2b2e66ba0cbc979c1e7d21c gltt-2.5.2.tar.gz 217332
diff --git a/media-libs/gltt/gltt-2.5.2-r1.ebuild b/media-libs/gltt/gltt-2.5.2-r1.ebuild
new file mode 100644
index 000000000000..fc08a3f4d51a
--- /dev/null
+++ b/media-libs/gltt/gltt-2.5.2-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gltt/gltt-2.5.2-r1.ebuild,v 1.1 2002/04/26 07:36:33 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GL truetype library"
+SRC_URI="http://gltt.sourceforge.net/download/${P}.tar.gz"
+HOMEPAGE="http://gltt.sourceforge.net/"
+
+DEPEND="virtual/glibc
+ virtual/opengl
+ virtual/glut
+ virtual/x11
+ >=media-libs/freetype-1.3.1"
+
+RDEPEND="$DEPEND"
+
+src_compile() {
+
+ ./configure \
+ --with-x \
+ --prefix=/usr \
+ --with-ttf-dir=/usr || die
+
+ make || die
+
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README
+
+}