summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-04-18 21:16:38 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-04-18 21:16:38 +0000
commit5a29a9d36e345aa4e90d365f85e02cdd569939bb (patch)
treee6fe8274dc4261fc2fc45cae1e9e0cace9c47d03 /media-libs/libmad
parentVersion bump (diff)
downloadhistorical-5a29a9d36e345aa4e90d365f85e02cdd569939bb.tar.gz
historical-5a29a9d36e345aa4e90d365f85e02cdd569939bb.tar.bz2
historical-5a29a9d36e345aa4e90d365f85e02cdd569939bb.zip
Revision bump to drop libtool .la files.
Package-Manager: portage-2.1.5_rc4
Diffstat (limited to 'media-libs/libmad')
-rw-r--r--media-libs/libmad/ChangeLog10
-rw-r--r--media-libs/libmad/libmad-0.15.1b-r5.ebuild67
2 files changed, 75 insertions, 2 deletions
diff --git a/media-libs/libmad/ChangeLog b/media-libs/libmad/ChangeLog
index 964e1fc06584..99be863263f7 100644
--- a/media-libs/libmad/ChangeLog
+++ b/media-libs/libmad/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/libmad
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libmad/ChangeLog,v 1.53 2007/08/06 20:26:40 dirtyepic Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmad/ChangeLog,v 1.54 2008/04/18 21:14:50 flameeyes Exp $
+
+*libmad-0.15.1b-r5 (18 Apr 2008)
+
+ 18 Apr 2008; Diego Pettenò <flameeyes@gentoo.org>
+ +libmad-0.15.1b-r5.ebuild:
+ Revision bump to drop libtool .la files.
*libmad-0.15.1b-r4 (06 Aug 2007)
diff --git a/media-libs/libmad/libmad-0.15.1b-r5.ebuild b/media-libs/libmad/libmad-0.15.1b-r5.ebuild
new file mode 100644
index 000000000000..1f4b8309cd5f
--- /dev/null
+++ b/media-libs/libmad/libmad-0.15.1b-r5.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmad/libmad-0.15.1b-r5.ebuild,v 1.1 2008/04/18 21:14:50 flameeyes Exp $
+
+inherit eutils autotools libtool flag-o-matic
+
+DESCRIPTION="\"M\"peg \"A\"udio \"D\"ecoder library"
+HOMEPAGE="http://mad.sourceforge.net"
+SRC_URI="mirror://sourceforge/mad/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug"
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/libmad-0.15.1b-cflags.patch"
+ epatch "${FILESDIR}/libmad-0.15.1b-cflags-O2.patch"
+
+ eautoreconf
+
+ elibtoolize
+ epunt_cxx #74490
+}
+
+src_compile() {
+ local myconf="--enable-accuracy"
+ # --enable-speed optimize for speed over accuracy
+ # --enable-accuracy optimize for accuracy over speed
+ # --enable-experimental enable code using the EXPERIMENTAL
+ # preprocessor define
+
+ # Fix for b0rked sound on sparc64 (maybe also sparc32?)
+ # default/approx is also possible, uses less cpu but sounds worse
+ use sparc && myconf="${myconf} --enable-fpm=64bit"
+
+ [[ $(tc-arch) == "amd64" ]] && myconf="${myconf} --enable-fpm=64bit"
+ [[ $(tc-arch) == "x86" ]] && myconf="${myconf} --enable-fpm=intel"
+ [[ $(tc-arch) == "ppc" ]] && myconf="${myconf} --enable-fpm=ppc"
+ [[ $(tc-arch) == "ppc64" ]] && myconf="${myconf} --enable-fpm=64bit"
+
+ econf \
+ $(use_enable debug debugging) \
+ ${myconf} || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "make install failed"
+
+ dodoc CHANGES CREDITS README TODO VERSION
+
+ # This file must be updated with each version update
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins "${FILESDIR}"/mad.pc
+
+ # Use correct libdir in pkgconfig file
+ dosed "s:^libdir.*:libdir=/usr/$(get_libdir):" \
+ /usr/$(get_libdir)/pkgconfig/mad.pc
+
+ find "${D}" -name '*.la' -delete
+}