summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-02-02 07:58:53 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-02-02 07:58:53 +0000
commit8066cf18bbea0a9db3b5a6b86402555010ce094c (patch)
treeee52cde1b919a43df088e8501407b38ef5d5aded /media-libs/smpeg
parentUpdating avidemux mask reason (diff)
downloadhistorical-8066cf18bbea0a9db3b5a6b86402555010ce094c.tar.gz
historical-8066cf18bbea0a9db3b5a6b86402555010ce094c.tar.bz2
historical-8066cf18bbea0a9db3b5a6b86402555010ce094c.zip
stop installing the gtk1 player (bug 161077)
Package-Manager: portage-2.1.1-r2
Diffstat (limited to 'media-libs/smpeg')
-rw-r--r--media-libs/smpeg/ChangeLog8
-rw-r--r--media-libs/smpeg/files/digest-smpeg-0.4.4-r96
-rw-r--r--media-libs/smpeg/smpeg-0.4.4-r9.ebuild71
3 files changed, 84 insertions, 1 deletions
diff --git a/media-libs/smpeg/ChangeLog b/media-libs/smpeg/ChangeLog
index 0b471d775410..8e3847e6dac4 100644
--- a/media-libs/smpeg/ChangeLog
+++ b/media-libs/smpeg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/smpeg
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/smpeg/ChangeLog,v 1.47 2007/01/09 09:28:03 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/smpeg/ChangeLog,v 1.48 2007/02/02 07:58:53 mr_bones_ Exp $
+
+*smpeg-0.4.4-r9 (02 Feb 2007)
+
+ 02 Feb 2007; Michael Sterrett <mr_bones_@gentoo.org>
+ -smpeg-0.4.4-r6.ebuild, -smpeg-0.4.4-r7.ebuild, +smpeg-0.4.4-r9.ebuild:
+ stop installing the gtk1 player (bug 161077)
09 Jan 2007; Michael Sterrett <mr_bones_@gentoo.org>
+files/smpeg-0.4.4-missing-init.patch, smpeg-0.4.4-r8.ebuild:
diff --git a/media-libs/smpeg/files/digest-smpeg-0.4.4-r9 b/media-libs/smpeg/files/digest-smpeg-0.4.4-r9
new file mode 100644
index 000000000000..d97b5615ed6a
--- /dev/null
+++ b/media-libs/smpeg/files/digest-smpeg-0.4.4-r9
@@ -0,0 +1,6 @@
+MD5 49c7a926f4e841590ea7a9305c42bced smpeg-0.4.4-gtkm4.patch.bz2 3894
+RMD160 fbef70da1b1a9f5d482c9506286c9f8e7ce764d8 smpeg-0.4.4-gtkm4.patch.bz2 3894
+SHA256 85c1c2126bd0e405092f3f08caace3503997fd0447989fdd175c7f39c3f6091b smpeg-0.4.4-gtkm4.patch.bz2 3894
+MD5 59c76ac704088ef5539210190c4e1fe3 smpeg-0.4.4.tar.gz 315054
+RMD160 d55249ad53417fa0df3d925aed0e83d2204e28b7 smpeg-0.4.4.tar.gz 315054
+SHA256 1efa7984d0aada0c2954cd0aaef357e9d7871dadd3368dbe742ab5f260523e57 smpeg-0.4.4.tar.gz 315054
diff --git a/media-libs/smpeg/smpeg-0.4.4-r9.ebuild b/media-libs/smpeg/smpeg-0.4.4-r9.ebuild
new file mode 100644
index 000000000000..9a50409f2e4b
--- /dev/null
+++ b/media-libs/smpeg/smpeg-0.4.4-r9.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/smpeg/smpeg-0.4.4-r9.ebuild,v 1.1 2007/02/02 07:58:53 mr_bones_ Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+inherit eutils toolchain-funcs autotools
+
+DESCRIPTION="SDL MPEG Player Library"
+HOMEPAGE="http://www.lokigames.com/development/smpeg.php3"
+SRC_URI="ftp://ftp.lokigames.com/pub/open-source/smpeg/${P}.tar.gz
+ mirror://gentoo/${P}-gtkm4.patch.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="X debug mmx opengl"
+
+DEPEND=">=media-libs/libsdl-1.2.0
+ opengl? (
+ virtual/opengl
+ virtual/glu )
+ X? (
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libX11
+ )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-m4.patch \
+ "${FILESDIR}"/${P}-gnu-stack.patch \
+ "${FILESDIR}"/${P}-config.patch \
+ "${FILESDIR}"/${P}-PIC.patch \
+ "${FILESDIR}"/${P}-gcc41.patch \
+ "${FILESDIR}"/${P}-flags.patch \
+ "${FILESDIR}"/${P}-automake.patch \
+ "${FILESDIR}"/${P}-mmx.patch \
+ "${FILESDIR}"/${P}-malloc.patch \
+ "${FILESDIR}"/${P}-missing-init.patch
+
+ cd "${WORKDIR}"
+ epatch "${DISTDIR}"/${P}-gtkm4.patch.bz2
+ rm "${S}/acinclude.m4"
+
+ cd "${S}"
+ AT_M4DIR="${S}/m4" eautoreconf
+}
+
+src_compile() {
+ tc-export CC CXX RANLIB AR
+
+ # the debug option is bogus ... all it does is add extra
+ # optimizations if you pass --disable-debug
+ econf \
+ --enable-debug \
+ --disable-gtk-player \
+ $(use_enable debug assertions) \
+ $(use_with X x) \
+ $(use_enable opengl opengl-player) \
+ $(use_enable mmx) \
+ || die
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc CHANGES README* TODO
+}