summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Romans <killsoft@gentoo.org>2004-10-01 23:13:15 +0000
committerRob Romans <killsoft@gentoo.org>2004-10-01 23:13:15 +0000
commit8d900d11504fba0577608f10901ecd600163bc4d (patch)
tree15f28148e427efba1f9c03ba5e94f9d9941bc3f2 /media-radio
parentAdded ebuild for 2.6.8.1 headers that includes some statfs fixes needed for n... (diff)
downloadhistorical-8d900d11504fba0577608f10901ecd600163bc4d.tar.gz
historical-8d900d11504fba0577608f10901ecd600163bc4d.tar.bz2
historical-8d900d11504fba0577608f10901ecd600163bc4d.zip
new version. bug 64351
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/xlog/ChangeLog20
-rw-r--r--media-radio/xlog/Manifest4
-rw-r--r--media-radio/xlog/files/digest-xlog-0.9.71
-rw-r--r--media-radio/xlog/xlog-0.9.7.ebuild35
4 files changed, 58 insertions, 2 deletions
diff --git a/media-radio/xlog/ChangeLog b/media-radio/xlog/ChangeLog
index 4f3348a19aec..9e545d2d83a0 100644
--- a/media-radio/xlog/ChangeLog
+++ b/media-radio/xlog/ChangeLog
@@ -1,6 +1,24 @@
# ChangeLog for media-radio/xlog
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/xlog/ChangeLog,v 1.4 2004/08/04 23:18:38 killsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-radio/xlog/ChangeLog,v 1.5 2004/10/01 23:13:15 killsoft Exp $
+
+*xlog-0.9.7 (01 Oct 2004)
+
+ 01 Oct 2004; Robb Romans <killsoft@gentoo.org> +xlog-0.9.7.ebuild:
+ New version, thanks to Douglas Gallup for the contribution.
+ Closes bug 64351
+
+ Changes for xlog version 0.9.7
+ * A fix by Nigel Horne, G0LOV for a NULL pointer deref in dxcc.c, which would
+ cause crashes on some architectures. Thanks!
+ * xlog will now also build with older libgnomeprint versions.
+ * The ChangeLog is now included in the help menu and the xlog data directory.
+ * When importing from trlog, the date is converted to your current locale.
+ * If there is a comment in a trlog file (lines starting with ';'), it will
+ be imported and added to the remarks field.
+ * Another printing fix. People on redhat have been reporting overlapping
+ columns, a new way of column width calculation fixes this. Thanks to Tomi,
+ OH2BNS and Alex, OZ9AEC for testing.
04 Aug 2004; Robb Romans <killsoft@gentoo.org> xlog-0.9.6.ebuild:
Mark stable on x86.
diff --git a/media-radio/xlog/Manifest b/media-radio/xlog/Manifest
index 74fd30e710d0..ef198f469c5c 100644
--- a/media-radio/xlog/Manifest
+++ b/media-radio/xlog/Manifest
@@ -1,4 +1,6 @@
-MD5 1ec53727db955bf3cf678bf7fbf48987 ChangeLog 654
+MD5 379fc75b6c3f7c5a42cf8a255dfccd80 ChangeLog 1558
MD5 28d0c3bb6c80425620241cff231da8d3 metadata.xml 224
+MD5 7f22c9601d19e249584989b2cf9fff3e xlog-0.9.7.ebuild 830
MD5 d8b2f26f31a931bb88e33404e4fe61ed xlog-0.9.6.ebuild 831
+MD5 d0afee6be83642f398db70c755d275c8 files/digest-xlog-0.9.7 63
MD5 4a19ffcb3c1423a645b3c135e94fca43 files/digest-xlog-0.9.6 63
diff --git a/media-radio/xlog/files/digest-xlog-0.9.7 b/media-radio/xlog/files/digest-xlog-0.9.7
new file mode 100644
index 000000000000..3764f9c1483f
--- /dev/null
+++ b/media-radio/xlog/files/digest-xlog-0.9.7
@@ -0,0 +1 @@
+MD5 d9ac2c74372ae822f064f8d519202d6f xlog-0.9.7.tar.gz 3162565
diff --git a/media-radio/xlog/xlog-0.9.7.ebuild b/media-radio/xlog/xlog-0.9.7.ebuild
new file mode 100644
index 000000000000..c395c092677a
--- /dev/null
+++ b/media-radio/xlog/xlog-0.9.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-radio/xlog/xlog-0.9.7.ebuild,v 1.1 2004/10/01 23:13:15 killsoft Exp $
+
+inherit eutils
+
+DESCRIPTION="GTK+ Amateur Radio logging program"
+HOMEPAGE="http://www.qsl.net/pg4i/linux/xlog.html"
+SRC_URI="http://www.qsl.net/pg4i/download/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="x86 ~ppc"
+IUSE=""
+
+RDEPEND="virtual/libc
+ virtual/x11
+ >=gnome-base/libgnomeprint-2.4.0
+ >=x11-libs/gtk+-2.4.0-r1
+ media-libs/hamlib"
+
+DEPEND="sys-devel/libtool
+ >=app-doc/doxygen-1.3.5-r1
+ >=dev-util/pkgconfig-0.12.0"
+
+src_compile() {
+ econf --enable-hamlib \
+ || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die
+ make_desktop_entry xlog XLog xlog.xpm HamRadio
+}