summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrank van de Pol <fvdpol@gentoo.org>2004-06-18 22:17:33 +0000
committerFrank van de Pol <fvdpol@gentoo.org>2004-06-18 22:17:33 +0000
commit17f8a2ac24db593e62654afe8878dac66b554a37 (patch)
tree2b57c7ef34021dff1e4f2842ed0af90d0a4bdf12 /media-sound
parent~amd64 (diff)
downloadhistorical-17f8a2ac24db593e62654afe8878dac66b554a37.tar.gz
historical-17f8a2ac24db593e62654afe8878dac66b554a37.tar.bz2
historical-17f8a2ac24db593e62654afe8878dac66b554a37.zip
First ebuild for timemachine, thanks to Toni Arnold <toni__arnold@bluewin.ch>. Closing bug #52555.
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/timemachine/ChangeLog15
-rw-r--r--media-sound/timemachine/Manifest5
-rw-r--r--media-sound/timemachine/files/digest-timemachine-0.2.41
-rw-r--r--media-sound/timemachine/files/timemachine-0.2.4-ladcca-compile.patch27
-rw-r--r--media-sound/timemachine/metadata.xml12
-rw-r--r--media-sound/timemachine/timemachine-0.2.4.ebuild35
6 files changed, 95 insertions, 0 deletions
diff --git a/media-sound/timemachine/ChangeLog b/media-sound/timemachine/ChangeLog
new file mode 100644
index 000000000000..6c30397a4e50
--- /dev/null
+++ b/media-sound/timemachine/ChangeLog
@@ -0,0 +1,15 @@
+# ChangeLog for media-sound/timemachine
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/timemachine/ChangeLog,v 1.1 2004/06/18 22:17:33 fvdpol Exp $
+
+*timemachine-0.2.4 (19 Jun 2004)
+
+ 19 Jun 2004; Frank van de Pol <fvdpol@gentoo.org> +metadata.xml,
+ +files/timemachine-0.2.4-ladcca-compile.patch, +timemachine-0.2.4.ebuild:
+ The first version of this package. Timemachine is a simple
+ jack client record button remembering the last ten seconds
+ of audio when pressed.
+
+ Thanks to Toni Arnold <toni__arnold@bluewin.ch> for the ebuild.
+ Closes bug #52555.
+
diff --git a/media-sound/timemachine/Manifest b/media-sound/timemachine/Manifest
new file mode 100644
index 000000000000..22ffe4207ea6
--- /dev/null
+++ b/media-sound/timemachine/Manifest
@@ -0,0 +1,5 @@
+MD5 ddff2304137b2854c2a3fe16bba8e6be timemachine-0.2.4.ebuild 907
+MD5 2ea3a55dc8476a027082a9ae209a0d0d metadata.xml 361
+MD5 163a52d49fb983d7cc8140571eefa8ad ChangeLog 643
+MD5 d36266bdc7ee0e2f641a99ea0c9747dd files/timemachine-0.2.4-ladcca-compile.patch 478
+MD5 6411861e6d8dc62ff415049f9020aa72 files/digest-timemachine-0.2.4 69
diff --git a/media-sound/timemachine/files/digest-timemachine-0.2.4 b/media-sound/timemachine/files/digest-timemachine-0.2.4
new file mode 100644
index 000000000000..2692cb569169
--- /dev/null
+++ b/media-sound/timemachine/files/digest-timemachine-0.2.4
@@ -0,0 +1 @@
+MD5 55e0864eb7749c36b739cbc36d661526 timemachine-0.2.4.tar.gz 145027
diff --git a/media-sound/timemachine/files/timemachine-0.2.4-ladcca-compile.patch b/media-sound/timemachine/files/timemachine-0.2.4-ladcca-compile.patch
new file mode 100644
index 000000000000..5949e74838a9
--- /dev/null
+++ b/media-sound/timemachine/files/timemachine-0.2.4-ladcca-compile.patch
@@ -0,0 +1,27 @@
+--- timemachine-0.2.4.orig/src/main.c
++++ timemachine-0.2.4/src/main.c
+@@ -169,7 +169,9 @@
+
+ bind_meters();
+ g_timeout_add(100, meter_tick, NULL);
++#ifdef HAVE_LADCCA
+ gtk_idle_add(idle_cb, cca_client);
++#endif
+
+ gtk_main();
+
+@@ -197,6 +199,7 @@
+ exit(0);
+ }
+
++#ifdef HAVE_LADCCA
+ gboolean idle_cb(gpointer data)
+ {
+ cca_client_t *cca_client = (cca_client_t *)data;
+@@ -237,5 +240,6 @@
+
+ return TRUE;
+ }
++#endif
+
+ /* vi:set ts=8 sts=4 sw=4: */
diff --git a/media-sound/timemachine/metadata.xml b/media-sound/timemachine/metadata.xml
new file mode 100644
index 000000000000..c14c0fa0f347
--- /dev/null
+++ b/media-sound/timemachine/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+<maintainer>
+<email>fvdpol@gentoo.org</email>
+</maintainer>
+<longdescription>
+Timemachine is a simple jack client record button remembering the last ten
+seconds of audio when pressed.
+</longdescription>
+</pkgmetadata>
diff --git a/media-sound/timemachine/timemachine-0.2.4.ebuild b/media-sound/timemachine/timemachine-0.2.4.ebuild
new file mode 100644
index 000000000000..24aee8e4c058
--- /dev/null
+++ b/media-sound/timemachine/timemachine-0.2.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/timemachine/timemachine-0.2.4.ebuild,v 1.1 2004/06/18 22:17:33 fvdpol Exp $
+
+inherit flag-o-matic eutils
+DESCRIPTION="JACK client record button remembering the last 10 seconds when pressed."
+HOMEPAGE="http://plugin.org.uk/timemachine/"
+SRC_URI="http://plugin.org.uk/timemachine/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+IUSE="ladcca"
+
+DEPEND=">=media-sound/jack-audio-connection-kit-0.80.0
+ >=x11-libs/gtk+-2.2.4-r1
+ >=media-libs/libsndfile-1.0.5
+ ladcca? ( >=media-libs/ladcca-0.4.0 )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-ladcca-compile.patch
+}
+
+src_compile() {
+ econf `use_enable ladcca` || die
+ make || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ einstall || die
+}