summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2003-02-07 22:25:01 +0000
committerRyan Phillips <rphillips@gentoo.org>2003-02-07 22:25:01 +0000
commit6c678730012f3aac42410fa3e45e03cd172810f3 (patch)
tree2a461f7c0c3c9a48dd9893e5ba206749c0e3c890 /media-sound
parentnew version. ARCH masked (diff)
downloadhistorical-6c678730012f3aac42410fa3e45e03cd172810f3.tar.gz
historical-6c678730012f3aac42410fa3e45e03cd172810f3.tar.bz2
historical-6c678730012f3aac42410fa3e45e03cd172810f3.zip
new version. ARCH masked
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/zinf/ChangeLog7
-rw-r--r--media-sound/zinf/files/digest-zinf-2.2.31
-rw-r--r--media-sound/zinf/zinf-2.2.3.ebuild78
3 files changed, 85 insertions, 1 deletions
diff --git a/media-sound/zinf/ChangeLog b/media-sound/zinf/ChangeLog
index 06c78ec12ef4..9ca079680aec 100644
--- a/media-sound/zinf/ChangeLog
+++ b/media-sound/zinf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/zinf
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/zinf/ChangeLog,v 1.4 2002/12/06 17:02:31 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/zinf/ChangeLog,v 1.5 2003/02/07 22:25:01 rphillips Exp $
+
+*zinf-2.2.3 (07 Feb 2003)
+
+ 07 Feb 2003; Ryan Phillips <rphillips@gentoo.org> ChangeLog:
+ new version.
*zinf-2.2.1 (06 Dec 2002)
diff --git a/media-sound/zinf/files/digest-zinf-2.2.3 b/media-sound/zinf/files/digest-zinf-2.2.3
new file mode 100644
index 000000000000..b13ed4aaafbf
--- /dev/null
+++ b/media-sound/zinf/files/digest-zinf-2.2.3
@@ -0,0 +1 @@
+MD5 2eda6103c0287c7d4d591841e4898199 zinf-2.2.3.tar.gz 1412373
diff --git a/media-sound/zinf/zinf-2.2.3.ebuild b/media-sound/zinf/zinf-2.2.3.ebuild
new file mode 100644
index 000000000000..3f5a2fdf8fc2
--- /dev/null
+++ b/media-sound/zinf/zinf-2.2.3.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/zinf/zinf-2.2.3.ebuild,v 1.1 2003/02/07 22:25:01 rphillips Exp $
+
+IUSE="esd X gtk oggvorbis gnome"
+
+inherit kde-functions
+
+S=${WORKDIR}/${P}
+DESCRIPTION="An extremely full-featured mp3/vorbis/cd player with ALSA support, previously called FreeAmp"
+SRC_URI="http://telia.dl.sourceforge.net/sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.zinf.org/"
+
+RDEPEND="=dev-libs/glib-1.2*
+ =x11-libs/gtk+-1.2*
+ sys-libs/zlib
+ >=sys-libs/ncurses-5.2
+ =media-libs/freetype-1*
+ >=media-libs/musicbrainz-1.0.1
+ X? ( virtual/x11 )
+ esd? ( media-sound/esound )
+ gtk? ( >=media-libs/gdk-pixbuf-0.8 )
+ gnome? ( gnome-base/ORBit )
+ oggvorbis? ( media-libs/libvorbis )"
+ #arts? ( kde-base/arts ) # doesn't work anymore? see bug #9675
+ #alsa? ( media-libs/alsa-lib ) # it only supports alsa 0.5.x, so support disabled
+
+DEPEND="$RDEPEND x86? ( dev-lang/nasm )
+sys-devel/perl"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+# Unfortunately you can't selectively build a lot of the features. Therefore
+# this whole package is essentially a judgement call. However, I've made the
+# DEPEND in a strategic manner to ensure that your USE variable is respected
+# when the knobs are *set*.
+
+src_unpack() {
+
+ unpack ${A}
+
+# if [ "`use arts`" ]; then
+# cd ${S}/io/arts/src
+# cp artspmo.cpp 1
+# sed -e 's:artsc/artsc.h:artsc.h:g' 1 > artspmo.cpp
+# fi
+
+}
+
+src_compile() {
+
+ set-kdedir 3
+
+ local myconf
+ #use alsa ||
+ myconf="${myconf} --disable-alsa"
+ use esd || myconf="${myconf} --disable-esd"
+# use arts && export ARTSCCONFIG="$KDEDIR/bin/artsc-config" && myconf="${myconf} --with-extra-includes=${KDEDIR}/include --enable-arts" || \
+ myconf="$myconf --disable-arts"
+
+ ./configure --prefix=/usr --host=${CHOST} ${myconf} || die
+ make || die
+# use arts && ( CPATH=${KDEDIR}/include/artsc:${S}/io/arts/include make -f Makefile-plugins plugins/arts.pmo || die )
+
+}
+
+src_install() {
+
+ into /usr ; dobin zinf
+ exeinto /usr/lib/zinf/plugins ; doexe plugins/*
+ insinto /usr/share/zinf/themes ; doins themes/*
+ dodir /usr/share/zinf/fonts
+
+ dodoc AUTHORS CHANGES COPYING NEWS README README.linux
+
+}