summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Mylchreest <johnm@gentoo.org>2003-07-09 00:08:22 +0000
committerJohn Mylchreest <johnm@gentoo.org>2003-07-09 00:08:22 +0000
commitd1555ac9e00f446d3627510debd2a4f0d917d50d (patch)
tree6e333a74bca6d4372773fd44dbc4c4a7553eeae3 /media-tv
parentinitial check-in (diff)
downloadhistorical-d1555ac9e00f446d3627510debd2a4f0d917d50d.tar.gz
historical-d1555ac9e00f446d3627510debd2a4f0d917d50d.tar.bz2
historical-d1555ac9e00f446d3627510debd2a4f0d917d50d.zip
initial check-in
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/mythtv/Manifest8
-rw-r--r--media-tv/mythtv/files/digest-mythtv-0.101
-rw-r--r--media-tv/mythtv/files/mythbackend.conf23
-rw-r--r--media-tv/mythtv/files/mythbackend.rc656
-rw-r--r--media-tv/mythtv/files/mythfilldatabase.cron4
-rw-r--r--media-tv/mythtv/mythtv-0.10.ebuild117
-rw-r--r--media-tv/xmltv/ChangeLog75
-rw-r--r--media-tv/xmltv/Manifest2
-rw-r--r--media-tv/xmltv/xmltv-0.5.14.ebuild184
9 files changed, 466 insertions, 4 deletions
diff --git a/media-tv/mythtv/Manifest b/media-tv/mythtv/Manifest
index 3cc5ede9384c..234dce4f9fba 100644
--- a/media-tv/mythtv/Manifest
+++ b/media-tv/mythtv/Manifest
@@ -1,6 +1,6 @@
-MD5 d3a6bbe930485c5564b49f7cb8ce897f ChangeLog 2683
-MD5 93839304c75bb767c628465486bbd226 mythtv-0.10.ebuild 3036
-MD5 790d2d5812512ad990db10a0e3c97d9d files/mythbackend.conf 858
-MD5 b2e751160af5ec63a2a762ca246def1f files/mythbackend.rc6 1661
+MD5 02ef526f5ea6f99aac46e233c3d36881 ChangeLog 2692
+MD5 51592cc8ddf7a7abc7b6ca362b752c6b mythtv-0.10.ebuild 3045
+MD5 ce8c4dae21199ea11abd156b16cc3b8a files/mythbackend.conf 867
+MD5 897368570b822b7a42c9693e16f1f052 files/mythbackend.rc6 1670
MD5 e14a28e72b9ac693884dc418dbeef119 files/digest-mythtv-0.10 65
MD5 b3a4780890d53640604812b8069a8297 files/mythfilldatabase.cron 74
diff --git a/media-tv/mythtv/files/digest-mythtv-0.10 b/media-tv/mythtv/files/digest-mythtv-0.10
new file mode 100644
index 000000000000..6fbdb3de9d4c
--- /dev/null
+++ b/media-tv/mythtv/files/digest-mythtv-0.10
@@ -0,0 +1 @@
+MD5 3e6dad28e1c25929ceb124ad7d0a3d0b mythtv-0.10.tar.bz2 2466640
diff --git a/media-tv/mythtv/files/mythbackend.conf b/media-tv/mythtv/files/mythbackend.conf
new file mode 100644
index 000000000000..44ee86fbec66
--- /dev/null
+++ b/media-tv/mythtv/files/mythbackend.conf
@@ -0,0 +1,23 @@
+# Copyright 2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/files/mythbackend.conf,v 1.1 2003/07/09 00:05:43 johnm Exp $
+
+# Uncomment this to disable the permission warnings.
+MYTH_WARN=yes
+
+# Specify which user to run as
+#
+# NOTE: this user must have permissions to write
+# to the LOG and PID directories specified
+# below. Furthermore, this user must be able
+# to write to the audio and video devices
+# that are configured in MythTV. This can
+# be achieved by adding this user to the
+# audio and video groups.
+MYTH_USER=root
+
+# Specify which file to use for the backend log.
+MYTH_LOG=/var/log/mythtv/mythbackend.log
+
+# Specify in which file to store the backend process id.
+MYTH_PID=/var/run/mythtv/mythbackend.pid
diff --git a/media-tv/mythtv/files/mythbackend.rc6 b/media-tv/mythtv/files/mythbackend.rc6
new file mode 100644
index 000000000000..3eaa74ebfe68
--- /dev/null
+++ b/media-tv/mythtv/files/mythbackend.rc6
@@ -0,0 +1,56 @@
+#!/sbin/runscript
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/files/mythbackend.rc6,v 1.1 2003/07/09 00:05:43 johnm Exp $
+
+depend() {
+ need net
+ use mysql
+}
+
+checkconfig() {
+ for i in $(groups "${MYTH_USER/:*/}") ; do
+ [ "${i}" = "audio" ] && audio="yes"
+ [ "${i}" = "video" ] && video="yes"
+ done
+
+ if [ -z "${audio}" -o -z "${video}" ] ; then
+ ewarn ""
+ [ -z "${audio}" ] && \
+ ewarn "${HILITE}${MYTH_USER/:*/}${NORMAL} is not in the audio group"
+ [ -z "${video}" ] && \
+ ewarn "${HILITE}${MYTH_USER/:*/}${NORMAL} is not in the video group"
+ ewarn ""
+ ewarn "insufficient permissions discovered"
+ ewarn "mythbackend may not start correctly"
+ ewarn ""
+ fi
+}
+
+start() {
+ [ -z "${MYTH_USER}" ] && MYTH_USER="nobody:nobody"
+ [ -z "${MYTH_LOG}" ] && MYTH_LOG="/var/log/mythtv/mythbackend.log"
+ [ -z "${MYTH_PID}" ] && MYTH_PID="/var/run/mythtv/mythbackend.pid"
+ [ -z "${MYTH_WARN}" -o "${MYTH_WARN}" = "yes" ] && checkconfig
+
+ HOME="$(dirname "${MYTH_PID}")"
+ QTDIR=/usr/qt/3
+
+ # Work around any strange permissions that may be on these files.
+ chown -R "${MYTH_USER}" "$(dirname "${MYTH_LOG}")"
+ chown -R "${MYTH_USER}" "$(dirname "${MYTH_PID}")"
+
+ ebegin "Starting myth backend"
+ start-stop-daemon --start --quiet --chuid "${MYTH_USER}" \
+ --exec /usr/bin/mythbackend -- \
+ --daemon --pidfile "${MYTH_PID}" --logfile "${MYTH_LOG}"
+ eend $?
+}
+
+stop () {
+ [ -z "${MYTH_PID}" ] && MYTH_PID="/var/run/mythtv/mythbackend.pid"
+
+ ebegin "Stopping myth backend"
+ start-stop-daemon --stop --quiet --pidfile="${MYTH_PID}"
+ eend $?
+}
diff --git a/media-tv/mythtv/files/mythfilldatabase.cron b/media-tv/mythtv/files/mythfilldatabase.cron
new file mode 100644
index 000000000000..f1a675c1d121
--- /dev/null
+++ b/media-tv/mythtv/files/mythfilldatabase.cron
@@ -0,0 +1,4 @@
+#! /bin/sh
+
+QTDIR=/usr/qt/3
+/usr/bin/mythfilldatabase --no-delete --quiet
diff --git a/media-tv/mythtv/mythtv-0.10.ebuild b/media-tv/mythtv/mythtv-0.10.ebuild
new file mode 100644
index 000000000000..1f28a3d0192e
--- /dev/null
+++ b/media-tv/mythtv/mythtv-0.10.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.10.ebuild,v 1.1 2003/07/09 00:05:43 johnm Exp $
+
+inherit flag-o-matic
+
+IUSE="lcd mmx oss"
+DESCRIPTION="Homebrew PVR project."
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=x11-libs/qt-3
+ media-libs/a52dec
+ >=media-tv/xmltv-0.5.14
+ media-sound/lame
+ >=media-libs/freetype-2.0
+ >=sys-apps/sed-4
+ virtual/x11"
+
+RDEPEND="${DEPEND}
+ lcd? ( app-misc/lcdproc )"
+
+src_unpack() {
+
+ unpack ${A}
+
+ for i in `grep -lr usr/local "${S}"` ; do
+ sed -e "s:usr/local:usr:" -i "${i}" || die "sed failed"
+ done
+
+}
+
+src_compile() {
+
+ local myconf="--enable-a52bin --enable-shared"
+ myconf="${myconf} `use_enable lcd`"
+ myconf="${myconf} `use_enable mmx`"
+ myconf="${myconf} `use_enable oss audio-oss`"
+
+ cpu="`get-flag march`"
+ if [ -n "${cpu}" ] ; then
+ myconf="${myconf} --cpu=${cpu}"
+ sed -e "s:pentiumpro:${cpu}:g" -i "${S}/settings.pro" || die "sed failed"
+ fi
+
+ qmake -o "${S}/Makefile" "${S}/${PN}.pro"
+
+ econf ${myconf}
+
+ # Parallel build doesn't work.
+ make || die "compile problem"
+
+}
+
+src_install() {
+
+ make INSTALL_ROOT="${D}" install || die "make install failed"
+ newbin "setup/setup" "mythsetup"
+
+ dodir /etc/mythtv
+ mv "${D}/usr/share/mythtv/mysql.txt" "${D}/etc/mythtv"
+ dosym /etc/mythtv/mysql.txt /usr/share/mythtv/mysql.txt
+
+ exeinto /etc/init.d
+ newexe "${FILESDIR}/mythbackend.rc6" mythbackend
+
+ insinto /etc/conf.d
+ newins "${FILESDIR}/mythbackend.conf" mythbackend
+
+ exeinto /usr/share/mythtv
+ doexe "${FILESDIR}/mythfilldatabase.cron"
+
+ insinto /usr/share/mythtv/database
+ doins "${S}"/database/*
+
+ dodoc AUTHORS COPYING FAQ README UPGRADING keys.txt docs/*.txt
+ dohtml docs/*.html
+
+ keepdir /var/{log,run}/mythtv
+
+}
+
+pkg_postinst() {
+
+ ewarn "Please note that /usr/share/mythtv/setup has been moved"
+ ewarn "to /usr/bin/mythsetup"
+ echo
+
+ einfo "If this is the first time you install MythTV,"
+ einfo "you need to add /usr/share/mythtv/database/mc.sql"
+ einfo "to your mysql database."
+ einfo
+ einfo "You might run 'mysql < /usr/share/mythtv/database/mc.sql'"
+ einfo
+ einfo "Next, you need to run the mythsetup program."
+ einfo "It will ask you some questions about your hardware, and"
+ einfo "then run xmltv's grabber to configure your channels."
+ einfo
+ einfo "Once you have configured your database, you can run"
+ einfo "/usr/bin/mythfilldatabase to populate the schedule"
+ einfo "or copy /usr/share/mythtv/mythfilldatabase.cron to"
+ einfo "/etc/cron.daily for this to happen automatically."
+ einfo
+ einfo "If you're upgrading from an older version and for more"
+ einfo "setup and usage instructions, please refer to:"
+ einfo " /usr/share/doc/${PF}/README.gz"
+ einfo " /usr/share/doc/${PF}/UPGRADING.gz"
+ ewarn "This part is important as there might be database changes"
+ ewarn "which need to be performed or this package will not work"
+ ewarn "properly."
+ echo
+
+}
diff --git a/media-tv/xmltv/ChangeLog b/media-tv/xmltv/ChangeLog
new file mode 100644
index 000000000000..a979996b4843
--- /dev/null
+++ b/media-tv/xmltv/ChangeLog
@@ -0,0 +1,75 @@
+# ChangeLog for media-tv/xmltv
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/xmltv/ChangeLog,v 1.1 2003/07/09 00:08:10 johnm Exp $
+
+ 03 Jul 2003; Max Kalika <max@lsit.ucsb.edu> xmltv-0.5.11.ebuild,
+ xmltv-0.5.12.ebuild, xmltv-0.5.14.ebuild:
+ Change DateManip dependency to >= 5.42 which is officially out today and seems
+ to work with xmltv.
+
+*xmltv-0.5.14 (01 Jul 2003)
+
+ 01 Jul 2003; Max Kalika <max@lsit.ucsb.edu> xmltv-0.5.13.ebuild,
+ xmltv-0.5.14.ebuild:
+ Bump version to 0.5.14 and drop version 0.5.13 as it got pulled upstream.
+
+*xmltv-0.5.13 (01 Jul 2003)
+
+ 01 Jul 2003; Max Kalika <max@lsit.ucsb.edu> xmltv-0.5.13.ebuild:
+ Bump version to 0.5.13.
+
+*xmltv-0.5.12 (29 Jun 2003)
+
+ 29 Jun 2003; Max Kalika <max@lsit.ucsb.edu> xmltv-0.5.12.ebuild:
+ Bump version to 0.5.12.
+
+*xmltv-0.5.11 (22 Jun 2003)
+
+ 22 Jun 2003; Max Kalika <max@lsit.ucsb.edu> xmltv-0.5.11.ebuild:
+ Bump to 0.5.11. This one requires some changes: *ALL* grabbers are optional
+ now, so enable support for them. Add support for two new grabbers: Hungary and
+ Denmark. Since there is an option to build everything, simplify the
+ make_config() routine. Bring up some dependency versions to those
+ required/recommended by XMLTV. Unfortunately this version requires some fixes
+ to Date::Manip that are only available in a temporary branch of that code.
+ This dependency is temporarily marked as >=dev-perl/DateManip-5.40-r3 (which
+ is not in portage yet).
+
+*xmltv-0.5.10-r4 (18 Jun 2003)
+
+ 18 Jun 2003; Max Kalika <max@lsit.ucsb.edu> xmltv-0.5.10-r4.ebuild:
+ Move to media-tv.
+
+*xmltv-0.5.10-r3 (16 Jun 2003)
+
+ 16 Jun 2003; Max Kalika <max@lsit.ucsb.edu> xmltv-0.5.10-r3.ebuild:
+ Correctly fix the PREFIX issue. Just setting the PREFIX="${D}/usr" is
+ insufficient because the resulting executable script contains incorrectly
+ hard-coded paths to the SHARE_DIR (as pointed out by bug #10536 comment #66).
+ This update also greatly simplifies the src_compile() routine by calling
+ perl-module_src_compile() only and adds dependency on >= sed-4 because of
+ inlined sed usage.
+
+*xmltv-0.5.10-r2 (15 Jun 2003)
+ 13 Jun 2003; Tony Clark <tclark@telia.com> xmltv-0.5.10-r2.ebuild:
+ Fixed minor bug with tv_grab_nl_wolf, had the last underscore missing.
+ Had access denied when trying to install. Changed PREFIX back the
+ the way it use to be.
+
+*xmltv-0.5.10-r1 (13 Jun 2003)
+
+ 13 Jun 2003; Max Kalika <max@lsit.ucsb.edu> xmltv-0.5.10-r1.ebuild:
+ Drop all the local USE flag, use environment variable (XMLTV_OPTS)
+ instead. Drop the apache/cgi stuff and install tv_pick_cgi into
+ /usr/bin with a note on how to procede (until Gentoo has a standard
+ place for web things -- being discussed on -dev currently). Force
+ adding required dependencies for ALL grabbers until portage knows
+ about custom variables in /etc/make.conf during the dependency
+ checking stage.
+
+*xmltv-0.5.10 (28 Apr 2003)
+
+ 28 Apr 2003; Max Kalika <max@lsit.ucsb.edu> xmltv-0.5.10.ebuild:
+ Initial import. Bump to 0.5.10. Add xmltvnonlwolf flag to support
+ a new grabber. Install tv_pick_cgi file into ScriptAlias if the
+ xmltvnocgi USE flag is unset.
diff --git a/media-tv/xmltv/Manifest b/media-tv/xmltv/Manifest
new file mode 100644
index 000000000000..8336419cc4de
--- /dev/null
+++ b/media-tv/xmltv/Manifest
@@ -0,0 +1,2 @@
+MD5 8efe29bb59b43eaf84d13c03ceea7f0d xmltv-0.5.14.ebuild 6046
+MD5 60382fd1d3ad196ae1fe763d15bdb3ed ChangeLog 3211
diff --git a/media-tv/xmltv/xmltv-0.5.14.ebuild b/media-tv/xmltv/xmltv-0.5.14.ebuild
new file mode 100644
index 000000000000..a2ad11a7dddd
--- /dev/null
+++ b/media-tv/xmltv/xmltv-0.5.14.ebuild
@@ -0,0 +1,184 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/xmltv/xmltv-0.5.14.ebuild,v 1.1 2003/07/09 00:08:10 johnm Exp $
+
+inherit perl-module
+
+IUSE=""
+DESCRIPTION="Set of utilities to manage TV listings stored in the XMLTV format."
+HOMEPAGE="http://membled.com/work/apps/xmltv/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+# NOTE: you can customize the xmltv installation by
+# defining a XMLTV_OPTS variable which contains
+# a space-separated list of optional features.
+# If this variable is unspecified or has an
+# empty value, everything will be *enabled*.
+#
+# none: Don't enable any of the features below
+# tv_grab_de: Germany and Austria listing grabbers
+# tv_grab_uk: Britain listings grabber
+# tv_grab_uk_rt: Alternate Britain listings grabber
+# tv_grab_it: Italy listings grabber
+# tv_grab_na: North America listings grabber
+# tv_grab_sn: Sweden and Norway listings grabber
+# tv_grab_nz: New Zealand listings grabber
+# tv_grab_fi: Finland listings grabber
+# tv_grab_es: Spain listings grabber
+# tv_grab_nl: Netherlands listings grabber
+# tv_grab_nl_wolf: Alternate Netherlands listings grabber
+# tv_grab_hu: Hungary listings grabber
+# tv_grab_dk: Denmark listings grabber
+# tv_check: Graphical front-end for listings data
+# tv_pick_cgi: CGI front-end for listings data
+
+# EXAMPLES:
+# enable just North American grabber
+# XMLTV_OPTS="tv_grab_na"
+#
+# enable graphical front-end, New Zealand and Italy grabbers
+# XMLTV_OPTS="tv_check tv_grab_nz tv_grab_it"
+
+DEPEND=">=sys-apps/sed-4
+ >=dev-perl/libwww-perl-5.65
+ >=dev-perl/XML-Twig-3.09
+ dev-perl/XML-Writer
+ >=dev-perl/DateManip-5.42
+ dev-perl/Memoize
+ >=dev-perl/Term-ProgressBar-2.03
+ dev-perl/Compress-Zlib
+ dev-perl/Lingua-EN-Numbers-Ordinate
+ dev-perl/Lingua-Preferred
+ dev-perl/Unicode-String"
+
+# for tv_check
+DEPEND="${DEPEND} dev-perl/perl-tk dev-perl/Tk-TableMatrix dev-perl/XML-Simple"
+# for tv_grab_na
+DEPEND="${DEPEND} dev-perl/HTML-Parser"
+# for tv_grab_sn
+DEPEND="${DEPEND} >=dev-perl/HTML-TableExtract-1.08"
+# for tv_grab_nz
+DEPEND="${DEPEND} >=dev-lang/python-1.5.2"
+# for tv_grab_fi tv_grab_es tv_grab_nl tv_grab_nl_wolf tv_grab_hu tv_grab_dk
+DEPEND="${DEPEND} dev-perl/HTML-Tree"
+
+### disabled until portage dependecy checker has notions of things
+### other then incrementals that are in /etc/make.conf
+### 6/13/2003 Max Kalika <max@lsit.ucsb.edu>
+#[ -z "${XMLTV_OPTS}" -o "`has tv_grab_na ${XMLTV_OPTS}`" ] \
+# && DEPEND="${DEPEND} dev-perl/HTML-Parser"
+#[ -z "${XMLTV_OPTS}" -o "`has tv_grab_sn ${XMLTV_OPTS}`" ] \
+# && DEPEND="${DEPEND} >=dev-perl/HTML-TableExtract-1.0.8"
+#[ -z "${XMLTV_OPTS}" -o "`has tv_grab_nz ${XMLTV_OPTS}`" ] \
+# && DEPEND="${DEPEND} >=dev-lang/python-1.5.1"
+#[ -z "${XMLTV_OPTS}" -o "`has tv_grab_fi ${XMLTV_OPTS}`" ] \
+# && DEPEND="${DEPEND} dev-perl/HTML-Tree"
+#[ -z "${XMLTV_OPTS}" -o "`has tv_grab_es ${XMLTV_OPTS}`" ] \
+# && DEPEND="${DEPEND} dev-perl/HTML-Tree"
+#[ -z "${XMLTV_OPTS}" -o "`has tv_grab_nl ${XMLTV_OPTS}`" ] \
+# && DEPEND="${DEPEND} dev-perl/HTML-Tree"
+#[ -z "${XMLTV_OPTS}" -o "`has tv_grab_nl_wolf ${XMLTV_OPTS}`" ] \
+# && DEPEND="${DEPEND} dev-perl/HTML-Tree"
+#[ -z "${XMLTV_OPTS}" -o "`has tv_grab_hu ${XMLTV_OPTS}`" ] \
+# && DEPEND="${DEPEND} dev-perl/HTML-Tree"
+#[ -z "${XMLTV_OPTS}" -o "`has tv_grab_dk ${XMLTV_OPTS}`" ] \
+# && DEPEND="${DEPEND} dev-perl/HTML-Tree"
+#[ -z "${XMLTV_OPTS}" -o "`has tv_check ${XMLTV_OPTS}`" ] \
+# && DEPEND="${DEPEND} dev-perl/perl-tk dev-perl/Tk-TableMatrix dev-perl/XML-Simple"
+
+make_config() {
+
+ if [ -z "${XMLTV_OPTS}" ] ; then
+ # No customization needed, build everything (default)
+ echo "yes"
+ return
+ else
+ # Need to specify custom settings, do not accept defaults
+ echo "no"
+ fi
+
+ # Enable Germany and Austria
+ [ "`has tv_grab_de ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
+
+ # Enable Brittain
+ [ "`has tv_grab_uk ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
+
+ # Enable Alternate Brittain
+ [ "`has tv_grab_uk_rt ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
+
+ # Enable Italy
+ [ "`has tv_grab_it ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
+
+ # Enable North America
+ [ "`has tv_grab_na ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
+
+ # Enable Sweden and Norway
+ [ "`has tv_grab_sn ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
+
+ # Enable New Zealand
+ [ "`has tv_grab_nz ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
+
+ # Enable Finland
+ [ "`has tv_grab_fi ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
+
+ # Enable Spain
+ [ "`has tv_grab_es ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
+
+ # Enable Netherlands
+ [ "`has tv_grab_nl ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
+
+ # Enable Alternate Netherlands
+ [ "`has tv_grab_nl_wolf ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
+
+ # Enable Hungary
+ [ "`has tv_grab_hu ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
+
+ # Enable Denmark
+ [ "`has tv_grab_nl ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
+
+ # Enable GUI checking.
+ [ "`has tv_check ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
+
+ # Enable CGI support
+ [ "`has tv_pick_cgi ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
+
+}
+
+src_compile() {
+
+ make_config | perl-module_src_compile
+
+}
+
+src_install() {
+
+ perl-module_src_install
+
+ for i in `grep -rl "${D}" "${D}"` ; do
+ sed -e "s:${D}::g" -i "${i}"
+ done
+
+ if [ -z "${XMLTV_OPTS}" -o "`has tv_pick_cgi ${XMLTV_OPTS}`" ] ; then
+ dobin choose/tv_pick/tv_pick_cgi
+ einfo
+ einfo "To use tv_pick_cgi, please link it from /usr/bin/tv_pick_cgi"
+ einfo "to where the ScriptAlias directive is configured."
+ einfo
+ fi
+
+}
+
+pkg_postinst() {
+
+ ewarn "If you are upgrading from < 0.5.10 and you need to use the"
+ ewarn "DE (Germany/Austria), UK or UK_RT (Britain), or IT (Italy)"
+ ewarn "grabbers, please make sure you have the appropriate value"
+ ewarn "specified in your XMLTV_OPTS setting because these grabbers"
+ ewarn "no longer build by default."
+ echo
+
+}