summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2011-02-04 23:39:36 +0000
committerMichał Górny <mgorny@gentoo.org>2011-02-04 23:39:36 +0000
commitcdfadc6ad73cfaf0acfd3da9fe3696b83669ff2e (patch)
treeec1293f79a9b92477d20d02d8784469e0e07349d /media-video/stk11xx
parentstable x86, security bug 353326 (diff)
downloadhistorical-cdfadc6ad73cfaf0acfd3da9fe3696b83669ff2e.tar.gz
historical-cdfadc6ad73cfaf0acfd3da9fe3696b83669ff2e.tar.bz2
historical-cdfadc6ad73cfaf0acfd3da9fe3696b83669ff2e.zip
Add a patch to fix building against 2.6.37 kernel.
Package-Manager: portage-2.2.0_alpha19_p84/cvs/Linux x86_64
Diffstat (limited to 'media-video/stk11xx')
-rw-r--r--media-video/stk11xx/ChangeLog8
-rw-r--r--media-video/stk11xx/files/stk11xx-2.6.37.patch16
-rw-r--r--media-video/stk11xx/stk11xx-2.1.0.ebuild10
3 files changed, 29 insertions, 5 deletions
diff --git a/media-video/stk11xx/ChangeLog b/media-video/stk11xx/ChangeLog
index 1741fcbb2ddc..84491be2514f 100644
--- a/media-video/stk11xx/ChangeLog
+++ b/media-video/stk11xx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/stk11xx
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/stk11xx/ChangeLog,v 1.2 2010/10/26 14:49:42 fauli Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/stk11xx/ChangeLog,v 1.3 2011/02/04 23:39:36 mgorny Exp $
+
+ 04 Feb 2011; Michał Górny <mgorny@gentoo.org> stk11xx-2.1.0.ebuild,
+ +files/stk11xx-2.6.37.patch:
+ Add a patch to fix building against 2.6.37 kernel.
26 Oct 2010; Christian Faulhammer <fauli@gentoo.org> stk11xx-2.1.0.ebuild:
keyworded ~arch for x86, bug 342659
diff --git a/media-video/stk11xx/files/stk11xx-2.6.37.patch b/media-video/stk11xx/files/stk11xx-2.6.37.patch
new file mode 100644
index 000000000000..d7a8bac31b22
--- /dev/null
+++ b/media-video/stk11xx/files/stk11xx-2.6.37.patch
@@ -0,0 +1,16 @@
+diff -ruN driver.org//stk11xx-usb.c driver/stk11xx-usb.c
+--- driver.org//stk11xx-usb.c 2011-01-06 21:51:53.674999852 +0200
++++ driver/stk11xx-usb.c 2011-01-06 21:56:44.418999851 +0200
+@@ -844,7 +844,12 @@
+ }
+
+ // Init mutexes, spinlock, etc.
++
++#ifndef init_MUTEX
++ sema_init(&dev->mutex,1);
++#else
+ init_MUTEX(&dev->mutex);
++#endif
+ mutex_init(&dev->modlock);
+ spin_lock_init(&dev->spinlock);
+ init_waitqueue_head(&dev->wait_frame);
diff --git a/media-video/stk11xx/stk11xx-2.1.0.ebuild b/media-video/stk11xx/stk11xx-2.1.0.ebuild
index 40054b31a47a..09491a6a5b0d 100644
--- a/media-video/stk11xx/stk11xx-2.1.0.ebuild
+++ b/media-video/stk11xx/stk11xx-2.1.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/stk11xx/stk11xx-2.1.0.ebuild,v 1.2 2010/10/26 14:49:42 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/stk11xx/stk11xx-2.1.0.ebuild,v 1.3 2011/02/04 23:39:36 mgorny Exp $
EAPI=2
@@ -24,6 +24,10 @@ pkg_setup() {
BUILD_TARGETS="${PN}.ko"
BUILD_PARAMS="-C ${KV_DIR} SUBDIRS=${S}"
- PATCHES=( "${FILESDIR}"/${PN}-v4l_compat_ioctl32.diff )
+ PATCHES=(
+ "${FILESDIR}"/${PN}-v4l_compat_ioctl32.diff
+ # http://sourceforge.net/tracker/index.php?func=detail&aid=3152597&group_id=178178&atid=884193
+ "${FILESDIR}"/${PN}-2.6.37.patch
+ )
MODULESD_STK11XX_DOCS=( README )
}