summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2006-11-01 19:46:27 +0000
committerPeter Volkov <pva@gentoo.org>2006-11-01 19:46:27 +0000
commit0620edb993135f36c4407bbab73d84bfbd6b03da (patch)
treebe719a67fddedd19b1d8980a12380df43442aec4 /net-analyzer
parentChange RDEPEND to bmpx-2 (bug 153608). Clean out old version. (diff)
downloadhistorical-0620edb993135f36c4407bbab73d84bfbd6b03da.tar.gz
historical-0620edb993135f36c4407bbab73d84bfbd6b03da.tar.bz2
historical-0620edb993135f36c4407bbab73d84bfbd6b03da.zip
Version bump. As always thank upstream dev Loren Bandiera for report. Old versions are removed.
Package-Manager: portage-2.1.1
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/sussen/ChangeLog18
-rw-r--r--net-analyzer/sussen/files/digest-sussen-0.323
-rw-r--r--net-analyzer/sussen/sussen-0.32.ebuild96
3 files changed, 116 insertions, 1 deletions
diff --git a/net-analyzer/sussen/ChangeLog b/net-analyzer/sussen/ChangeLog
index 7671f22763a5..b5abf0cb752c 100644
--- a/net-analyzer/sussen/ChangeLog
+++ b/net-analyzer/sussen/ChangeLog
@@ -1,6 +1,22 @@
# ChangeLog for net-analyzer/sussen
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sussen/ChangeLog,v 1.36 2006/10/28 10:49:45 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sussen/ChangeLog,v 1.37 2006/11/01 19:46:27 pva Exp $
+
+*sussen-0.32 (01 Nov 2006)
+
+ 01 Nov 2006; Peter Volkov <pva@gentoo.org>
+ -files/sussen-0.22-applet-cancel-scan-crash.patch,
+ -files/sussen-0.22-panel-applet-crash.patch,
+ -files/sussen-0.23-try-catch-on-results.patch,
+ -files/sussen-0.24-applet-no-definitions.patch,
+ -files/sussen-0.24-xml-to-datadir.patch,
+ -files/sussen-0.25-0.28-interface-failsafe.diff,
+ -files/sussen-0.26-agent-empty-definitions.patch, -sussen-0.19.ebuild,
+ -sussen-0.21.ebuild, -sussen-0.22-r2.ebuild, -sussen-0.23.ebuild,
+ -sussen-0.24.ebuild, -sussen-0.25-r1.ebuild, -sussen-0.26-r1.ebuild,
+ -sussen-0.27-r1.ebuild, -sussen-0.28.ebuild, +sussen-0.32.ebuild:
+ Version bump. As always thank upstream dev Loren Bandiera for report. Old
+ versions are removed.
28 Oct 2006; Christian Faulhammer <opfer@gentoo.org> sussen-0.29.ebuild:
x86 stable wrt bug #151302
diff --git a/net-analyzer/sussen/files/digest-sussen-0.32 b/net-analyzer/sussen/files/digest-sussen-0.32
new file mode 100644
index 000000000000..db6cc6db43bc
--- /dev/null
+++ b/net-analyzer/sussen/files/digest-sussen-0.32
@@ -0,0 +1,3 @@
+MD5 4c49ced3fa7d43714f56ee1a81ed0553 sussen-0.32.tar.gz 917745
+RMD160 fc7d5553766bea7eadfb7e02760e66553b409e9f sussen-0.32.tar.gz 917745
+SHA256 1c58613c45fee3fa39123ab6ddc90d4c91b8833b68b2b3a20bf0403929c9f2fc sussen-0.32.tar.gz 917745
diff --git a/net-analyzer/sussen/sussen-0.32.ebuild b/net-analyzer/sussen/sussen-0.32.ebuild
new file mode 100644
index 000000000000..2b35b6b902fe
--- /dev/null
+++ b/net-analyzer/sussen/sussen-0.32.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sussen/sussen-0.32.ebuild,v 1.1 2006/11/01 19:46:27 pva Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="1.8"
+inherit eutils gnome2 mono autotools
+
+DESCRIPTION="Sussen is a tool that checks for vulnerabilities and configuration issues on computer systems"
+HOMEPAGE="http://dev.mmgsecurity.com/projects/sussen/"
+SRC_URI="http://dev.mmgsecurity.com/downloads/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+# web interface now optional, but does not work.
+#IUSE="doc gnome web"
+IUSE="doc gnome"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+RDEPEND=">=dev-lang/mono-1.1
+ gnome? ( >=dev-dotnet/gtk-sharp-2.4
+ >=dev-dotnet/gnome-sharp-2.4
+ >=dev-dotnet/gconf-sharp-2.4
+ >=dev-dotnet/glade-sharp-2.4
+ gnome-base/gnome-panel )"
+
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/monodoc-1.1.8 )
+ app-arch/rpm
+ >=dev-util/intltool-0.34.2"
+
+DOCS="AUTHORS ChangeLog README TODO"
+
+pkg_setup() {
+ ewarn "dbus support has been removed from sussen until mono binding"
+ ewarn "issue will be resolved: http://www.j5live.com/?p=221"
+ ebeep 5
+
+ use gnome || { elog "You do not have gnome in your USE flags.";
+ elog "applet and editor will not be built." ; }
+}
+
+# src_unpack, pkg_postinst, pkg_postrm are exported in gnome2.eclass. But since
+# we have gnome2 support depends on USE let's call gnome2.eclass internal
+# functions only when USE="gnome".
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ use gnome && gnome2_omf_fix
+}
+
+src_compile () {
+ # Put all asp pages in /usr/share/$PF dir instead of /usr/share/sussen
+ sed -i -e \
+ "s:wwwdir = \$(datadir)/doc/sussen/www/asp:wwwdir = \$(datadir)/doc/${PF}/www/asp:" \
+ www/asp/Makefile.in || die "sed failed."
+
+ # $(use_enable web yes)
+ econf ${myconf} \
+ --enable-web=no \
+ $(use_enable gnome) || die "./configure failed."
+
+ emake -j1 || die "Compilation failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die "Installation failed"
+
+ dodoc ${DOCS}
+
+ if use gnome ; then
+ elog "sussen-applet is a GNOME applet. You can not run it directly from"
+ elog "the command line. Use GNOME panel to invoke it."
+ elog "You can also run it with the --tray-icon command line option."
+ echo
+ ewarn "sussen-editor is still work in progress... But 'new', 'save' and"
+ ewarn "'save as' operations are now implemented. Also it is possible to"
+ ewarn "execute definitions."
+ echo
+ ewarn "Beginning with sussen-0.24 default location for oval definitions changed."
+ ewarn "If you had previous versions installed, please, run the following"
+ ewarn "commands to clean outdated locations for each user that run sussen:"
+ ewarn
+ ewarn "gconftool-2 --unset /apps/sussen-applet/oval_xml_directory"
+ ewarn "gconftool-2 --unset /apps/sussen-applet/oval_download_directory"
+ echo
+ fi
+}
+
+pkg_postinst() {
+ use gnome && gnome2_pkg_postinst
+}
+
+pkg_postrm() {
+ use gnome && gnome2_pkg_postrm
+}