summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChuck Short <zul@gentoo.org>2003-11-21 20:45:39 +0000
committerChuck Short <zul@gentoo.org>2003-11-21 20:45:39 +0000
commit91fdb0407d98b912351e4c89485a43eed33e19e1 (patch)
tree7d5f2a821f23a240987ace3de5ad7644968b2bdf /net-irc/epic4
parentNew version. (diff)
downloadhistorical-91fdb0407d98b912351e4c89485a43eed33e19e1.tar.gz
historical-91fdb0407d98b912351e4c89485a43eed33e19e1.tar.bz2
historical-91fdb0407d98b912351e4c89485a43eed33e19e1.zip
New version.
Diffstat (limited to 'net-irc/epic4')
-rw-r--r--net-irc/epic4/Manifest4
-rw-r--r--net-irc/epic4/epic4-1.1.16.ebuild72
-rw-r--r--net-irc/epic4/files/digest-epic4-1.1.162
3 files changed, 76 insertions, 2 deletions
diff --git a/net-irc/epic4/Manifest b/net-irc/epic4/Manifest
index 76fc8e80809c..6917f7520133 100644
--- a/net-irc/epic4/Manifest
+++ b/net-irc/epic4/Manifest
@@ -2,8 +2,8 @@ MD5 0257d9b4666ccec4ba7a6d1bc2e60b04 epic4-1.1.14-r1.ebuild 1974
MD5 c2880c7eaedef26a5d1518ecf38fba84 epic4-1.1.10.ebuild 2079
MD5 012746f52e0a8a1b41117246bbaf29f6 epic4-1.1.12.ebuild 2201
MD5 00cbb951ea73e3176a7dd612bfddcf2f epic4-1.1.14.ebuild 2055
-MD5 e6e232bae4de5117970c2a3f01dbab26 ChangeLog 4212
-MD5 0257d9b4666ccec4ba7a6d1bc2e60b04 epic4-1.1.16.ebuild 1974
+MD5 1d5e470f821a1338cabaf6688c8f2063 ChangeLog 4322
+MD5 9360dc280857adc3c0ca989e4307a5b8 epic4-1.1.16.ebuild 1971
MD5 44c39c6ad372a8e5a5e7ee3311f703a7 metadata.xml 160
MD5 a8cfb6bc69fec7c761bc19b8013974ad epic4-1.1.11.ebuild 2042
MD5 33df45dcbc3a9e94246c4ee10474f332 files/epic4-1.0.1-gcc33.patch 850
diff --git a/net-irc/epic4/epic4-1.1.16.ebuild b/net-irc/epic4/epic4-1.1.16.ebuild
new file mode 100644
index 000000000000..730cdaee218e
--- /dev/null
+++ b/net-irc/epic4/epic4-1.1.16.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/epic4/epic4-1.1.16.ebuild,v 1.1 2003/11/21 20:45:30 zul Exp $
+
+IUSE="ipv6 perl ssl tcltk"
+
+DESCRIPTION="Epic4 IRC Client"
+SRC_URI="ftp://prbh.org/pub/epic/EPIC4-ALPHA/${P}.tar.bz2
+ ftp://prbh.org/pub/epic/EPIC4-PRODUCTION/epic4-help-20030114.tar.gz"
+HOMEPAGE="http://epicsol.org"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86 ~ppc ~ia64 ~alpha ~hppa"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ perl? ( >=dev-lang/perl-5.6.1 )
+ ssl? ( >=dev-libs/openssl-0.9.5 )
+ tcltk? ( dev-lang/tcl )"
+
+inherit flag-o-matic
+replace-flags "-O?" "-O"
+
+src_compile() {
+ myconf=""
+
+ myconf="${myconf} `use_with ipv6`"
+ myconf="${myconf} `use_with perl`"
+ myconf="${myconf} `use_with ssl`"
+ myconf="${myconf} `use_with tcltk`"
+
+ econf \
+ --libexecdir=/usr/lib/misc \
+ ${myconf} || die
+
+ make || die
+}
+
+src_install () {
+ einstall \
+ sharedir=${D}/usr/share \
+ libexecdir=${D}/usr/lib/misc || die
+
+ rm -f ${D}/usr/bin/epic
+ dosym epic-EPIC4-${PV} /usr/bin/epic
+
+ dodoc BUG_FORM COPYRIGHT README KNOWNBUGS VOTES
+ docinto doc
+ cd doc
+ dodoc *.txt colors EPIC* IRCII_VERSIONS local_vars missing new-load
+ dodoc nicknames outputhelp server_groups SILLINESS TS4
+
+ dodir /usr/share/epic
+ tar zxvf ${DISTDIR}/epic4-help-20030114.tar.gz -C ${D}/usr/share/epic
+
+ rm -f ${D}/usr/share/epic/help/Makefile
+ rm -rf ${D}/usr/share/epic/help/CVS
+
+ chown -R root.root ${D}/usr/share/epic/help
+}
+
+pkg_postinst() {
+ einfo "If /usr/share/epic/script/local does not exist, I will now"
+ einfo "create it. If you do not like the look/feel of this file, or"
+ einfo "if you'd prefer to use your own script, simply remove this"
+ einfo "file. If you want to prevent this file from being installed"
+ einfo "in the future, simply create an empty file with this name."
+
+ if [ ! -e /usr/share/epic/script/local ]; then
+ cp ${FILESDIR}/local /usr/share/epic/script/
+ fi
+}
diff --git a/net-irc/epic4/files/digest-epic4-1.1.16 b/net-irc/epic4/files/digest-epic4-1.1.16
new file mode 100644
index 000000000000..caa8eccdeac1
--- /dev/null
+++ b/net-irc/epic4/files/digest-epic4-1.1.16
@@ -0,0 +1,2 @@
+MD5 92f62697a9952b2f4210dd693803d3d0 epic4-1.1.16.tar.bz2 607142
+MD5 f4220b4cf989e320fbbd6051c5117307 epic4-help-20030114.tar.gz 287157