summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2005-05-16 09:50:49 +0000
committerAndrej Kacian <ticho@gentoo.org>2005-05-16 09:50:49 +0000
commite311f99261c313f4dbee9f7e3e3cc1f510cd942d (patch)
tree648c1088ed4846f0bf8b14f4c3ced808041a4612 /net-mail/checkpassword
parentInherit toolchain-funcs.eclass instead of gcc.eclass. Bug #92745. (diff)
downloadhistorical-e311f99261c313f4dbee9f7e3e3cc1f510cd942d.tar.gz
historical-e311f99261c313f4dbee9f7e3e3cc1f510cd942d.tar.bz2
historical-e311f99261c313f4dbee9f7e3e3cc1f510cd942d.zip
Inherit toolchain-funcs.eclass instead of gcc.eclass. Bug #92745.
Package-Manager: portage-2.0.51.21-r1
Diffstat (limited to 'net-mail/checkpassword')
-rw-r--r--net-mail/checkpassword/ChangeLog8
-rw-r--r--net-mail/checkpassword/Manifest14
-rw-r--r--net-mail/checkpassword/checkpassword-0.90-r1.ebuild10
3 files changed, 23 insertions, 9 deletions
diff --git a/net-mail/checkpassword/ChangeLog b/net-mail/checkpassword/ChangeLog
index e425e6c6cd1a..977a41cae51d 100644
--- a/net-mail/checkpassword/ChangeLog
+++ b/net-mail/checkpassword/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-mail/checkpassword
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/checkpassword/ChangeLog,v 1.17 2004/07/05 02:29:19 robbat2 Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/checkpassword/ChangeLog,v 1.18 2005/05/16 09:50:49 ticho Exp $
+
+ 16 May 2005; Andrej Kacian <ticho@gentoo.org>
+ checkpassword-0.90-r1.ebuild:
+ Inherit toolchain-funcs.eclass instead of gcc.eclass. Bug #92745.
04 Jul 2004; Robin H. Johnson <robbat2@gentoo.org>
checkpassword-0.90-r1.ebuild:
diff --git a/net-mail/checkpassword/Manifest b/net-mail/checkpassword/Manifest
index 9ecb20c36321..54ad879fff85 100644
--- a/net-mail/checkpassword/Manifest
+++ b/net-mail/checkpassword/Manifest
@@ -1,6 +1,16 @@
-MD5 0339fe98e9a55213ef9104f105aae006 checkpassword-0.90-r1.ebuild 1022
-MD5 99465fb12ec9594de8ec84a8975a57be ChangeLog 1908
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 70bd730d7470afed28d0fae853808bc2 checkpassword-0.90-r1.ebuild 1030
+MD5 06e9de61040067a76cb768dc1d5a04d3 ChangeLog 2055
MD5 9d0c568ea32cf6b45797c6e7c82b4a67 metadata.xml 280
MD5 894ae022f7765b23ddfce23bc2f91c3e files/digest-checkpassword-0.90-r1 69
MD5 5c5ff561b8a7baeb2e1a0e38503fa425 files/0.90-head-1.patch 1201
MD5 760d73c8b3091ca1cae9a1ae5b6fab8f files/0.90-errno.patch 243
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iD8DBQFCiG0LQlM6RnzZP+IRAsS/AKCgHsNPBlWrm2GGvJRFfvBLAn4DZQCgmZww
+TmQowJrKrqtdusOdMasmODo=
+=ULB/
+-----END PGP SIGNATURE-----
diff --git a/net-mail/checkpassword/checkpassword-0.90-r1.ebuild b/net-mail/checkpassword/checkpassword-0.90-r1.ebuild
index 2b2f96a05ace..6013c622cfcd 100644
--- a/net-mail/checkpassword/checkpassword-0.90-r1.ebuild
+++ b/net-mail/checkpassword/checkpassword-0.90-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/checkpassword/checkpassword-0.90-r1.ebuild,v 1.14 2004/07/05 02:29:19 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/checkpassword/checkpassword-0.90-r1.ebuild,v 1.15 2005/05/16 09:50:49 ticho Exp $
-inherit eutils gcc
+inherit eutils toolchain-funcs
DESCRIPTION="A uniform password checking interface for root applications"
HOMEPAGE="http://cr.yp.to/checkpwd.html"
@@ -23,8 +23,8 @@ src_unpack() {
LDFLAGS="${LDFLAGS} -s"
use pic && CFLAGS="${CFLAGS} -fPIC"
use static && LDFLAGS="${LDFLAGS} -static"
- echo "$(gcc-getCC) ${CFLAGS}" > conf-cc
- echo "$(gcc-getCC) ${LDFLAGS}" > conf-ld
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
}
src_compile() {