summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-08-02 10:56:03 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-08-02 10:56:03 +0000
commit763f63913e160af77657878485ea4f91ddae347e (patch)
tree04fc8fc6c6188254287e1e0eef8aea9d5d590efd /net-mail/mpack
parentinitial import (diff)
downloadhistorical-763f63913e160af77657878485ea4f91ddae347e.tar.gz
historical-763f63913e160af77657878485ea4f91ddae347e.tar.bz2
historical-763f63913e160af77657878485ea4f91ddae347e.zip
Security update
Diffstat (limited to 'net-mail/mpack')
-rw-r--r--net-mail/mpack/ChangeLog7
-rw-r--r--net-mail/mpack/files/digest-mpack-1.5-r11
-rw-r--r--net-mail/mpack/files/mpack-1.5-r1.patch82
-rw-r--r--net-mail/mpack/mpack-1.5-r1.ebuild30
4 files changed, 119 insertions, 1 deletions
diff --git a/net-mail/mpack/ChangeLog b/net-mail/mpack/ChangeLog
index 6a417b96014f..6a9efa41dd3b 100644
--- a/net-mail/mpack/ChangeLog
+++ b/net-mail/mpack/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/mpack
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mpack/ChangeLog,v 1.1 2002/06/12 13:03:49 stroke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mpack/ChangeLog,v 1.2 2002/08/02 10:56:03 aliz Exp $
+
+*mpack-1.5-r1 (02 Aug 2002)
+
+ 02 Aug 2002; Daniel Ahlberg <aliz@gentoo.org> mpack-1.5-r1.ebuild :
+ Security fix.
*mpack-1.5 (12 Jun 2002)
diff --git a/net-mail/mpack/files/digest-mpack-1.5-r1 b/net-mail/mpack/files/digest-mpack-1.5-r1
new file mode 100644
index 000000000000..6819469ab30e
--- /dev/null
+++ b/net-mail/mpack/files/digest-mpack-1.5-r1
@@ -0,0 +1 @@
+MD5 f41f8aa2ae92d90e1ac03291973e65e4 mpack-1.5-src.tar.Z 285360
diff --git a/net-mail/mpack/files/mpack-1.5-r1.patch b/net-mail/mpack/files/mpack-1.5-r1.patch
new file mode 100644
index 000000000000..581f5d5590e1
--- /dev/null
+++ b/net-mail/mpack/files/mpack-1.5-r1.patch
@@ -0,0 +1,82 @@
+--- mpack-1.5.orig/decode.c
++++ mpack-1.5/decode.c
+@@ -466,6 +466,7 @@
+ while (*from && *from != '\"') {
+ if (!--left) {
+ alloced += VALUEGROWSIZE;
++ left += VALUEGROWSIZE;
+ value = xrealloc(value, alloced);
+ to = value + alloced - left - 2;
+ }
+@@ -482,6 +483,7 @@
+ while (*from && !isspace(*from)) {
+ if (!--left) {
+ alloced += VALUEGROWSIZE;
++ left += VALUEGROWSIZE;
+ value = xrealloc(value, alloced);
+ to = value + alloced - left - 2;
+ }
+@@ -571,6 +573,7 @@
+ while (*disposition && *disposition != '\"') {
+ if (!--left) {
+ alloced += VALUEGROWSIZE;
++ left += VALUEGROWSIZE;
+ value = xrealloc(value, alloced);
+ to = value + alloced - left - 2;
+ }
+@@ -588,6 +591,7 @@
+ *disposition != '(') {
+ if (!--left) {
+ alloced += VALUEGROWSIZE;
++ left += VALUEGROWSIZE;
+ value = xrealloc(value, alloced);
+ to = value + alloced - left - 2;
+ }
+--- mpack-1.5.orig/unixos.c
++++ mpack-1.5/unixos.c
+@@ -89,7 +89,7 @@
+ strcpy(buf, getenv("TMPDIR"));
+ }
+ else {
+- strcpy(buf, "/usr/tmp");
++ strcpy(buf, "/var/tmp");
+ }
+ strcat(buf, "/m-prts-");
+ p = getenv("USER");
+@@ -159,6 +159,11 @@
+
+ /* Get rid of leading ~ or ~/ */
+ while (*fname == '~' || *fname == '/') fname++;
++
++ /* Debian fix: the loop below handles internal "/../" but not
++ * leading "../" */
++ /* Get rid of leading "../" */
++ while (!strncmp(fname, "../", 3)) fname += 3;
+
+ /* Clean out bad characters, create directories along path */
+ for (p=fname; *p; p++) {
+--- mpack-1.5.orig/unixunpk.man
++++ mpack-1.5/unixunpk.man
+@@ -107,7 +107,7 @@
+ .SH ENVIRONMENT
+ .TP
+ .B TMPDIR
+-Directory to store temporary files. Default is /usr/tmp.
++Directory to store temporary files. Default is /var/tmp.
+ .SH FILES
+ .TP
+ .B $TMPDIR/m-prts-$USER/
+--- mpack-1.5.orig/uudecode.c
++++ mpack-1.5/uudecode.c
+@@ -524,8 +524,9 @@
+ * representation syntax
+ */
+ do {
+- while (*scan != '\n' && isprint(*scan)
+- && !isalnum(*scan) && *scan != '_') ++scan;
++ /* Debian patch: skip non-printable characters too.
++ * Sent upstream, no reply yet. */
++ while (*scan != '\n' && !isalnum(*scan) && *scan != '_') ++scan;
+ *fnamep = start = scan;
+ while (isalnum(*scan) || *scan == '-' || *scan == '+' || *scan == '&'
+ || *scan == '_' || *scan == '.') {
diff --git a/net-mail/mpack/mpack-1.5-r1.ebuild b/net-mail/mpack/mpack-1.5-r1.ebuild
new file mode 100644
index 000000000000..e1226c528e8c
--- /dev/null
+++ b/net-mail/mpack/mpack-1.5-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mpack/mpack-1.5-r1.ebuild,v 1.1 2002/08/02 10:56:03 aliz Exp $
+
+S=${WORKDIR}/${PN}
+DESCRIPTION="Command-line MIME encoding and decoding utilities"
+HOMEPAGE="ftp://ftp.andrew.cmu.edu/pub/mpack/"
+SRC_URI="ftp://ftp.andrew.cmu.edu/pub/mpack/${P}-src.tar.Z"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="x86"
+
+DEPEND="virtual/glibc"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${P}-src.tar.Z
+ cd ${S}
+ patch -l -p1 <${FILESDIR}/${P}-r1.patch
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" || die
+}
+
+src_install () {
+ dodir /usr
+ make DESTDIR=${D}/usr install || die
+}