summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2011-09-12 20:52:05 +0000
committerEray Aslan <eras@gentoo.org>2011-09-12 20:52:05 +0000
commit8d69461c51d816aaed6b1df8661e753da12505f2 (patch)
tree25f0472b0be6fb1bb9cfe5492f5812130b51b150 /net-mail/uw-mailutils
parentRewrite eqawarn() to reuse PORTAGE_ELOG_CLASSES set by dev profile. (diff)
downloadhistorical-8d69461c51d816aaed6b1df8661e753da12505f2.tar.gz
historical-8d69461c51d816aaed6b1df8661e753da12505f2.tar.bz2
historical-8d69461c51d816aaed6b1df8661e753da12505f2.zip
version bump
Package-Manager: portage-2.1.10.15/cvs/Linux x86_64
Diffstat (limited to 'net-mail/uw-mailutils')
-rw-r--r--net-mail/uw-mailutils/ChangeLog7
-rw-r--r--net-mail/uw-mailutils/uw-mailutils-2007f.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/net-mail/uw-mailutils/ChangeLog b/net-mail/uw-mailutils/ChangeLog
index c706d7eea74f..25a3367c59ae 100644
--- a/net-mail/uw-mailutils/ChangeLog
+++ b/net-mail/uw-mailutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/uw-mailutils
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/uw-mailutils/ChangeLog,v 1.32 2011/06/06 19:50:05 eras Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/uw-mailutils/ChangeLog,v 1.33 2011/09/12 20:49:28 eras Exp $
+
+*uw-mailutils-2007f (12 Sep 2011)
+
+ 12 Sep 2011; Eray Aslan <eras@gentoo.org> +uw-mailutils-2007f.ebuild:
+ version bump
06 Jun 2011; Eray Aslan <eras@gentoo.org> -uw-mailutils-2007b.ebuild,
uw-mailutils-2007e-r1.ebuild:
diff --git a/net-mail/uw-mailutils/uw-mailutils-2007f.ebuild b/net-mail/uw-mailutils/uw-mailutils-2007f.ebuild
new file mode 100644
index 000000000000..f7fe1d20c3ec
--- /dev/null
+++ b/net-mail/uw-mailutils/uw-mailutils-2007f.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/uw-mailutils/uw-mailutils-2007f.ebuild,v 1.1 2011/09/12 20:49:28 eras Exp $
+
+EAPI=4
+
+inherit eutils flag-o-matic
+
+MY_P="imap-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Mail utilities from the UW"
+HOMEPAGE="http://www.washington.edu/imap/"
+SRC_URI="ftp://ftp.cac.washington.edu/imap/${MY_P}.tar.Z"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="pam ssl"
+
+DEPEND="pam? ( virtual/pam )
+ ssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}
+ !<net-mail/uw-imap-${PV}"
+
+src_prepare() {
+ chmod -R ug+w "${S}"
+
+ epatch "${FILESDIR}/${PN}-2004g.patch"
+ epatch "${FILESDIR}/${PN}-ssl.patch"
+
+ sed -i -e "s|\`cat \$C/CFLAGS\`|${CFLAGS}|g" \
+ src/mailutil/Makefile \
+ src/mtest/Makefile || die "sed failed patching Makefile CFLAGS."
+
+ append-flags -fPIC
+}
+
+src_compile() {
+ local port=slx
+ use elibc_FreeBSD && port=bsf
+ use pam && port=lnp
+ local ssltype=none
+ use ssl && ssltype=nopwd
+ emake -j1 "${port}" EXTRACFLAGS="${CFLAGS}" EXTRALDFLAGS="${LDFLAGS}" SSLTYPE="${ssltype}"
+}
+
+src_install() {
+ dobin mailutil/mailutil mtest/mtest
+ doman src/mailutil/mailutil.1
+}