summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-11-10 00:03:58 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-11-10 00:03:58 +0000
commit4f3c4c05d6ce183ba0c27654c4b9aec731d00c2d (patch)
tree03f2cde51ee3fb77198f0dff936fdd9a179fc884 /net-mail
parentuse ~ instead of = for coin deps (diff)
downloadhistorical-4f3c4c05d6ce183ba0c27654c4b9aec731d00c2d.tar.gz
historical-4f3c4c05d6ce183ba0c27654c4b9aec731d00c2d.tar.bz2
historical-4f3c4c05d6ce183ba0c27654c4b9aec731d00c2d.zip
fixed so that it doesn't install outside of
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/spruce/files/digest-spruce-0.7.6-r2 (renamed from net-mail/spruce/files/digest-spruce-0.7.6-r1)0
-rw-r--r--net-mail/spruce/spruce-0.7.6-r1.ebuild49
-rw-r--r--net-mail/spruce/spruce-0.7.6-r2.ebuild72
3 files changed, 72 insertions, 49 deletions
diff --git a/net-mail/spruce/files/digest-spruce-0.7.6-r1 b/net-mail/spruce/files/digest-spruce-0.7.6-r2
index 4a7450aad5c9..4a7450aad5c9 100644
--- a/net-mail/spruce/files/digest-spruce-0.7.6-r1
+++ b/net-mail/spruce/files/digest-spruce-0.7.6-r2
diff --git a/net-mail/spruce/spruce-0.7.6-r1.ebuild b/net-mail/spruce/spruce-0.7.6-r1.ebuild
deleted file mode 100644
index 667b43c9c573..000000000000
--- a/net-mail/spruce/spruce-0.7.6-r1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Joe Bormolini <lordjoe@bigfoot.com>
-# $Header: /var/cvsroot/gentoo-x86/net-mail/spruce/spruce-0.7.6-r1.ebuild,v 1.1 2001/10/06 10:08:19 azarah Exp $
-
-S=${WORKDIR}/${P}
-DESCRIPTION="Gtk email client"
-SRC_URI="ftp://spruce.sourceforge.net/pub/spruce/devel/${P}.tar.gz"
-HOMEPAGE="http://spruce.sourceforge.net/"
-
-RDEPEND=">=x11-libs/gtk+-1.2.10-r4
- gnome-base/libglade
- ssl? ( >=dev-libs/openssl-0.9.6 )
- gpg? ( app-crypt/gnupg )
- gnome? ( gnome-base/gnome-print-0.29-r1 )"
-
-DEPEND="$RDEPEND nls? ( sys-devel/gettext )"
-
-# Doesn't work? Please test =)
-
-src_compile() {
-
- local myopts
- if [ -z "`use nls`" ]; then
- myopts="--disable-nls"
- fi
- if [ "`use ssl`" ]; then
- echo "SSL does not work"
- # myopts="$myopts --with-ssl"
- fi
- if [ "`use gpg`" ] ; then
- myopts="$myopts --enable-pgp"
- else
- myopts="$myopts --disable-pgp"
- fi
- if [ "`use gnome`" ] ; then
- myopts="$myopts --enable-gnome"
- fi
-
- try ./configure --prefix=/usr --host=${CHOST} ${myopts}
- try make
-
-}
-
-src_install () {
- try make prefix=${D}/usr install
-
- dodoc ChangeLog README README.firewall INSTALL
-}
diff --git a/net-mail/spruce/spruce-0.7.6-r2.ebuild b/net-mail/spruce/spruce-0.7.6-r2.ebuild
new file mode 100644
index 000000000000..b7a0c855e2ee
--- /dev/null
+++ b/net-mail/spruce/spruce-0.7.6-r2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Joe Bormolini <lordjoe@bigfoot.com>
+# Maintainer: Desktop Team <desktop@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-mail/spruce/spruce-0.7.6-r2.ebuild,v 1.1 2001/11/10 00:03:58 hallski Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Gtk email client"
+SRC_URI="ftp://spruce.sourceforge.net/pub/spruce/devel/${P}.tar.gz"
+HOMEPAGE="http://spruce.sourceforge.net/"
+
+RDEPEND=">=x11-libs/gtk+-1.2.10-r4
+ gnome-base/libglade
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ gpg? ( app-crypt/gnupg )
+ gnome? ( gnome-base/gnome-print-0.29-r1 )"
+
+DEPEND="$RDEPEND
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ autoconf
+}
+
+src_compile() {
+ local myopts
+
+ if [ -z "`use nls`" ]; then
+ myopts="--disable-nls"
+ fi
+
+ if [ "`use ssl`" ]; then
+ echo "SSL does not work"
+ # myopts="$myopts --with-ssl"
+ fi
+
+ if [ "`use gpg`" ] ; then
+ myopts="$myopts --enable-pgp"
+ else
+ myopts="$myopts --disable-pgp"
+ fi
+
+ if [ "`use gnome`" ] ; then
+ myopts="$myopts --enable-gnome"
+ fi
+
+ CFLAGS="${CFLAGS} `gnome-config --cflags print gdk_pixbuf`"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ ${myopts} || die
+
+ emake || die
+}
+
+src_install () {
+ # Don't use DESTDIR, it doesn't follow the rules
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ dodoc ChangeLog README README.firewall INSTALL
+}