summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-02-19 18:09:05 +0000
committerMike Frysinger <vapier@gentoo.org>2011-02-19 18:09:05 +0000
commit18793ba627ec0ca25fb8c3f82da7b7755bd1f0af (patch)
treec0acd1df5b5f844208c34d75d2d109364c25f0e5 /net-misc/iputils
parentDrop faad2 dep since xbmc no longer uses it #355371 by BT. (diff)
downloadhistorical-18793ba627ec0ca25fb8c3f82da7b7755bd1f0af.tar.gz
historical-18793ba627ec0ca25fb8c3f82da7b7755bd1f0af.tar.bz2
historical-18793ba627ec0ca25fb8c3f82da7b7755bd1f0af.zip
old
Diffstat (limited to 'net-misc/iputils')
-rw-r--r--net-misc/iputils/files/iputils-20060512-linux-headers.patch10
-rw-r--r--net-misc/iputils/files/iputils-20070202-no-open-max.patch16
-rw-r--r--net-misc/iputils/files/iputils-20071127-gcc34.patch134
-rw-r--r--net-misc/iputils/iputils-20071127-r2.ebuild78
-rw-r--r--net-misc/iputils/iputils-20100418.ebuild73
5 files changed, 0 insertions, 311 deletions
diff --git a/net-misc/iputils/files/iputils-20060512-linux-headers.patch b/net-misc/iputils/files/iputils-20060512-linux-headers.patch
deleted file mode 100644
index 0281f85dceef..000000000000
--- a/net-misc/iputils/files/iputils-20060512-linux-headers.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- rdisc.c
-+++ rdisc.c
-@@ -34,6 +34,7 @@
- #include <sys/time.h>
- /* Do not use "improved" glibc version! */
- #include <linux/limits.h>
-+#include <linux/types.h>
-
- #include <sys/param.h>
- #include <sys/socket.h>
diff --git a/net-misc/iputils/files/iputils-20070202-no-open-max.patch b/net-misc/iputils/files/iputils-20070202-no-open-max.patch
deleted file mode 100644
index 5013ba4fdc06..000000000000
--- a/net-misc/iputils/files/iputils-20070202-no-open-max.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-the OPEN_MAX define has been removed in newer kernel headers so use the
-proper method of getting the value dynamically
-
-http://bugs.gentoo.org/195861
-
---- a/rdisc.c
-+++ b/rdisc.c
-@@ -247,7 +247,7 @@ void do_fork(void)
- if ((pid=fork()) != 0)
- exit(0);
-
-- for (t = 0; t < OPEN_MAX; t++)
-+ for (t = 0; t < sysconf(_SC_OPEN_MAX); t++)
- if (t != s)
- close(t);
-
diff --git a/net-misc/iputils/files/iputils-20071127-gcc34.patch b/net-misc/iputils/files/iputils-20071127-gcc34.patch
deleted file mode 100644
index 36ea5424cf1d..000000000000
--- a/net-misc/iputils/files/iputils-20071127-gcc34.patch
+++ /dev/null
@@ -1,134 +0,0 @@
-iputils has a lot of ugly goto's that break when using
-large gcc inline-limits.
-
-Fixes by Robert Moss and Dave Stahl
-http://bugs.gentoo.org/49241
-http://bugs.gentoo.org/80969
-
---- iputils/tracepath.c
-+++ iputils/tracepath.c
-@@ -76,7 +76,7 @@
- int progress = -1;
- int broken_router;
-
--restart:
-+ while (1) {
- memset(&rcvbuf, -1, sizeof(rcvbuf));
- iov.iov_base = &rcvbuf;
- iov.iov_len = sizeof(rcvbuf);
-@@ -93,7 +93,7 @@
- if (res < 0) {
- if (errno == EAGAIN)
- return progress;
-- goto restart;
-+ continue;
- }
-
- progress = mtu;
-@@ -216,7 +216,7 @@
- perror("NET ERROR");
- return 0;
- }
-- goto restart;
-+ }
- }
-
- int probe_ttl(int fd, int ttl)
-@@ -227,7 +227,6 @@
-
- memset(sndbuf,0,mtu);
-
--restart:
- for (i=0; i<10; i++) {
- int res;
-
-@@ -243,7 +242,8 @@
- if (res==0)
- return 0;
- if (res > 0)
-- goto restart;
-+ i = 0;
-+ continue;
- }
- hisptr = (hisptr + 1)&63;
-
---- iputils/tracepath6.c
-+++ iputils/tracepath6.c
-@@ -66,7 +66,7 @@
- int progress = -1;
- int broken_router;
-
--restart:
-+ while (1) {
- memset(&rcvbuf, -1, sizeof(rcvbuf));
- iov.iov_base = &rcvbuf;
- iov.iov_len = sizeof(rcvbuf);
-@@ -83,7 +83,7 @@
- if (res < 0) {
- if (errno == EAGAIN)
- return progress;
-- goto restart;
-+ continue;
- }
-
- progress = 2;
-@@ -222,34 +222,29 @@
- perror("NET ERROR");
- return 0;
- }
-- goto restart;
-+ }
- }
-
- int probe_ttl(int fd, int ttl)
- {
-- int i;
-+ int i=0, res;
- char sndbuf[mtu];
- struct probehdr *hdr = (struct probehdr*)sndbuf;
-
--restart:
--
-- for (i=0; i<10; i++) {
-- int res;
--
-- hdr->ttl = ttl;
-- gettimeofday(&hdr->tv, NULL);
-- if (send(fd, sndbuf, mtu-overhead, 0) > 0)
-- break;
-- res = recverr(fd, ttl);
-- if (res==0)
-- return 0;
-- if (res > 0)
-- goto restart;
-- }
--
-- if (i<10) {
-- int res;
--
-+ while (i<10) {
-+ for (i=0; i<10; i++) {
-+ hdr->ttl = ttl;
-+ gettimeofday(&hdr->tv, NULL);
-+ if (send(fd, sndbuf, mtu-overhead, 0) > 0)
-+ break;
-+ res = recverr(fd, ttl);
-+ if (res==0)
-+ return 0;
-+ if (res > 0) {
-+ i = 0;
-+ continue;
-+ }
-+ }
- data_wait(fd);
- if (recv(fd, sndbuf, sizeof(sndbuf), MSG_DONTWAIT) > 0) {
- printf("%2d?: reply received 8)\n", ttl);
-@@ -257,7 +252,7 @@
- }
- res = recverr(fd, ttl);
- if (res == 1)
-- goto restart;
-+ continue;
- return res;
- }
-
diff --git a/net-misc/iputils/iputils-20071127-r2.ebuild b/net-misc/iputils/iputils-20071127-r2.ebuild
deleted file mode 100644
index c0e5306c569e..000000000000
--- a/net-misc/iputils/iputils-20071127-r2.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/iputils/iputils-20071127-r2.ebuild,v 1.2 2010/01/07 15:52:15 fauli Exp $
-
-inherit flag-o-matic eutils toolchain-funcs
-
-DESCRIPTION="Network monitoring tools including ping and ping6"
-HOMEPAGE="http://www.linux-foundation.org/en/Net:Iputils"
-SRC_URI="http://www.skbuff.net/iputils/iputils-s${PV}.tar.bz2
- mirror://gentoo/iputils-s${PV}-manpages.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux"
-IUSE="doc idn ipv6 SECURITY_HAZARD static"
-
-DEPEND="virtual/os-headers
- doc? (
- app-text/openjade
- dev-perl/SGMLSpm
- app-text/docbook-sgml-dtd
- app-text/docbook-sgml-utils
- )"
-RDEPEND="!net-misc/rarpd
- idn? ( net-dns/libidn )"
-
-S=${WORKDIR}/${PN}-s${PV}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-gcc34.patch
- epatch "${FILESDIR}"/021109-uclibc-no-ether_ntohost.patch
- epatch "${FILESDIR}"/${PN}-20070202-makefile.patch
- epatch "${FILESDIR}"/${P}-kernel-ifaddr.patch
- epatch "${FILESDIR}"/${PN}-20060512-linux-headers.patch
- epatch "${FILESDIR}"/${PN}-20070202-no-open-max.patch #195861
- epatch "${FILESDIR}"/${PN}-20070202-idn.patch #218638
- use SECURITY_HAZARD && epatch "${FILESDIR}"/${PN}-20071127-nonroot-floodping.patch
- use static && append-ldflags -static
- use ipv6 || sed -i -e 's:IPV6_TARGETS=:#IPV6_TARGETS=:' Makefile
- export IDN=$(use idn && echo yes)
-}
-
-src_compile() {
- tc-export CC
- emake || die "make main failed"
-
- # We include the extra check for docbook2html
- # because when we emerge from a stage1/stage2,
- # it may not exist #23156
- if use doc && type -P docbook2html >/dev/null ; then
- emake -j1 html || die
- fi
-}
-
-src_install() {
- into /
- dobin ping || die "ping"
- use ipv6 && dobin ping6
- dosbin arping || die "arping"
- into /usr
- dosbin tracepath || die "tracepath"
- use ipv6 && dosbin trace{path,route}6
- dosbin clockdiff rarpd rdisc ipg tftpd || die "misc sbin"
-
- fperms 4711 /bin/ping
- use ipv6 && fperms 4711 /bin/ping6 /usr/sbin/traceroute6
-
- dodoc INSTALL RELNOTES
- use ipv6 \
- && dosym ping.8 /usr/share/man/man8/ping6.8 \
- || rm -f doc/*6.8
- rm -f doc/setkey.8
- doman doc/*.8
-
- use doc && dohtml doc/*.html
-}
diff --git a/net-misc/iputils/iputils-20100418.ebuild b/net-misc/iputils/iputils-20100418.ebuild
deleted file mode 100644
index fda7d52a44ad..000000000000
--- a/net-misc/iputils/iputils-20100418.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/iputils/iputils-20100418.ebuild,v 1.9 2010/09/06 20:11:05 ranger Exp $
-
-inherit flag-o-matic eutils toolchain-funcs
-
-DESCRIPTION="Network monitoring tools including ping and ping6"
-HOMEPAGE="http://www.linux-foundation.org/en/Net:Iputils"
-SRC_URI="http://www.skbuff.net/iputils/iputils-s${PV}.tar.bz2
- mirror://gentoo/iputils-s${PV}-manpages.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-linux ~x86-linux"
-IUSE="doc idn ipv6 SECURITY_HAZARD ssl static"
-
-# sysfsutils is needed for libsysfs which is used by arping only
-RDEPEND="!net-misc/rarpd
- ssl? ( dev-libs/openssl )
- idn? ( net-dns/libidn )
- sys-fs/sysfsutils"
-DEPEND="${RDEPEND}
- virtual/os-headers"
-
-S=${WORKDIR}/${PN}-s${PV}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/021109-uclibc-no-ether_ntohost.patch
- epatch "${FILESDIR}"/${PN}-20100418-openssl.patch #335436
- epatch "${FILESDIR}"/${PN}-20100418-so_mark.patch #335347
- epatch "${FILESDIR}"/${PN}-20100418-makefile.patch
- epatch "${FILESDIR}"/${PN}-20100418-proper-libs.patch #332703
- epatch "${FILESDIR}"/${PN}-20100418-printf-size.patch
- epatch "${FILESDIR}"/${PN}-20100418-aliasing.patch
- epatch "${FILESDIR}"/${PN}-20071127-kernel-ifaddr.patch
- epatch "${FILESDIR}"/${PN}-20070202-idn.patch #218638
- epatch "${FILESDIR}"/${PN}-20100418-ping-CVE-2010-2529.patch #332527
- use SECURITY_HAZARD && epatch "${FILESDIR}"/${PN}-20071127-nonroot-floodping.patch
- use static && append-ldflags -static
- use ssl && append-cppflags -DHAVE_OPENSSL
- use ipv6 || sed -i -e 's:IPV6_TARGETS=:#IPV6_TARGETS=:' Makefile
- export IDN=$(use idn && echo yes)
-}
-
-src_compile() {
- tc-export CC
- emake || die "make main failed"
-}
-
-src_install() {
- into /
- dobin ping || die "ping"
- use ipv6 && dobin ping6
- dosbin arping || die "arping"
- into /usr
- dosbin tracepath || die "tracepath"
- use ipv6 && dosbin trace{path,route}6
- dosbin clockdiff rarpd rdisc ipg tftpd || die "misc sbin"
-
- fperms 4711 /bin/ping
- use ipv6 && fperms 4711 /bin/ping6 /usr/sbin/traceroute6
-
- dodoc INSTALL RELNOTES
- use ipv6 \
- && dosym ping.8 /usr/share/man/man8/ping6.8 \
- || rm -f doc/*6.8
- rm -f doc/setkey.8
- doman doc/*.8
-
- use doc && dohtml doc/*.html
-}