summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2010-07-07 17:46:20 +0000
committerDoug Goldstein <cardoe@gentoo.org>2010-07-07 17:46:20 +0000
commit272baf1420c2c6b03647ef69f311a6db9d52927f (patch)
treeefe68d88ed00b4529db0f4005ecc9fba93776809 /net-misc/netcf
parentppc64 stable wrt #321447 (diff)
downloadhistorical-272baf1420c2c6b03647ef69f311a6db9d52927f.tar.gz
historical-272baf1420c2c6b03647ef69f311a6db9d52927f.tar.bz2
historical-272baf1420c2c6b03647ef69f311a6db9d52927f.zip
Add netcf to the tree but it doesn't actually support Gentoo yet
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'net-misc/netcf')
-rw-r--r--net-misc/netcf/ChangeLog10
-rw-r--r--net-misc/netcf/Manifest4
-rw-r--r--net-misc/netcf/metadata.xml12
-rw-r--r--net-misc/netcf/netcf-0.1.6.ebuild31
4 files changed, 57 insertions, 0 deletions
diff --git a/net-misc/netcf/ChangeLog b/net-misc/netcf/ChangeLog
new file mode 100644
index 000000000000..3d048c5c42ce
--- /dev/null
+++ b/net-misc/netcf/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-misc/netcf
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netcf/ChangeLog,v 1.1 2010/07/07 17:46:20 cardoe Exp $
+
+*netcf-0.1.6 (07 Jul 2010)
+
+ 07 Jul 2010; Doug Goldstein <cardoe@gentoo.org> +netcf-0.1.6.ebuild,
+ +metadata.xml:
+ Add netcf to the tree but it doesn't actually support Gentoo yet
+
diff --git a/net-misc/netcf/Manifest b/net-misc/netcf/Manifest
new file mode 100644
index 000000000000..eb739eabb64a
--- /dev/null
+++ b/net-misc/netcf/Manifest
@@ -0,0 +1,4 @@
+DIST netcf-0.1.6.tar.gz 463217 RMD160 4c812b7dc725d50438081b738cbf2758f8881e80 SHA1 0caf9c1f8c7e22dc93e53cfa42bd1527c655816e SHA256 f6c8b5f145c085fd0de65e4d71c7cecd51dd8ab158b667c2382b8ebe2e3b50f4
+EBUILD netcf-0.1.6.ebuild 797 RMD160 a20bd4224a38c9c911c4ea3a6f927ef3bac4aca9 SHA1 c1d213764827d4605ae048257cc097cfad83505b SHA256 34272a82c5ead7b1ca0c0a7071072376026adbb61c2e6d7a1c2b92d9561dd56d
+MISC ChangeLog 385 RMD160 05eb5a921942ae3ebc3b2c8bb96ea3904e82d97e SHA1 12c64306de5bc454ff81fcd8fd280444bc7d63a9 SHA256 43e3d7b26979d722411c0c597c78f9393d3b6ffcc56c84e37154883596d7268c
+MISC metadata.xml 335 RMD160 780de50d548ada6133ab9feb900a104418501eef SHA1 580a913dc3fa6220ef0a70869ee4e54249df9b04 SHA256 6dcb3f7931c0c32fc4ab8999c5a0987237820b4833944665bd94fd9617dffda6
diff --git a/net-misc/netcf/metadata.xml b/net-misc/netcf/metadata.xml
new file mode 100644
index 000000000000..0b48d6a1fd46
--- /dev/null
+++ b/net-misc/netcf/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>cardoe@gentoo.org</email>
+ <name>Doug Goldstein</name>
+ <description>Anyone can take over this package if they
+ want</description>
+ </maintainer>
+</pkgmetadata>
+
diff --git a/net-misc/netcf/netcf-0.1.6.ebuild b/net-misc/netcf/netcf-0.1.6.ebuild
new file mode 100644
index 000000000000..98a0c567f4d3
--- /dev/null
+++ b/net-misc/netcf/netcf-0.1.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netcf/netcf-0.1.6.ebuild,v 1.1 2010/07/07 17:46:20 cardoe Exp $
+
+EAPI=2
+
+DESCRIPTION="netcf is a cross-platform network configuration library"
+HOMEPAGE="https://fedorahosted.org/netcf/"
+SRC_URI="https://fedorahosted.org/released/netcf/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=app-admin/augeas-0.5.0
+ dev-libs/libnl
+ dev-libs/libxml2
+ dev-libs/libxslt
+ sys-libs/readline"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # static libs are a waste of time and disk for this
+ econf --disable-static
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS ChangeLog README NEWS
+}