summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Keadle <mkeadle@gentoo.org>2002-12-12 02:00:24 +0000
committerMatt Keadle <mkeadle@gentoo.org>2002-12-12 02:00:24 +0000
commit4784a799cd702108d1ca91cc5b647c79f4ecb3f5 (patch)
treef8755dab8d60549ffb76b0ed5a4aaa3f953e55e5 /net-misc/tn5250
parentNew version (diff)
downloadhistorical-4784a799cd702108d1ca91cc5b647c79f4ecb3f5.tar.gz
historical-4784a799cd702108d1ca91cc5b647c79f4ecb3f5.tar.bz2
historical-4784a799cd702108d1ca91cc5b647c79f4ecb3f5.zip
initial import. ~x86 for testing.
Diffstat (limited to 'net-misc/tn5250')
-rw-r--r--net-misc/tn5250/ChangeLog12
-rw-r--r--net-misc/tn5250/files/digest-tn5250-0.16.51
-rw-r--r--net-misc/tn5250/tn5250-0.16.5.ebuild66
3 files changed, 79 insertions, 0 deletions
diff --git a/net-misc/tn5250/ChangeLog b/net-misc/tn5250/ChangeLog
new file mode 100644
index 000000000000..4a50328c933b
--- /dev/null
+++ b/net-misc/tn5250/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for net-misc/tn5250
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header
+
+*tn5250-0.16.5 (11 Dec 2002)
+
+ 11 Dec 2002; Matt Keadle <mkeadle@gentoo.org> tn5250-0.16.5.ebuild
+ files/digest-tn5250-0.16.5 :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. Thanks to CJ Kucera for submitting this ebuild
+ in bug #9575.
diff --git a/net-misc/tn5250/files/digest-tn5250-0.16.5 b/net-misc/tn5250/files/digest-tn5250-0.16.5
new file mode 100644
index 000000000000..877241cc917e
--- /dev/null
+++ b/net-misc/tn5250/files/digest-tn5250-0.16.5
@@ -0,0 +1 @@
+MD5 2f9ef4509198e96bb184577fdddfce6d tn5250-0.16.5.tar.gz 455546
diff --git a/net-misc/tn5250/tn5250-0.16.5.ebuild b/net-misc/tn5250/tn5250-0.16.5.ebuild
new file mode 100644
index 000000000000..0eee3efc5fc0
--- /dev/null
+++ b/net-misc/tn5250/tn5250-0.16.5.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tn5250/tn5250-0.16.5.ebuild,v 1.1 2002/12/12 02:00:24 mkeadle Exp $
+
+DESCRIPTION="Telnet client for the IBM AS/400 that emulates 5250 terminals and printers."
+HOMEPAGE="http://tn5250.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="X ssl slang"
+
+DEPEND="sys-libs/ncurses
+ X? ( virtual/x11 )
+ ssl? ( dev-libs/openssl )
+ slang? ( sys-libs/slang )"
+
+S="${WORKDIR}/${P}"
+
+src_unpack() {
+ unpack ${A}
+
+ # First, for some reason, TRUE and FALSE aren't defined
+ # for the compile. This causes some problems. ???
+ echo >> ${S}/src/tn5250-config.h.in
+ echo "/* Define TRUE and FALSE */" >> ${S}/src/tn5250-config.h.in
+ echo "#define FALSE 0" >> ${S}/src/tn5250-config.h.in
+ echo "#define TRUE !FALSE" >> ${S}/src/tn5250-config.h.in
+
+ # Next, the Makefile for the terminfo settings tries to remove
+ # some files it doesn't have access to. We can just remove those
+ # lines.
+ cd ${S}/linux
+ cp Makefile.in Makefile.in.orig
+ sed -e "/rm -f \/usr\/.*\/terminfo.*5250/d" \
+ Makefile.in.orig > Makefile.in
+}
+
+src_compile() {
+ local myconf
+ myconf=""
+ use X && myconf="${myconf} --with-x"
+ use ssl && myconf="${myconf} --with-ssl"
+ use slang && myconf="${myconf} --with-slang"
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc \
+ ${myconf} || die "./configure failed"
+ emake || die
+}
+
+src_install() {
+
+ # The TERMINFO variable needs to be defined for the install
+ # to work, because the install calls "tic." man tic for
+ # details.
+ mkdir -p ${D}/usr/share/terminfo
+ make DESTDIR=${D} \
+ TERMINFO=${D}/usr/share/terminfo install || die
+ dodoc AUTHORS BUGS COPYING INSTALL NEWS README README.ssl TODO
+ dohtml -r doc/*
+}