summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2004-09-19 20:40:23 +0000
committerMichael Imhof <tantive@gentoo.org>2004-09-19 20:40:23 +0000
commit44b2dd8b576bdd2e8e648f49dc5124c192a3ddde (patch)
treea79b3cb9c41e866cdf6f4b868b3c8056d85b895c /net-misc/ucarp
parentFixed install process for ijs. The previous hack didn't work when we passed ... (diff)
downloadhistorical-44b2dd8b576bdd2e8e648f49dc5124c192a3ddde.tar.gz
historical-44b2dd8b576bdd2e8e648f49dc5124c192a3ddde.tar.bz2
historical-44b2dd8b576bdd2e8e648f49dc5124c192a3ddde.zip
Version bumped. Closes #64310.
Diffstat (limited to 'net-misc/ucarp')
-rw-r--r--net-misc/ucarp/ChangeLog7
-rw-r--r--net-misc/ucarp/Manifest14
-rw-r--r--net-misc/ucarp/files/digest-ucarp-1.11
-rw-r--r--net-misc/ucarp/ucarp-1.1.ebuild32
4 files changed, 52 insertions, 2 deletions
diff --git a/net-misc/ucarp/ChangeLog b/net-misc/ucarp/ChangeLog
index e6fa7ba55025..7aab52188ee2 100644
--- a/net-misc/ucarp/ChangeLog
+++ b/net-misc/ucarp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/ucarp
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ucarp/ChangeLog,v 1.3 2004/08/08 00:27:03 slarti Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ucarp/ChangeLog,v 1.4 2004/09/19 20:40:23 tantive Exp $
+
+*ucarp-1.1 (19 Sep 2004)
+
+ 19 Sep 2004; Michael Imhof <tantive@gentoo.org> +ucarp-1.1.ebuild:
+ Version bumped. Closes #64310.
08 Aug 2004; Tom Martin <slarti@gentoo.org> ucarp-0.7.ebuild:
Typo in DESCRIPTION: implimentation -> implementation. Bug 59717.
diff --git a/net-misc/ucarp/Manifest b/net-misc/ucarp/Manifest
index 79054b908dcd..46381eae22fe 100644
--- a/net-misc/ucarp/Manifest
+++ b/net-misc/ucarp/Manifest
@@ -1,3 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 b63324a9a548d29d734a9ce346ccbe31 ucarp-1.1.ebuild 1163
+MD5 645f6eec496365147c033dfa08fb7087 ChangeLog 674
MD5 8482b270f56141aa579113e78ab976ff ucarp-0.7.ebuild 726
-MD5 5694f99e67ca04e59ac5a6db3343e769 ChangeLog 544
+MD5 3f0a78b9bbdbe61fd16e25ceb4ff1627 files/digest-ucarp-1.1 61
MD5 705d7cc5a9540cf4265ba8890308ef58 files/digest-ucarp-0.7 61
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.2.4 (GNU/Linux)
+
+iD8DBQFBTe7FKtJO8LeSoosRAjoMAKCFzFRl+MzXGDN0Enlq3AsiT8gYpwCggi4/
+y4SZGfja3oIvruKS8OKLIiE=
+=bWXe
+-----END PGP SIGNATURE-----
diff --git a/net-misc/ucarp/files/digest-ucarp-1.1 b/net-misc/ucarp/files/digest-ucarp-1.1
new file mode 100644
index 000000000000..2d7b1a2b5b8c
--- /dev/null
+++ b/net-misc/ucarp/files/digest-ucarp-1.1
@@ -0,0 +1 @@
+MD5 59122fd8efd49ac18c5da60e08e93493 ucarp-1.1.tar.gz 189708
diff --git a/net-misc/ucarp/ucarp-1.1.ebuild b/net-misc/ucarp/ucarp-1.1.ebuild
new file mode 100644
index 000000000000..efd7cc8659a1
--- /dev/null
+++ b/net-misc/ucarp/ucarp-1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ucarp/ucarp-1.1.ebuild,v 1.1 2004/09/19 20:40:23 tantive Exp $
+
+inherit eutils
+
+DESCRIPTION="UCARP allows a couple of hosts to share common virtual IP addresses in order to provide automatic failover. It is a portable userland implementation of the secure and patent-free Common Address Redundancy Protocol (CARP, OpenBSD's alternative to the VRRP).
+Strong points of the CARP protocol are : very low overhead, cryptographically signed messages, interoperability between different operating systems and no need for any dedicated extra network link between redundant hosts.
+"
+HOMEPAGE="http://www.ucarp.org"
+LICENSE="GPL-2"
+DEPEND=">=net-libs/libpcap-0.8.3-r1"
+SRC_URI="ftp://ftp.ucarp.org/pub/ucarp/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE=""
+
+src_compile() {
+ cd "${S}"
+ econf || die
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install-strip || die
+ #einstall || die
+
+ dodoc README INSTALL NEWS ChangeLog || die
+ dodoc examples/linux/vip-up.sh examples/linux/vip-down.sh
+}