summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-06-08 19:49:03 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-06-08 19:49:03 +0000
commit09791aec614f1fd7730d656574e31ffb6314abcb (patch)
treea21f67ab0c203fe1f8491f22f4fafa654aa5767d /net-misc
parentFixed checks for ffmpeg features. (diff)
downloadhistorical-09791aec614f1fd7730d656574e31ffb6314abcb.tar.gz
historical-09791aec614f1fd7730d656574e31ffb6314abcb.tar.bz2
historical-09791aec614f1fd7730d656574e31ffb6314abcb.zip
Bug #74322. Based on initial submission by Andre Kloth <bugs-gentoo@blubbmon.de>.
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/nstx/ChangeLog11
-rw-r--r--net-misc/nstx/Manifest4
-rw-r--r--net-misc/nstx/files/digest-nstx-1.1_beta61
-rw-r--r--net-misc/nstx/metadata.xml8
-rw-r--r--net-misc/nstx/nstx-1.1_beta6.ebuild36
5 files changed, 60 insertions, 0 deletions
diff --git a/net-misc/nstx/ChangeLog b/net-misc/nstx/ChangeLog
new file mode 100644
index 000000000000..cd8b918eaa20
--- /dev/null
+++ b/net-misc/nstx/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-misc/nstx
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nstx/ChangeLog,v 1.1 2005/06/08 19:49:03 robbat2 Exp $
+
+*nstx-1.1_beta6 (08 Jun 2005)
+
+ 08 Jun 2005; Robin H. Johnson <robbat2@gentoo.org> +metadata.xml,
+ +nstx-1.1_beta6.ebuild:
+ Bug #74322. Based on initial submission by Andre Kloth
+ <bugs-gentoo@blubbmon.de>.
+
diff --git a/net-misc/nstx/Manifest b/net-misc/nstx/Manifest
new file mode 100644
index 000000000000..9bedbd715c7d
--- /dev/null
+++ b/net-misc/nstx/Manifest
@@ -0,0 +1,4 @@
+MD5 94d81a6bf2ee948040e8f6f051293c0a ChangeLog 412
+MD5 cd6bda7470de36aaddf4274b283431e8 nstx-1.1_beta6.ebuild 802
+MD5 21cd68602737d7c996bceabf6e62c468 metadata.xml 223
+MD5 9943b0c4bfa3099c67a0abbc9d0ff048 files/digest-nstx-1.1_beta6 62
diff --git a/net-misc/nstx/files/digest-nstx-1.1_beta6 b/net-misc/nstx/files/digest-nstx-1.1_beta6
new file mode 100644
index 000000000000..31b501629164
--- /dev/null
+++ b/net-misc/nstx/files/digest-nstx-1.1_beta6
@@ -0,0 +1 @@
+MD5 275abd75a856b07a798b1f2360088cf5 nstx-1.1-beta6.tgz 20458
diff --git a/net-misc/nstx/metadata.xml b/net-misc/nstx/metadata.xml
new file mode 100644
index 000000000000..5d9f5be9d49d
--- /dev/null
+++ b/net-misc/nstx/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>robbat2@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/net-misc/nstx/nstx-1.1_beta6.ebuild b/net-misc/nstx/nstx-1.1_beta6.ebuild
new file mode 100644
index 000000000000..74e8a094edcd
--- /dev/null
+++ b/net-misc/nstx/nstx-1.1_beta6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nstx/nstx-1.1_beta6.ebuild,v 1.1 2005/06/08 19:49:03 robbat2 Exp $
+
+inherit linux-info versionator
+
+MY_PV=$(replace_version_separator 2 - "${PV}")
+MY_P="${PN}-${MY_PV}"
+
+CONFIG_CHECK="ETHERTAP"
+
+DESCRIPTION="IP over DNS tunnel"
+SRC_URI="http://dereference.de/nstx/${MY_P}.tgz"
+HOMEPAGE="http://dereference.de/nstx/"
+DEPEND="virtual/linux-sources"
+RDEPEND=""
+KEYWORDS="~x86"
+IUSE=""
+LICENSE="GPL-2"
+SLOT="0"
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ into /usr
+ dosbin nstxcd nstxd
+ dodoc README Changelog
+}
+
+pkg_postinst() {
+ einfo "Please read the documentation provided in"
+ einfo " /usr/share/doc/${PF}/README.gz"
+}