summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2010-08-18 15:05:33 +0000
committerTiziano Müller <dev-zero@gentoo.org>2010-08-18 15:05:33 +0000
commitfefae2c14cff48fa6444a95c4d8c2ff136734c58 (patch)
treea0f72eb0e11a0bbae2e4a8693480436ef69b60ca /net-nds/gosa-plugin-systems
parentStable on amd64 wrt bug #329583 (diff)
downloadhistorical-fefae2c14cff48fa6444a95c4d8c2ff136734c58.tar.gz
historical-fefae2c14cff48fa6444a95c4d8c2ff136734c58.tar.bz2
historical-fefae2c14cff48fa6444a95c4d8c2ff136734c58.zip
Initial commit, needed for gosa-plugin-samba and gosa-plugin-mail.
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'net-nds/gosa-plugin-systems')
-rw-r--r--net-nds/gosa-plugin-systems/ChangeLog10
-rw-r--r--net-nds/gosa-plugin-systems/Manifest4
-rw-r--r--net-nds/gosa-plugin-systems/gosa-plugin-systems-2.6.10.ebuild44
-rw-r--r--net-nds/gosa-plugin-systems/metadata.xml12
4 files changed, 70 insertions, 0 deletions
diff --git a/net-nds/gosa-plugin-systems/ChangeLog b/net-nds/gosa-plugin-systems/ChangeLog
new file mode 100644
index 000000000000..81c60fcbb4d2
--- /dev/null
+++ b/net-nds/gosa-plugin-systems/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-nds/gosa-plugin-systems
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/gosa-plugin-systems/ChangeLog,v 1.1 2010/08/18 15:05:33 dev-zero Exp $
+
+*gosa-plugin-systems-2.6.10 (18 Aug 2010)
+
+ 18 Aug 2010; Tiziano Müller <dev-zero@gentoo.org>
+ +gosa-plugin-systems-2.6.10.ebuild, +metadata.xml:
+ Initial commit, needed for gosa-plugin-samba and gosa-plugin-mail.
+
diff --git a/net-nds/gosa-plugin-systems/Manifest b/net-nds/gosa-plugin-systems/Manifest
new file mode 100644
index 000000000000..e70d6b977744
--- /dev/null
+++ b/net-nds/gosa-plugin-systems/Manifest
@@ -0,0 +1,4 @@
+DIST gosa-plugin-systems-2.6.10.tar.bz2 148131 RMD160 9a3da0b96e416575d0c4bdab68acaf05bfca986f SHA1 6b701e84d80ce4fa450f75d897ffcdae2af1422a SHA256 ab9aed6368dea0a38bdcadc00be63845435f9adb9f792ee96efacef73827b3cc
+EBUILD gosa-plugin-systems-2.6.10.ebuild 1126 RMD160 fbf1a0275328eeb2e854119b5a3b0f38c49fdf44 SHA1 9105484ddf56ff39ce22226cb2307ca5b0ece1ae SHA256 b694e1c7cc055bbdd7b885815f36b609cf90a0f044a077a860f0d557ca7fef8d
+MISC ChangeLog 448 RMD160 c0c1817e07c72e35cd733f718699f3c3d7bda8b8 SHA1 eaf081f05ba66fb6f35ad11bc2a40f277095b0fa SHA256 3ed86bcd3eeefa09904faa524d1698ead821ee74c12a293d942873eaefdf3c72
+MISC metadata.xml 359 RMD160 96620757d6d325b880ac0a88eebae279ad7efef1 SHA1 358f0611dd431a453cdb2ece6ff8a9c4a0e1f5cc SHA256 22c27f7439772e98075452bac86ea3467b408bb04836420fbb8d35a72a54f40b
diff --git a/net-nds/gosa-plugin-systems/gosa-plugin-systems-2.6.10.ebuild b/net-nds/gosa-plugin-systems/gosa-plugin-systems-2.6.10.ebuild
new file mode 100644
index 000000000000..eab92c679991
--- /dev/null
+++ b/net-nds/gosa-plugin-systems/gosa-plugin-systems-2.6.10.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/gosa-plugin-systems/gosa-plugin-systems-2.6.10.ebuild,v 1.1 2010/08/18 15:05:33 dev-zero Exp $
+
+EAPI=3
+
+inherit eutils
+
+DESCRIPTION="GOsa plugin for common systems integration"
+HOMEPAGE="https://oss.gonicus.de/labs/gosa/wiki/WikiStart."
+SRC_URI="ftp://oss.gonicus.de/pub/gosa/${P}.tar.bz2
+ http://oss.gonicus.de/pub/gosa/${P}.tar.bz2
+ ftp://oss.gonicus.de/pub/gosa/archive/${P}.tar.bz2
+ http://oss.gonicus.de/pub/gosa/archive/${P}.tar.bz2 "
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="~net-nds/gosa-core-${PV}"
+
+GOSA_COMPONENT="${PN/gosa-plugin-}"
+
+src_install() {
+ insinto /usr/share/gosa/html/plugins/${GOSA_COMPONENT}/
+ doins -r html/*
+
+ insinto /usr/share/gosa/locale/plugins/${GOSA_COMPONENT}/
+ doins -r locale/*
+
+ insinto /usr/share/gosa/plugins
+ doins -r admin
+
+ insinto /usr/share/gosa/doc/plugins/${GOSA_COMPONENT}/
+ doins -r help/*
+}
+
+pkg_postinst() {
+ ebegin "Updating class cache and locales"
+ "${EROOT}"usr/sbin/update-gosa
+ eend $?
+}
diff --git a/net-nds/gosa-plugin-systems/metadata.xml b/net-nds/gosa-plugin-systems/metadata.xml
new file mode 100644
index 000000000000..0c6ccc026e3b
--- /dev/null
+++ b/net-nds/gosa-plugin-systems/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>dev-zero@gentoo.org</email>
+ <name>Tiziano Müller</name>
+ </maintainer>
+ <upstream>
+ <changelog>http://oss.gonicus.de/pub/gosa/Changelog</changelog>
+ </upstream>
+</pkgmetadata>