summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-01 04:07:37 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-01 04:07:37 +0000
commit97691524f73127600972e79b18cd860e7441f9fa (patch)
tree3f67f164fbc28814fc29d9873e019082d9d34c52 /net-print
parent-amd64 (diff)
downloadhistorical-97691524f73127600972e79b18cd860e7441f9fa.tar.gz
historical-97691524f73127600972e79b18cd860e7441f9fa.tar.bz2
historical-97691524f73127600972e79b18cd860e7441f9fa.zip
Add patch for gcc-3.4 #49736 by ecco@piggy.demon.nl.
Diffstat (limited to 'net-print')
-rw-r--r--net-print/hpijs/ChangeLog6
-rw-r--r--net-print/hpijs/files/hpijs-1.5-gcc34.patch27
-rw-r--r--net-print/hpijs/hpijs-1.5.ebuild41
3 files changed, 55 insertions, 19 deletions
diff --git a/net-print/hpijs/ChangeLog b/net-print/hpijs/ChangeLog
index 3b46454820b7..f8106ec27464 100644
--- a/net-print/hpijs/ChangeLog
+++ b/net-print/hpijs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-print/hpijs
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/hpijs/ChangeLog,v 1.22 2004/04/27 22:04:28 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/hpijs/ChangeLog,v 1.23 2004/06/01 04:07:37 vapier Exp $
+
+ 01 Jun 2004; Mike Frysinger <vapier@gentoo.org>
+ +files/hpijs-1.5-gcc34.patch, hpijs-1.5.ebuild:
+ Add patch for gcc-3.4 #49736 by ecco@piggy.demon.nl.
27 Apr 2004; Aron Griffis <agriffis@gentoo.org> hpijs-1.4.1.ebuild,
hpijs-1.5.ebuild:
diff --git a/net-print/hpijs/files/hpijs-1.5-gcc34.patch b/net-print/hpijs/files/hpijs-1.5-gcc34.patch
new file mode 100644
index 000000000000..7414d1dd98ba
--- /dev/null
+++ b/net-print/hpijs/files/hpijs-1.5-gcc34.patch
@@ -0,0 +1,27 @@
+diff -u hpijs-1.5-orig/hpijs.cpp hpijs-1.5/hpijs.cpp
+--- hpijs-1.5-orig/hpijs.cpp 2004-05-02 19:25:56.135556960 +0000
++++ hpijs-1.5/hpijs.cpp 2004-05-02 19:56:03.839744152 +0000
+@@ -79,7 +79,10 @@
+ {
+ BOOL bDevText;
+ bug("unable to set Quality=%d, ColorMode=%d, MediaType=%d, err=%d\n", pSS->Quality, pSS->ColorMode, pSS->MediaType, r);
+- pSS->pPC->GetPrintModeSettings ((QUALITY_MODE)pSS->Quality, (MEDIATYPE)pSS->MediaType, (COLORMODE)pSS->ColorMode, bDevText);
++ apdk::QUALITY_MODE quality_mode = (QUALITY_MODE)pSS->Quality;
++ apdk::MEDIATYPE mediatype = (MEDIATYPE)pSS->MediaType;
++ apdk::COLORMODE colormode = (COLORMODE)pSS->ColorMode;
++ pSS->pPC->GetPrintModeSettings (quality_mode, mediatype, colormode, bDevText);
+ bug("following will be used Quality=%d, ColorMode=%d, MediaType=%d\n", pSS->Quality, pSS->ColorMode, pSS->MediaType);
+ }
+
+@@ -211,7 +214,10 @@
+
+ /* Got a valid device class, let's set some print mode defaults. */
+ BOOL bDevText;
+- pSS->pPC->GetPrintModeSettings ((QUALITY_MODE)pSS->Quality, (MEDIATYPE)pSS->MediaType, (COLORMODE)pSS->ColorMode, bDevText);
++ apdk::QUALITY_MODE quality_mode = (QUALITY_MODE)pSS->Quality;
++ apdk::MEDIATYPE mediatype = (MEDIATYPE)pSS->MediaType;
++ apdk::COLORMODE colormode = (COLORMODE)pSS->ColorMode;
++ pSS->pPC->GetPrintModeSettings (quality_mode, mediatype, colormode, bDevText);
+ }
+ else
+ {
diff --git a/net-print/hpijs/hpijs-1.5.ebuild b/net-print/hpijs/hpijs-1.5.ebuild
index 24cf43b82057..7be0459ee57c 100644
--- a/net-print/hpijs/hpijs-1.5.ebuild
+++ b/net-print/hpijs/hpijs-1.5.ebuild
@@ -1,33 +1,38 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/hpijs/hpijs-1.5.ebuild,v 1.5 2004/04/27 22:04:28 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/hpijs/hpijs-1.5.ebuild,v 1.6 2004/06/01 04:07:37 vapier Exp $
inherit gnuconfig eutils
DB_V=${PV}-20031125
DESCRIPTION="The HP Inkjet server for Ghostscript. Provides best output for HP Inkjet Printers and some LaserJets"
-HOMEPAGE="http://hpinkjet.sourceforge.net"
-KEYWORDS="x86 ~ppc ~alpha ~sparc ~hppa ~amd64"
+HOMEPAGE="http://hpinkjet.sourceforge.net/"
SRC_URI="mirror://sourceforge/hpinkjet/${P}.tar.gz
http://www.linuxprinting.org/download/foomatic/foomatic-db-hpijs-${DB_V}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~alpha ~sparc ~hppa ~amd64"
+IUSE="cups foomaticdb ppds"
+
DEPEND="virtual/ghostscript
cups? ( net-print/cups )
net-print/foomatic-filters
foomaticdb? ( net-print/foomatic-db-engine )"
-LICENSE="BSD"
-SLOT="0"
-IUSE="cups foomaticdb ppds"
-src_compile () {
+src_unpack() {
+ unpack ${A}
+ cd ${S}
use amd64 && gnuconfig_update
-
- use ppds \
- && myconf="--enable-foomatic-install" \
- || myconf="--disable-foomatic-install"
-
+ epatch ${FILESDIR}/${P}-gcc34.patch
epatch ${FILESDIR}/hpijs-1.4.1-rss.1.patch
+}
- econf --disable-cups-install ${myconf} || die "econf failed"
+src_compile () {
+ econf \
+ --disable-cups-install \
+ `use_enable ppds foomatic-install` \
+ || die "econf failed"
for i in Makefile; do
mv $i $i.orig ;
@@ -37,7 +42,7 @@ src_compile () {
make || die "compile problem"
- if [ `use foomaticdb` ]; then
+ if use foomaticdb ; then
cd ../foomatic-db-hpijs-${DB_V}
econf || die "econf failed"
rm -fR data-generators/hpijs-rss
@@ -46,23 +51,23 @@ src_compile () {
fi
}
-src_install () {
+src_install() {
einstall || die
- if [ "`use cups`" -a "`use ppds`" ] ; then
+ if use cups && use ppds ; then
dodir /usr/share/cups/model
dosym /usr/share/ppd /usr/share/cups/model/foomatic-ppds
fi
use ppds && rm -f ${D}/usr/bin/foomatic-rip
- if [ `use foomaticdb` ]; then
+ if use foomaticdb ; then
cd ../foomatic-db-hpijs-${DB_V}
make DESTDIR=${D} install || die
fi
}
-pkg_postinst () {
+pkg_postinst() {
einfo "To use the hpijs driver with the PDQ spooler you will need the PDQ driver file"
einfo "for your printer from http://www.linuxprinting.org/show_driver.cgi?driver=hpijs"
einfo "This file should be installed in /etc/pdq/drivers"