summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-18 18:09:45 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-18 18:09:45 +0000
commit88bb4d463f05e83dd3db17ba7aff4c9e2e6515a3 (patch)
tree24b935eb84e9b5b9e2af50c0192caf51df79f391 /sci-chemistry/bkchem/bkchem-0.14.0_pre1-r2.ebuild
parentUnmask dev-util/pkgconfig-0.25-r1. works fine here. (diff)
downloadhistorical-88bb4d463f05e83dd3db17ba7aff4c9e2e6515a3.tar.gz
historical-88bb4d463f05e83dd3db17ba7aff4c9e2e6515a3.tar.bz2
historical-88bb4d463f05e83dd3db17ba7aff4c9e2e6515a3.zip
Fix Assertions, thanks rei4dan for providing the patch
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'sci-chemistry/bkchem/bkchem-0.14.0_pre1-r2.ebuild')
-rw-r--r--sci-chemistry/bkchem/bkchem-0.14.0_pre1-r2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sci-chemistry/bkchem/bkchem-0.14.0_pre1-r2.ebuild b/sci-chemistry/bkchem/bkchem-0.14.0_pre1-r2.ebuild
new file mode 100644
index 000000000000..11006df5ef71
--- /dev/null
+++ b/sci-chemistry/bkchem/bkchem-0.14.0_pre1-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/bkchem/bkchem-0.14.0_pre1-r2.ebuild,v 1.1 2010/06/18 18:09:45 jlec Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH="tk"
+
+inherit distutils eutils versionator
+
+MY_P="${PN}-$(replace_version_separator 3 -)"
+
+DESCRIPTION="Chemical drawing program"
+HOMEPAGE="http://bkchem.zirael.org/"
+SRC_URI="http://bkchem.zirael.org/download/${MY_P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2"
+IUSE="cairo"
+
+DEPEND="dev-python/pycairo[svg]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-piddle-Fix-assertions.patch
+ distutils_src_prepare
+}
+
+src_install() {
+ distutils_src_install "--strip=${D%/}"
+ sed "s:^python:$(PYTHON):g" -i "${D}"/usr/bin/${PN} || die
+}
+
+
+
+
+