summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2006-05-13 22:24:31 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2006-05-13 22:24:31 +0000
commit22bf569a1c8dbead5d27901a10a0035815500659 (patch)
treedd688bcb1067d73ebdcfc52d8baf75a4882806ab /sci-chemistry
parent(#132835) Bump to latest release. Ebuild based on work of Donald E. Curtis. P... (diff)
downloadhistorical-22bf569a1c8dbead5d27901a10a0035815500659.tar.gz
historical-22bf569a1c8dbead5d27901a10a0035815500659.tar.bz2
historical-22bf569a1c8dbead5d27901a10a0035815500659.zip
(#132835) Bump to latest release. Ebuild based on work of Donald E. Curtis.
Package-Manager: portage-2.1_pre10-r5
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/ghemical/ChangeLog8
-rw-r--r--sci-chemistry/ghemical/files/digest-ghemical-2.013
-rw-r--r--sci-chemistry/ghemical/ghemical-2.01.ebuild50
3 files changed, 60 insertions, 1 deletions
diff --git a/sci-chemistry/ghemical/ChangeLog b/sci-chemistry/ghemical/ChangeLog
index a6f6f869356f..db19fdecda74 100644
--- a/sci-chemistry/ghemical/ChangeLog
+++ b/sci-chemistry/ghemical/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/ghemical
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ghemical/ChangeLog,v 1.15 2006/05/13 22:07:03 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ghemical/ChangeLog,v 1.16 2006/05/13 22:24:31 spyderous Exp $
+
+*ghemical-2.01 (13 May 2006)
+
+ 13 May 2006; Donnie Berkholz <spyderous@gentoo.org>;
+ +ghemical-2.01.ebuild:
+ (#132835) Bump to latest release. Ebuild based on work of Donald E. Curtis.
13 May 2006; Donnie Berkholz <spyderous@gentoo.org>; ghemical-1.02.ebuild:
Update openbabel dep for adding openbabel-2 to the tree.
diff --git a/sci-chemistry/ghemical/files/digest-ghemical-2.01 b/sci-chemistry/ghemical/files/digest-ghemical-2.01
new file mode 100644
index 000000000000..794a06f5a964
--- /dev/null
+++ b/sci-chemistry/ghemical/files/digest-ghemical-2.01
@@ -0,0 +1,3 @@
+MD5 7a160160c80f213b43485613a5ca2d75 ghemical-2.01.tar.gz 2060867
+RMD160 18332ba3067c463948671d220f7b0a693fe47aa1 ghemical-2.01.tar.gz 2060867
+SHA256 a0d5cc14b53cf132634f053f8779d0e720eb3d92e90ae154d4f41133beb8c4ae ghemical-2.01.tar.gz 2060867
diff --git a/sci-chemistry/ghemical/ghemical-2.01.ebuild b/sci-chemistry/ghemical/ghemical-2.01.ebuild
new file mode 100644
index 000000000000..c098b41436e8
--- /dev/null
+++ b/sci-chemistry/ghemical/ghemical-2.01.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ghemical/ghemical-2.01.ebuild,v 1.1 2006/05/13 22:24:31 spyderous Exp $
+
+inherit eutils
+
+DESCRIPTION="Ghemical supports both quantum-mechanics (semi-empirical and ab initio) models and molecular mechanics models (there is an experimental Tripos 5.2-like force field for organic molecules). Also a tool for reduced protein models is included. Geometry optimization, molecular dynamics and a large set of visualization tools are currently available."
+HOMEPAGE="http://www.uku.fi/~thassine/ghemical/"
+SRC_URI="http://bioinformatics.org/ghemical/download/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE="threads openbabel toolbar"
+RDEPEND="virtual/glut
+ virtual/glu
+ virtual/opengl
+ >=x11-libs/gtk+-2.6
+ >=x11-libs/gtkglext-1.0.5
+ >=gnome-base/libglade-2.4
+ >=sci-libs/libghemical-2
+ openbabel? ( >=sci-chemistry/openbabel-2 )
+ threads? ( >=dev-libs/glib-2.4 )
+ || ( x11-libs/libXmu virtual/x11 )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.15"
+
+pkg_setup() {
+ # Only works with xorg-x11 GL implementation
+ GL_IMPLEM=$(eselect opengl show)
+ eselect opengl set xorg-x11
+}
+
+src_compile() {
+ econf \
+ $(use_enable toolbar shortcuts) \
+ $(use_enable openbabel) \
+ $(use_enable threads) \
+ --enable-gamess \
+ || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ # sed -e "s:^prefix=.*:prefix=${D}/usr:" -i Makefile
+ make DESTDIR="${D}" install || die "install failed"
+}
+
+pkg_postinst() {
+ eselect opengl set ${GL_IMPLEM}
+}