summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2009-07-11 17:59:04 +0000
committerDenis Dupeyron <calchan@gentoo.org>2009-07-11 17:59:04 +0000
commit1c424b862e85ec6bcc40f694581155c877b2af97 (patch)
tree0004aa524209f199b94916236bada089864f691b /sci-electronics/systemc
parentoops, fixing Manifest (diff)
downloadhistorical-1c424b862e85ec6bcc40f694581155c877b2af97.tar.gz
historical-1c424b862e85ec6bcc40f694581155c877b2af97.tar.bz2
historical-1c424b862e85ec6bcc40f694581155c877b2af97.zip
Fixed compilation with gcc 4.3 and 4.4 (bug #252623, thanks to Gene Seto for the patch). Fixed executable stack warnings in a portable way.
Package-Manager: portage-2.1.6.13/cvs/Linux x86_64
Diffstat (limited to 'sci-electronics/systemc')
-rw-r--r--sci-electronics/systemc/ChangeLog8
-rw-r--r--sci-electronics/systemc/Manifest3
-rw-r--r--sci-electronics/systemc/systemc-2.2.0-r1.ebuild68
3 files changed, 77 insertions, 2 deletions
diff --git a/sci-electronics/systemc/ChangeLog b/sci-electronics/systemc/ChangeLog
index 2a65f869f791..f3ad2bae48be 100644
--- a/sci-electronics/systemc/ChangeLog
+++ b/sci-electronics/systemc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-electronics/systemc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/systemc/ChangeLog,v 1.13 2009/07/11 16:19:51 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/systemc/ChangeLog,v 1.14 2009/07/11 17:59:04 calchan Exp $
+
+*systemc-2.2.0-r1 (11 Jul 2009)
+
+ 11 Jul 2009; Denis Dupeyron <calchan@gentoo.org> +systemc-2.2.0-r1.ebuild:
+ Fixed compilation with gcc 4.3 and 4.4 (bug #252623, thanks to Gene Seto
+ for the patch). Fixed executable stack warnings in a portable way.
11 Jul 2009; Denis Dupeyron <calchan@gentoo.org>
-systemc-2.2_beta20060605.ebuild:
diff --git a/sci-electronics/systemc/Manifest b/sci-electronics/systemc/Manifest
index 6c9f6df03779..69e240d51ee5 100644
--- a/sci-electronics/systemc/Manifest
+++ b/sci-electronics/systemc/Manifest
@@ -1,4 +1,5 @@
DIST systemc-2.2.0.tgz 2050634 RMD160 7c5b3e45f3fecd4027b0b49cb9b90014a1f0c996 SHA1 a914b335a4f46f7c687f4f315bb931da1e626d4f SHA256 fd7db3ac2b547bf54c94c0310f15f079ed59ffa318ed5b0043a65410960859e7
+EBUILD systemc-2.2.0-r1.ebuild 1937 RMD160 c05f81f5b1318ce25a444b6d9d746ba396944d7b SHA1 da6ce26456ec157f9a3babb75e7e0d7dadc33f5e SHA256 433dfc5dcb0ad52d11d7bee78026d7aa2dc07244bbf4720ffb8bbe2b3eb1eb09
EBUILD systemc-2.2.0.ebuild 1544 RMD160 16a727c86bcff122103ef44fc3e9b1738073ce2a SHA1 f84624936ee8bb7f423890958853b55599c90cfc SHA256 2c3b1b417aa1a61d60a8082286b5ed202219470968394031932dc0ea389c0de2
-MISC ChangeLog 2498 RMD160 f213bb749d680e62b0ef9551af47ff5bef8ca9c6 SHA1 70f3753860f36dad2037b150d26187e224b9a7d6 SHA256 ec0b20d699632d692e0519a8cb1f21843b9816bc12aaab7d50bdfda404aa2f99
+MISC ChangeLog 2753 RMD160 14dc03e6916b98e70b5f394604ac384fb534cc51 SHA1 85942a88734b298990ca7afd6793371545a3e391 SHA256 39466fe0ba22fbf8e84a62743535b1e3865bf48902f324f41601dcd3bb730ed4
MISC metadata.xml 646 RMD160 60e2ec4364294f0be9419c30413ec93ee8bd96fd SHA1 01247171085cb65ed9c2f210969763228ee316c6 SHA256 c96bd5be1afd449e04d51d43e09dbadf97e5b7d3c8eebf8f05a1b271cd4b3419
diff --git a/sci-electronics/systemc/systemc-2.2.0-r1.ebuild b/sci-electronics/systemc/systemc-2.2.0-r1.ebuild
new file mode 100644
index 000000000000..a969548ae13b
--- /dev/null
+++ b/sci-electronics/systemc/systemc-2.2.0-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/systemc/systemc-2.2.0-r1.ebuild,v 1.1 2009/07/11 17:59:04 calchan Exp $
+
+inherit versionator multilib
+
+DESCRIPTION="A C++ based modeling platform for VLSI and system-level co-design"
+LICENSE="SOPLA-2.3"
+HOMEPAGE="http://www.systemc.org/"
+SRC_URI="${P}.tgz"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+RESTRICT="fetch test"
+
+DEPEND=""
+RDEPEND=""
+
+pkg_nofetch() {
+ elog "${PN} developers require end-users to accept their license agreement"
+ elog "by registering on their Web site (${HOMEPAGE})."
+ elog "Please download ${A} manually and place it in ${DISTDIR}."
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i -e "s:lib-\$(TARGET_ARCH):$(get_libdir):g" $(find . -name Makefile.in) || die "Patching Makefile.in failed"
+
+ sed -i -e "s:OPT_CXXFLAGS=\"-O3\":OPT_CXXFLAGS=\"${CXXFLAGS}\":g" configure || die "Patching configure failed"
+
+ sed -i -e '/#include "sysc\/utils\/sc_report.h"/a \
+#include <cstdlib> \
+#include <cstring>' src/sysc/utils/sc_utils_ids.cpp || die "Patching failed"
+
+ for sfile in src/sysc/qt/md/*.s ; do
+ sed -i -e '$a \
+#if defined(__linux__) && defined(__ELF__) \
+.section .note.GNU-stack,"",%progbits \
+#endif' "${sfile}" || die "Patching ${sfile} failed"
+ done
+}
+
+src_compile() {
+ econf --disable-dependency-tracking CXX="g++" || die "Configuration failed"
+ cd src
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ dodoc AUTHORS ChangeLog INSTALL NEWS README RELEASENOTES
+ insinto /usr/share/doc/${PF}/docs
+ doins docs/*
+ cd src
+ einstall
+}
+
+pkg_postinst() {
+ elog "If you want to run the examples, you need to :"
+ elog " tar xvfz ${PORTAGE_ACTUAL_DISTDIR}/${A}"
+ elog " cd ${P}"
+ elog " find examples -name 'Makefile.*' -exec sed -i -e 's/-lm/-lm -lpthread/' '{}' \;"
+ elog " ./configure"
+ elog " cd examples"
+ elog " make check"
+}