summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-12-12 18:12:31 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-12-12 18:12:31 +0000
commitbc3f39bc5d54c9c90767131d8764678ccdfc8b98 (patch)
tree7dbceccde1b473cb4cfae1ed147245bb5f220b0d /sci-libs/oc
parentWhitespace. (diff)
downloadhistorical-bc3f39bc5d54c9c90767131d8764678ccdfc8b98.tar.gz
historical-bc3f39bc5d54c9c90767131d8764678ccdfc8b98.tar.bz2
historical-bc3f39bc5d54c9c90767131d8764678ccdfc8b98.zip
Initial import
Package-Manager: portage-2.2_rc58/cvs/Linux x86_64
Diffstat (limited to 'sci-libs/oc')
-rw-r--r--sci-libs/oc/ChangeLog10
-rw-r--r--sci-libs/oc/Manifest14
-rw-r--r--sci-libs/oc/metadata.xml10
-rw-r--r--sci-libs/oc/oc-1.0.ebuild28
4 files changed, 62 insertions, 0 deletions
diff --git a/sci-libs/oc/ChangeLog b/sci-libs/oc/ChangeLog
new file mode 100644
index 000000000000..59d3a113feb7
--- /dev/null
+++ b/sci-libs/oc/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-libs/oc
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/oc/ChangeLog,v 1.1 2009/12/12 18:12:31 bicatali Exp $
+
+*oc-1.0 (12 Dec 2009)
+
+ 12 Dec 2009; SĂ©bastien Fabbro <bicatali@gentoo.org> +oc-1.0.ebuild,
+ +metadata.xml:
+ Initial import
+
diff --git a/sci-libs/oc/Manifest b/sci-libs/oc/Manifest
new file mode 100644
index 000000000000..0318d2375f00
--- /dev/null
+++ b/sci-libs/oc/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST oc-1.0.tar.gz 1521136 RMD160 6b47a08e6391395440e71ff39dae0fa4b53fa7d7 SHA1 6804a42679741eaba573041d776aff42567289fc SHA256 451ed027eea5a89059ac2c999e5eda90e49029aa221ac1a9fb4dd7899d1e972d
+EBUILD oc-1.0.ebuild 669 RMD160 b3530a839d02286fc964551759c9f2c216783e63 SHA1 c1b233ead22cbd90087f37cb8995996748c61553 SHA256 56d80d93879b267555febaf40d228a491d77d242d74005ae178c6730b6248a13
+MISC ChangeLog 326 RMD160 c260bf5ab364abe42977e5505f7f501ce0e994b3 SHA1 b84e894163cbc99a999667423c3d0a16211d5d09 SHA256 c9be1dedf2820fd66df8899fa10460301e47875f294d41026c9d7a8bd5bfe4d9
+MISC metadata.xml 389 RMD160 145a3f08444c27622bda401ff8690f0abf45dab4 SHA1 d5b166a82fa5f95eb5fb9352d5ff2aac7abc3b75 SHA256 0df03f4a1bb9a482968a0021163ffcbc81a1689b18461f322db1a98b6b0ccbb7
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.13 (GNU/Linux)
+
+iEYEARECAAYFAksj5kwACgkQ1ycZbhPLE2D6JgCfWmx2nJqn91Ev6vJiOZwiIcvt
+WCAAnjhO28bYX/m3ZwdXv7Z1awbiK6rJ
+=kIS1
+-----END PGP SIGNATURE-----
diff --git a/sci-libs/oc/metadata.xml b/sci-libs/oc/metadata.xml
new file mode 100644
index 000000000000..9bacf03e2639
--- /dev/null
+++ b/sci-libs/oc/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ The New OPeNDAP C API (oc) is an OPeNDAP DAP 2.0 client implementation
+ written in generic C. This new API allows for more funcionality and
+ less complexity than the original C API.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-libs/oc/oc-1.0.ebuild b/sci-libs/oc/oc-1.0.ebuild
new file mode 100644
index 000000000000..05c1be8ea931
--- /dev/null
+++ b/sci-libs/oc/oc-1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/oc/oc-1.0.ebuild,v 1.1 2009/12/12 18:12:31 bicatali Exp $
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="Network Data Access Protocol client C library"
+HOMEPAGE="http://opendap.org/"
+SRC_URI="http://opendap.org/pub/OC/source/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="net-misc/curl"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README ChangeLog NEWS
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins *.html || die
+ fi
+}