summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2005-04-08 14:40:31 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2005-04-08 14:40:31 +0000
commit103057b2487a2ce30b0c4d8230dfa0bbcaddf6df (patch)
treeb42d4c07c004133d626a7f21331ab0cb78c9e2bd /sci-mathematics/drgeo
parentStable on ppc64 (diff)
downloadhistorical-103057b2487a2ce30b0c4d8230dfa0bbcaddf6df.tar.gz
historical-103057b2487a2ce30b0c4d8230dfa0bbcaddf6df.tar.bz2
historical-103057b2487a2ce30b0c4d8230dfa0bbcaddf6df.zip
Version bump with a few ebuild clean ups.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'sci-mathematics/drgeo')
-rw-r--r--sci-mathematics/drgeo/ChangeLog7
-rw-r--r--sci-mathematics/drgeo/Manifest12
-rw-r--r--sci-mathematics/drgeo/drgeo-1.0.0.ebuild44
-rw-r--r--sci-mathematics/drgeo/files/digest-drgeo-1.0.02
4 files changed, 59 insertions, 6 deletions
diff --git a/sci-mathematics/drgeo/ChangeLog b/sci-mathematics/drgeo/ChangeLog
index 45861f61232e..2132b03597e2 100644
--- a/sci-mathematics/drgeo/ChangeLog
+++ b/sci-mathematics/drgeo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/drgeo
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/drgeo/ChangeLog,v 1.4 2005/03/18 01:01:51 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/drgeo/ChangeLog,v 1.5 2005/04/08 14:40:31 cryos Exp $
+
+*drgeo-1.0.0 (08 Apr 2005)
+
+ 08 Apr 2005; Marcus D. Hanwell <cryos@gentoo.org> +drgeo-1.0.0.ebuild:
+ Version bump with a few ebuild clean ups.
18 Mar 2005; Marcus D. Hanwell <cryos@gentoo.org> -drgeo-0.9.12.ebuild:
Removing old ebuild.
diff --git a/sci-mathematics/drgeo/Manifest b/sci-mathematics/drgeo/Manifest
index fa1dc1dd582a..448f78d967d8 100644
--- a/sci-mathematics/drgeo/Manifest
+++ b/sci-mathematics/drgeo/Manifest
@@ -2,13 +2,15 @@
Hash: SHA1
MD5 f37c590b31f0dee6917b6bafe048e50c drgeo-0.9.14.ebuild 1146
-MD5 ad32cfef9dce4a965e55eded989f34db ChangeLog 1568
+MD5 ac836679b19f7a98081c21ce5c106931 drgeo-1.0.0.ebuild 1273
+MD5 93c7f851d4eeb670efa6168016705583 ChangeLog 1714
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
+MD5 2517f39945f64a2eafa7c8cd288efbec files/digest-drgeo-1.0.0 130
MD5 071a0455c3fec522e4561a64a2cdbf2f files/digest-drgeo-0.9.14 131
-----BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1-ecc0.1.6 (GNU/Linux)
+Version: GnuPG v1.4.1 (GNU/Linux)
-iD8DBQFCOiiSntT9W3vfTuoRAvZ7AJ9Jd3TIB3rA68wU003pK3buVziXFwCggpxR
-16gh7xrZmUZ6lSWymD+pXa0=
-=byyV
+iD8DBQFCVpf4ntT9W3vfTuoRAvt1AJ4jt8EZBf/ITrl5CurUR/UOHneBegCeI9BF
+LEeuipFpEBasNmjKlETSk10=
+=IMRV
-----END PGP SIGNATURE-----
diff --git a/sci-mathematics/drgeo/drgeo-1.0.0.ebuild b/sci-mathematics/drgeo/drgeo-1.0.0.ebuild
new file mode 100644
index 000000000000..cc67c74914c5
--- /dev/null
+++ b/sci-mathematics/drgeo/drgeo-1.0.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/drgeo/drgeo-1.0.0.ebuild,v 1.1 2005/04/08 14:40:31 cryos Exp $
+
+DOCN="${PN}-doc"
+DOCV="1.5"
+DOC="${DOCN}-${DOCV}"
+
+DESCRIPTION="Interactive geometry package"
+LICENSE="GPL-2"
+HOMEPAGE="http://www.ofset.org/drgeo"
+SRC_URI="mirror://sourceforge/ofset/${P}.tar.gz
+ mirror://sourceforge/ofset/${DOC}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="nls no-helpbrowser"
+
+DEPEND=">=x11-libs/gtk+-2
+ >=gnome-base/libglade-2
+ >=dev-libs/libxml2-2
+ >=dev-util/guile-1.4
+ !no-helpbrowser? ( www-client/dillo )"
+
+src_compile() {
+ econf || die "econf failed."
+ emake || die "emake failed."
+ # Can't make the documentation as it depends on Hyperlatex which isn't
+ # yet in portage. Fortunately HTML is already compiled for us in the
+ # tarball and so can be installed. Just create the make install target.
+ cd ${WORKDIR}/${DOC}
+ econf || die "docs econf failed."
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "make install failed."
+ dodoc AUTHORS ChangeLog README NEWS TODO
+ if use nls; then
+ cd ${WORKDIR}/${DOC}
+ else
+ cd ${WORKDIR}/${DOC}/c
+ fi
+ make install DESTDIR=${D} || die "docs make installation failed."
+}
diff --git a/sci-mathematics/drgeo/files/digest-drgeo-1.0.0 b/sci-mathematics/drgeo/files/digest-drgeo-1.0.0
new file mode 100644
index 000000000000..9d11af515723
--- /dev/null
+++ b/sci-mathematics/drgeo/files/digest-drgeo-1.0.0
@@ -0,0 +1,2 @@
+MD5 397158a710f9437b463739e1d008ee12 drgeo-1.0.0.tar.gz 1527984
+MD5 a454d102a02528f993e0ccd41aadcad1 drgeo-doc-1.5.tar.gz 2730242