summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-04-30 10:57:16 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-04-30 10:57:16 +0000
commit26b0651f31014221e7916cbdeeb16d27c8fca649 (patch)
tree587a6b5a715b7fe490d91d02065ee2eee01bac7e /sci-mathematics
parentVersion bump to 0.3.3b. Add SUPPORT_PYTHON_ABIS. (diff)
downloadhistorical-26b0651f31014221e7916cbdeeb16d27c8fca649.tar.gz
historical-26b0651f31014221e7916cbdeeb16d27c8fca649.tar.bz2
historical-26b0651f31014221e7916cbdeeb16d27c8fca649.zip
Minor fixes to match the latest update on python eclass. Fixes bug #316235
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/relational/ChangeLog5
-rw-r--r--sci-mathematics/relational/Manifest4
-rw-r--r--sci-mathematics/relational/relational-0.10.ebuild10
3 files changed, 10 insertions, 9 deletions
diff --git a/sci-mathematics/relational/ChangeLog b/sci-mathematics/relational/ChangeLog
index e23f5c3fe923..3342d24d3c29 100644
--- a/sci-mathematics/relational/ChangeLog
+++ b/sci-mathematics/relational/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-mathematics/relational
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/relational/ChangeLog,v 1.3 2010/04/23 09:04:36 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/relational/ChangeLog,v 1.4 2010/04/30 10:57:16 hwoarang Exp $
+
+ 30 Apr 2010; Markos Chandras <hwoarang@gentoo.org> relational-0.10.ebuild:
+ Minor fixes to match the latest update on python eclass. Fixes bug #316235
23 Apr 2010; Markos Chandras <hwoarang@gentoo.org> relational-0.10.ebuild:
Refactor ebuild to use python functions correctly. Fixes bug #316235
diff --git a/sci-mathematics/relational/Manifest b/sci-mathematics/relational/Manifest
index 0814e6cebd0a..78a0b7f538be 100644
--- a/sci-mathematics/relational/Manifest
+++ b/sci-mathematics/relational/Manifest
@@ -1,4 +1,4 @@
DIST relational_0.10.tar.gz 635600 RMD160 7fa8c5879bde19535804561d9b88d64e8b613d25 SHA1 f93fa4ac02732edfe10299912c8314301618559e SHA256 cbc45044ef759b147ef2d5ac6af8d8f75b6ae7d71e86c86e5a2978c3b8480d97
-EBUILD relational-0.10.ebuild 1244 RMD160 57d93b150c5e55b02dfb864e4683b5da766a2409 SHA1 8a5dcab9cf49c81af947da7b5787be2af4dfdb1b SHA256 10c56dd6037c83787eed3fba92537eda4a9b021378fc1864cc0c5ef50446250f
-MISC ChangeLog 641 RMD160 19e77583551e7e3c4791451f076f3dd36cec6b43 SHA1 5ea98485eb8cdbc2df5c34c5da2c7718f7f022b3 SHA256 0bb71e026f4c01fc671dd12c214eb22a57e3059e8ed7c890eb9a2b7461cfa417
+EBUILD relational-0.10.ebuild 1177 RMD160 641e3fa43c5ffbf90952dc3a18f3c8747c4aadab SHA1 6a2f3a01400108d393d098adfa05e428a63385f6 SHA256 97c20b91a1ac2971eb6ddc96efd4fb66745c06e654def23ba3d42d85f7a84a52
+MISC ChangeLog 796 RMD160 fc4f26a3918e4e63fdc5031fd26d9d6ab2ef3287 SHA1 a6d1f0d7aa7e5c077af4b80e9918366a50753dfe SHA256 20de797fc852953f91ca4588684960e3aa2486432b8f9360792e8974d4681a33
MISC metadata.xml 203 RMD160 f21ab0adb7ed966ccbfb8706172574746bf83c45 SHA1 9929f57d84969eaa6e4f2b8d399921bc4c7ba1e4 SHA256 e70e3acb51ca19e8ef1c7b3fe1356e152781028e0bdccd400e0979db61b77070
diff --git a/sci-mathematics/relational/relational-0.10.ebuild b/sci-mathematics/relational/relational-0.10.ebuild
index 723ba58d0ea4..1d8e1d9a437b 100644
--- a/sci-mathematics/relational/relational-0.10.ebuild
+++ b/sci-mathematics/relational/relational-0.10.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/relational/relational-0.10.ebuild,v 1.3 2010/04/23 09:04:36 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/relational/relational-0.10.ebuild,v 1.4 2010/04/30 10:57:16 hwoarang Exp $
-EAPI="2"
+EAPI="3"
PYTHON_DEPEND="2"
inherit python distutils eutils
@@ -42,11 +42,9 @@ src_install() {
}
pkg_postinst() {
- python_version
- python_mod_optimize $(python_get_sitedir)/${PN}/
- python_mod_optimize $(python_get_sitedir)/${PN}_gui/
+ python_mod_optimize ${PN} ${PN}_gui
}
pkg_postrm() {
- python_mod_cleanup
+ python_mod_cleanup ${PN} ${PN}_gui
}