summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2005-08-20 19:03:19 +0000
committerOlivier Fisette <ribosome@gentoo.org>2005-08-20 19:03:19 +0000
commit516e9a2793caf289c276d5684eaee5c590a53e9c (patch)
treeea493eaab1c5cf30af40fde879d63771e5fad876 /sci-mathematics
parentMarking ~ppc-macos (diff)
downloadhistorical-516e9a2793caf289c276d5684eaee5c590a53e9c.tar.gz
historical-516e9a2793caf289c276d5684eaee5c590a53e9c.tar.bz2
historical-516e9a2793caf289c276d5684eaee5c590a53e9c.zip
New version. Depends strictly on Octave 2.69 rather than 2.69 or later like previous ebuilds (see bug #99781).
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/octave-forge/ChangeLog10
-rw-r--r--sci-mathematics/octave-forge/Manifest4
-rw-r--r--sci-mathematics/octave-forge/files/digest-octave-forge-2005.06.131
-rw-r--r--sci-mathematics/octave-forge/octave-forge-2005.06.13.ebuild71
4 files changed, 84 insertions, 2 deletions
diff --git a/sci-mathematics/octave-forge/ChangeLog b/sci-mathematics/octave-forge/ChangeLog
index c4aebdd3d686..eb8a2b89f3d4 100644
--- a/sci-mathematics/octave-forge/ChangeLog
+++ b/sci-mathematics/octave-forge/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-mathematics/octave-forge
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave-forge/ChangeLog,v 1.9 2005/06/26 02:13:44 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave-forge/ChangeLog,v 1.10 2005/08/20 19:03:19 ribosome Exp $
+
+*octave-forge-2005.06.13 (20 Aug 2005)
+
+ 20 Aug 2005; Olivier Fisette <ribosome@gentoo.org>
+ +octave-forge-2005.06.13.ebuild:
+ New version. Depends strictly on Octave 2.69 rather than 2.69 or later like
+ previous ebuilds (see bug #99781). This dependency should be kept in sync as
+ new versions of Octave and Octave-Forge are released.
26 Jun 2005; Olivier Fisette <ribosome@gentoo.org>
-files/octave-2.1.57+.patch, -files/octave-forge-2004.02.12-fPIC.patch,
diff --git a/sci-mathematics/octave-forge/Manifest b/sci-mathematics/octave-forge/Manifest
index 1a67cd1fe240..d6670459b813 100644
--- a/sci-mathematics/octave-forge/Manifest
+++ b/sci-mathematics/octave-forge/Manifest
@@ -1,5 +1,7 @@
MD5 951981815988e63c61e9c25ef58fe330 octave-forge-2004.11.16-r1.ebuild 2265
-MD5 254420172f99df87cf84be67a57f3f88 ChangeLog 3736
+MD5 56096f5637d1beb35c0801c36c81b6ef octave-forge-2005.06.13.ebuild 2268
+MD5 2c515833e253ea96b34a0767a6264db1 ChangeLog 4079
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
MD5 64ae87b1b1190c6a51f7dfd91be73d05 files/2004.11.16.patch 1580
+MD5 cfc1fc06a341728e53b81d09d6376dea files/digest-octave-forge-2005.06.13 76
MD5 3aacf6f3c335a1f63edef94a9bd7011a files/digest-octave-forge-2004.11.16-r1 76
diff --git a/sci-mathematics/octave-forge/files/digest-octave-forge-2005.06.13 b/sci-mathematics/octave-forge/files/digest-octave-forge-2005.06.13
new file mode 100644
index 000000000000..b04974e6db75
--- /dev/null
+++ b/sci-mathematics/octave-forge/files/digest-octave-forge-2005.06.13
@@ -0,0 +1 @@
+MD5 cf82a74d27636abf07f1732b4851f2e2 octave-forge-2005.06.13.tar.gz 3680082
diff --git a/sci-mathematics/octave-forge/octave-forge-2005.06.13.ebuild b/sci-mathematics/octave-forge/octave-forge-2005.06.13.ebuild
new file mode 100644
index 000000000000..b87515897571
--- /dev/null
+++ b/sci-mathematics/octave-forge/octave-forge-2005.06.13.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave-forge/octave-forge-2005.06.13.ebuild,v 1.1 2005/08/20 19:03:19 ribosome Exp $
+
+inherit eutils
+
+DESCRIPTION="A collection of custom scripts, functions and extensions for GNU Octave"
+HOMEPAGE="http://octave.sourceforge.net/"
+SRC_URI="mirror://sourceforge/octave/${P}.tar.gz"
+
+LICENSE="as-is"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64"
+SLOT="0"
+IUSE="ginac qhull"
+
+DEPEND="=sci-mathematics/octave-2.1.69
+ >=sys-apps/sed-4
+ sys-libs/libtermcap-compat
+ !amd64? ( ginac? ( sci-mathematics/ginac ) )
+ qhull? ( >=media-libs/qhull-3.1-r1 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/2004.11.16.patch
+
+ # make it compile when X isn't installed. The source file there really
+ # doesn't need X at all.
+ # 02 Feb 2005, Robin H. Johnson <robbat2@gentoo.org>
+ sed -e '/#include <X11/d' -i ${S}/main/audio/aurecord.cc
+}
+
+src_compile() {
+ econf || die "econf failed"
+
+ # this must be done before the *PATH variables are changed
+ cd extra/graceplot && make grace_octave_path.m
+ cd ${S}
+
+ # The *PATH variables need to be changed, or they will
+ # cause Portage access violations. They cannot be easily set just using
+ # arguments passed to ./configure (at least, they can not easily be set
+ # correctly)
+ echo -en "Modifying paths..."
+ for path in M O X ALTM ALTO; do
+ sed -i "s|^\(${path}PATH = \)|\1${D}|" Makeconf || \
+ die "failed to modify ${path}PATH"
+ done
+ echo -e "done.\n"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+
+ # strip the fudged install paths
+ sed -i "s|${D}||g" ${D}/usr/bin/mex || die "sed failed"
+
+ dodoc AUTHORS COPYING* ChangeLog INDEX RELEASE-NOTES TODO
+}
+
+pkg_postinst() {
+ einfo "If you do not have GiNaC and Qhull installed, octave-forge did not"
+ einfo "compile itself with support for the geometry and symbolic math"
+ einfo "extensions. If you would like these features, please emerge ginac"
+ einfo "and/or qhull and then re-emerge octave-forge. Alternately, you can"
+ einfo "specify USE='ginac qhull' and re-emerge octave-forge; in that case"
+ einfo "the ebuild will automatically install the additional packages."
+}
+