summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-02-20 18:14:57 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-02-20 18:14:57 +0000
commitbbdca0f4ebafcfd09871539efe4e9005f6e0b287 (patch)
tree7e4ee5258f05a8cc3364813fcda39a39669f113f /sci-mathematics
parentVersion bump and fix path for ebin files, bug 259695. (diff)
downloadhistorical-bbdca0f4ebafcfd09871539efe4e9005f6e0b287.tar.gz
historical-bbdca0f4ebafcfd09871539efe4e9005f6e0b287.tar.bz2
historical-bbdca0f4ebafcfd09871539efe4e9005f6e0b287.zip
Update ebuild to use cmake-utils eclass correctly.
Package-Manager: portage-2.2_rc23/cvs/Linux x86_64
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/qtoctave/ChangeLog7
-rw-r--r--sci-mathematics/qtoctave/Manifest4
-rw-r--r--sci-mathematics/qtoctave/qtoctave-0.8.1.ebuild8
3 files changed, 11 insertions, 8 deletions
diff --git a/sci-mathematics/qtoctave/ChangeLog b/sci-mathematics/qtoctave/ChangeLog
index 5946f94cf482..7fba3280c537 100644
--- a/sci-mathematics/qtoctave/ChangeLog
+++ b/sci-mathematics/qtoctave/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-mathematics/qtoctave
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/qtoctave/ChangeLog,v 1.3 2008/11/02 21:30:55 markusle Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/qtoctave/ChangeLog,v 1.4 2009/02/20 18:14:57 scarabeus Exp $
+
+ 20 Feb 2009; Tomas Chvatal <scarabeus@gentoo.org> qtoctave-0.8.1.ebuild:
+ Update ebuild to use cmake-utils eclass correctly.
02 Nov 2008; Markus Dittrich <markusle@gentoo.org> qtoctave-0.8.1.ebuild:
Restrict dependency on Qt to >=Qt-4.4 since the source code uses
diff --git a/sci-mathematics/qtoctave/Manifest b/sci-mathematics/qtoctave/Manifest
index eb244f5bc681..ad30011bd6e9 100644
--- a/sci-mathematics/qtoctave/Manifest
+++ b/sci-mathematics/qtoctave/Manifest
@@ -1,4 +1,4 @@
DIST qtoctave-0.8.1.tar.gz 1707919 RMD160 41bb670f630ce08ce5b440b2c8dbe16fdbe282b0 SHA1 e7cb555eed318c0e62b2de974e5904e40579d2c4 SHA256 d5654f5aaa2ea86b473accb49cea4a85c2899d2822fe4c3d980f0260bbe87498
-EBUILD qtoctave-0.8.1.ebuild 810 RMD160 3aa3f32a4e6e269e27b103e3d05e17b98bae562f SHA1 88fbbca11bfb87becc1ed4879bf96b82b59c5d96 SHA256 4134a451cd24d6953253102cd0bbc3b42314416702846cb61dcc06b63881b553
-MISC ChangeLog 632 RMD160 7029eeb876755fc8c81a0db6445d1d536c8b6a23 SHA1 645f1e0a2b73d20b0f56f9fbeb237d42840021db SHA256 78c9f211dbd51bcd9a0098b13e5f689ad036f6f30e6fe8e4654ab0bfdf4d278e
+EBUILD qtoctave-0.8.1.ebuild 809 RMD160 c96b61773ec7e156442ec15e17f3c040b904fe78 SHA1 52cab7fba45fe65ce6359e32447cbd8bcc8f5ebf SHA256 f22aa64c590eea8cac9d47531e53dd8fbc12800bd8509bc9e47de98427ea2d9f
+MISC ChangeLog 762 RMD160 efef366b7d152912a1a28c71bb16433288ce61e3 SHA1 1329355f217dcfea4c29a67ae8635207c80c3da5 SHA256 08540aac03efe94cc251d999fe8e73cd1de3bb00fd7a2147e50068b468ef4046
MISC metadata.xml 168 RMD160 d98790cf055dc0f820c63d65f485b9dcfa8950f4 SHA1 95c9e4f7368f82053d631bbcd469612c92ca13cb SHA256 c0cc8d6ab9385750af753ddc504299ed90a70b5c4c655f6c77d865917a8829c9
diff --git a/sci-mathematics/qtoctave/qtoctave-0.8.1.ebuild b/sci-mathematics/qtoctave/qtoctave-0.8.1.ebuild
index 56b91a956bff..3a8c1e36acce 100644
--- a/sci-mathematics/qtoctave/qtoctave-0.8.1.ebuild
+++ b/sci-mathematics/qtoctave/qtoctave-0.8.1.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/qtoctave/qtoctave-0.8.1.ebuild,v 1.2 2008/11/02 21:30:55 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/qtoctave/qtoctave-0.8.1.ebuild,v 1.3 2009/02/20 18:14:57 scarabeus Exp $
EAPI="1"
+CMAKE_IN_SOURCE_BUILD=1
inherit cmake-utils
DESCRIPTION="QtOctave is a Qt4 front-end for Octave"
@@ -25,8 +26,7 @@ S="${WORKDIR}"/${P}/${PN}
src_compile() {
mycmakeargs="-DCMAKE_SKIP_RPATH:BOOL=YES"
- cmake-utils_src_configurein
- cmake-utils_src_make
+ cmake-utils_src_compile
}
src_install() {