summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-08-06 20:53:59 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-08-06 20:53:59 +0000
commite1bad01ba411568802d35377ad016d298bc38ba1 (patch)
treee870e7f705ff80c497262afc608ef5261b1d19c2 /sci-physics
parentFix underlinking in tests, bug 370161 (diff)
downloadhistorical-e1bad01ba411568802d35377ad016d298bc38ba1.tar.gz
historical-e1bad01ba411568802d35377ad016d298bc38ba1.tar.bz2
historical-e1bad01ba411568802d35377ad016d298bc38ba1.zip
Version bump
Package-Manager: portage-2.1.10.10/cvs/Linux x86_64
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/clhep/ChangeLog7
-rw-r--r--sci-physics/clhep/clhep-2.1.1.0.ebuild46
-rw-r--r--sci-physics/lhapdf/ChangeLog7
-rw-r--r--sci-physics/lhapdf/lhapdf-5.8.6.ebuild72
4 files changed, 130 insertions, 2 deletions
diff --git a/sci-physics/clhep/ChangeLog b/sci-physics/clhep/ChangeLog
index 181253105cfe..8b25640ae27a 100644
--- a/sci-physics/clhep/ChangeLog
+++ b/sci-physics/clhep/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-physics/clhep
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/clhep/ChangeLog,v 1.35 2011/06/28 20:00:38 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/clhep/ChangeLog,v 1.36 2011/08/06 20:50:27 bicatali Exp $
+
+*clhep-2.1.1.0 (06 Aug 2011)
+
+ 06 Aug 2011; Sébastien Fabbro <bicatali@gentoo.org> +clhep-2.1.1.0.ebuild:
+ Version bump
28 Jun 2011; Brent Baude <ranger@gentoo.org> clhep-2.1.0.1.ebuild:
Marking clhep-2.1.0.1 ppc for bug 354009
diff --git a/sci-physics/clhep/clhep-2.1.1.0.ebuild b/sci-physics/clhep/clhep-2.1.1.0.ebuild
new file mode 100644
index 000000000000..835c683e1eea
--- /dev/null
+++ b/sci-physics/clhep/clhep-2.1.1.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/clhep/clhep-2.1.1.0.ebuild,v 1.1 2011/08/06 20:50:27 bicatali Exp $
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="High Energy Physics C++ library"
+HOMEPAGE="http://www.cern.ch/clhep"
+SRC_URI="http://proj-clhep.web.cern.ch/proj-clhep/DISTRIBUTION/tarFiles/${P}.tgz"
+LICENSE="public-domain"
+SLOT="2"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+
+IUSE="exceptions static-libs"
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PV}/CLHEP"
+
+src_prepare() {
+ for d in $(find . -name configure.ac); do
+ # respect user flags and fix some compilers stuff
+ sed -i \
+ -e 's:^g++):*g++):g' \
+ -e 's:^icc):icc|icpc):g' \
+ -e '/AM_CXXFLAGS=/s:-O ::g' \
+ ${d} || die
+ # need to rebuild because original configurations
+ # have buggy detection
+ done
+ for d in $(find . -name Makefile.am | xargs grep -l ": %\.cc"); do
+ sed -i \
+ -e 's|: %\.cc|: %\.cc \$(shareddir)|' \
+ -e 's|all-local: \$(shareddir)|all-local: |' \
+ ${d} || die
+ # fixing parallel build
+ done
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable exceptions) \
+ $(use_enable static-libs static)
+}
diff --git a/sci-physics/lhapdf/ChangeLog b/sci-physics/lhapdf/ChangeLog
index 489357793a9a..70d992922a39 100644
--- a/sci-physics/lhapdf/ChangeLog
+++ b/sci-physics/lhapdf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-physics/lhapdf
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/lhapdf/ChangeLog,v 1.17 2011/03/09 20:03:41 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/lhapdf/ChangeLog,v 1.18 2011/08/06 20:53:59 bicatali Exp $
+
+*lhapdf-5.8.6 (06 Aug 2011)
+
+ 06 Aug 2011; Sébastien Fabbro <bicatali@gentoo.org> +lhapdf-5.8.6.ebuild:
+ Version bump
*lhapdf-5.8.5 (09 Mar 2011)
diff --git a/sci-physics/lhapdf/lhapdf-5.8.6.ebuild b/sci-physics/lhapdf/lhapdf-5.8.6.ebuild
new file mode 100644
index 000000000000..0ecb8cf32c7a
--- /dev/null
+++ b/sci-physics/lhapdf/lhapdf-5.8.6.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/lhapdf/lhapdf-5.8.6.ebuild,v 1.1 2011/08/06 20:53:59 bicatali Exp $
+
+EAPI=4
+
+inherit versionator eutils
+
+MY_PV=$(get_version_component_range 1-3 ${PV})
+MY_PF=${PN}-${MY_PV}
+
+DESCRIPTION="Les Houches Parton Density Function unified library"
+HOMEPAGE="http://projects.hepforge.org/lhapdf/"
+SRC_URI="http://www.hepforge.org/archive/lhapdf/${MY_PF}.tar.gz
+ test? (
+ http://svn.hepforge.org/${PN}/pdfsets/tags/${MY_PV}/cteq61.LHgrid
+ http://svn.hepforge.org/${PN}/pdfsets/tags/${MY_PV}/MRST2004nlo.LHgrid
+ http://svn.hepforge.org/${PN}/pdfsets/tags/${MY_PV}/cteq61.LHpdf
+ octave? ( http://svn.hepforge.org/${PN}/pdfsets/tags/${MY_PV}/cteq5l.LHgrid ) )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cxx doc examples octave python static-libs test"
+REQUIRED_USE="octave? ( cxx )"
+RDEPEND="octave? ( sci-mathematics/octave )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[latex] )
+ python? ( dev-lang/swig )"
+
+S="${WORKDIR}/${MY_PF}"
+
+src_prepare() {
+ # do not create extra latex docs
+ sed -i \
+ -e 's/GENERATE_LATEX.*=YES/GENERATE_LATEX = NO/g' \
+ ccwrap/Doxyfile || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable cxx ccwrap) \
+ $(use_enable cxx old-ccwrap ) \
+ $(use_enable doc doxygen) \
+ $(use_enable octave) \
+ $(use_enable python pyext) \
+ $(use_enable static-libs static)
+}
+
+src_test() {
+ # need to make a bogus link for octave test
+ ln -s "${DISTDIR}" PDFsets
+ LHAPATH="${PWD}/PDFsets" \
+ LD_LIBRARY_PATH="${PWD}/lib/.libs:${LD_LIBRARY_PATH}" \
+ emake check
+}
+
+src_install() {
+ default
+ # leftover
+ rm -rf "${ED}"/usr/share/${PN}/doc || die
+ use doc && use cxx && dohtml -r ccwrap/doxy/html/*
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.{f,cc}
+ fi
+}
+
+pkg_postinst() {
+ elog "To install data files, you have to run as root:"
+ elog "lhapdf-getdata --dest=${EROOT}usr/share/lhapdf/PDFsets --all"
+}