summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2011-10-09 06:56:22 +0000
committerFabio Erculiani <lxnay@gentoo.org>2011-10-09 06:56:22 +0000
commitad11cd4f88ca9253df15f9cbbf936eb354b63154 (patch)
tree64152751551edad58e051abeafe28310c5789d8d /sys-apps/entropy
parentversion bump (diff)
downloadhistorical-ad11cd4f88ca9253df15f9cbbf936eb354b63154.tar.gz
historical-ad11cd4f88ca9253df15f9cbbf936eb354b63154.tar.bz2
historical-ad11cd4f88ca9253df15f9cbbf936eb354b63154.zip
version bump
Package-Manager: portage-2.2.0_alpha51/cvs/Linux x86_64
Diffstat (limited to 'sys-apps/entropy')
-rw-r--r--sys-apps/entropy/ChangeLog7
-rw-r--r--sys-apps/entropy/entropy-1.0_rc59.ebuild83
2 files changed, 89 insertions, 1 deletions
diff --git a/sys-apps/entropy/ChangeLog b/sys-apps/entropy/ChangeLog
index bae86024f8da..f4b48324ddd0 100644
--- a/sys-apps/entropy/ChangeLog
+++ b/sys-apps/entropy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/entropy
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/entropy/ChangeLog,v 1.13 2011/09/18 17:31:00 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/entropy/ChangeLog,v 1.14 2011/10/09 06:52:11 lxnay Exp $
+
+*entropy-1.0_rc59 (09 Oct 2011)
+
+ 09 Oct 2011; Fabio Erculiani <lxnay@gentoo.org> +entropy-1.0_rc59.ebuild:
+ version bump
18 Sep 2011; Fabio Erculiani <lxnay@gentoo.org> entropy-1.0_rc53.ebuild:
add explicit dependency against python[sqlite]
diff --git a/sys-apps/entropy/entropy-1.0_rc59.ebuild b/sys-apps/entropy/entropy-1.0_rc59.ebuild
new file mode 100644
index 000000000000..2961d710dea3
--- /dev/null
+++ b/sys-apps/entropy/entropy-1.0_rc59.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/entropy/entropy-1.0_rc59.ebuild,v 1.1 2011/10/09 06:52:11 lxnay Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH="sqlite"
+inherit eutils python
+
+DESCRIPTION="Entropy Package Manager foundation library"
+HOMEPAGE="http://www.sabayon.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+SRC_URI="mirror://sabayon/${CATEGORY}/${P}.tar.bz2"
+
+RDEPEND="dev-db/sqlite[soundex]
+ net-misc/rsync
+ sys-apps/diffutils
+ sys-apps/sandbox
+ >=sys-apps/portage-2.1.9
+ sys-devel/gettext"
+DEPEND="${RDEPEND}
+ dev-util/intltool"
+
+REPO_CONFPATH="${ROOT}/etc/entropy/repositories.conf"
+ENTROPY_CACHEDIR="${ROOT}/var/lib/entropy/caches"
+
+pkg_setup() {
+ # Can:
+ # - update repos
+ # - update security advisories
+ # - handle on-disk cache (atm)
+ enewgroup entropy || die "failed to create entropy group"
+ # Create unprivileged entropy user
+ enewgroup entropy-nopriv || die "failed to create entropy-nopriv group"
+ enewuser entropy-nopriv -1 -1 -1 entropy-nopriv || die "failed to create entropy-nopriv user"
+}
+
+src_compile() {
+ # TODO: move to separate package
+ cd "${S}"/misc/po || die
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="usr/lib" entropy-install || die "make install failed"
+
+ # TODO: move to separate package
+ cd "${S}"/misc/po || die
+ emake DESTDIR="${D}" LIBDIR="usr/lib" install || die "make install failed"
+}
+
+pkg_postinst() {
+
+ # Copy config file over
+ if [ -f "${REPO_CONFPATH}.example" ] && [ ! -f "${REPO_CONFPATH}" ]; then
+ einfo "Copying ${REPO_CONFPATH}.example over to ${REPO_CONFPATH}"
+ cp "${REPO_CONFPATH}.example" "${REPO_CONFPATH}" -p
+ fi
+ if [ -d "${ENTROPY_CACHEDIR}" ]; then
+ einfo "Purging current Entropy cache"
+ rm -rf "${ENTROPY_CACHEDIR}"/*
+ fi
+
+ python_mod_optimize "/usr/lib/entropy/libraries/entropy"
+
+ # force python 2.x
+ eselect python update --ignore 3.0 --ignore 3.1 --ignore 3.2 --ignore 3.3
+
+ echo
+ elog "If you want to enable Entropy packages delta download support, please"
+ elog "install dev-util/bsdiff."
+ echo
+
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/lib/entropy/libraries/entropy"
+}