summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-05-29 09:15:48 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-05-29 09:15:48 +0000
commita7e8f9025e8ca7ab6145193405c2303be04eb5d4 (patch)
tree94b688ae8065130ea453c54ccc190d1d034e74a8 /sys-apps/lm-sensors
parentrenamed (diff)
downloadhistorical-a7e8f9025e8ca7ab6145193405c2303be04eb5d4.tar.gz
historical-a7e8f9025e8ca7ab6145193405c2303be04eb5d4.tar.bz2
historical-a7e8f9025e8ca7ab6145193405c2303be04eb5d4.zip
renamed
Diffstat (limited to 'sys-apps/lm-sensors')
-rw-r--r--sys-apps/lm-sensors/Manifest6
-rw-r--r--sys-apps/lm-sensors/files/digest-lm-sensors-2.6.51
-rw-r--r--sys-apps/lm-sensors/files/digest-lm-sensors-2.7.01
-rw-r--r--sys-apps/lm-sensors/files/rc_lm_sensors30
-rw-r--r--sys-apps/lm-sensors/lm-sensors-2.6.5.ebuild56
-rw-r--r--sys-apps/lm-sensors/lm-sensors-2.7.0.ebuild64
6 files changed, 155 insertions, 3 deletions
diff --git a/sys-apps/lm-sensors/Manifest b/sys-apps/lm-sensors/Manifest
index 7258f36a4498..d687174f1700 100644
--- a/sys-apps/lm-sensors/Manifest
+++ b/sys-apps/lm-sensors/Manifest
@@ -1,6 +1,6 @@
-MD5 b6a2ed81a6a253495ef6140b34d7487a lm-sensors-2.7.0.ebuild 2330
-MD5 c872bc4f9443e5d6cc97e07726a6d122 ChangeLog 2462
-MD5 67d4f2bc7309512f60d13e8456ccce5e lm-sensors-2.6.5.ebuild 1948
+MD5 1c57fd1c27d231d1c4b7fe36b791cc64 lm-sensors-2.7.0.ebuild 2328
+MD5 3380b0e18a819435a4077101c27f4d63 ChangeLog 2632
+MD5 9d17dd07a14aaff18ea1282c70856fe8 lm-sensors-2.6.5.ebuild 1948
MD5 d8c62d91275ce75f12c70d068db57a97 files/rc_lm_sensors 621
MD5 4e8f1427a529eb217c00370357991f73 files/digest-lm-sensors-2.6.5 68
MD5 cf55e040bb5a4609f79212a60fa0c1c3 files/digest-lm-sensors-2.7.0 68
diff --git a/sys-apps/lm-sensors/files/digest-lm-sensors-2.6.5 b/sys-apps/lm-sensors/files/digest-lm-sensors-2.6.5
new file mode 100644
index 000000000000..f86e14f036ba
--- /dev/null
+++ b/sys-apps/lm-sensors/files/digest-lm-sensors-2.6.5
@@ -0,0 +1 @@
+MD5 297a3e6173562ff92bd7467f744125db lm_sensors-2.6.5.tar.gz 559880
diff --git a/sys-apps/lm-sensors/files/digest-lm-sensors-2.7.0 b/sys-apps/lm-sensors/files/digest-lm-sensors-2.7.0
new file mode 100644
index 000000000000..4fcb22c216b5
--- /dev/null
+++ b/sys-apps/lm-sensors/files/digest-lm-sensors-2.7.0
@@ -0,0 +1 @@
+MD5 5ccf267a4e5d2d7dfa176750886f6939 lm_sensors-2.7.0.tar.gz 595379
diff --git a/sys-apps/lm-sensors/files/rc_lm_sensors b/sys-apps/lm-sensors/files/rc_lm_sensors
new file mode 100644
index 000000000000..697b572888a9
--- /dev/null
+++ b/sys-apps/lm-sensors/files/rc_lm_sensors
@@ -0,0 +1,30 @@
+#!/sbin/runscript
+
+start() {
+ if ! [ -f /etc/sysconfig/lm_sensors ] ; then
+ eerror "/etc/sysconfig/lm_sensors does not exist"
+ return 1
+ fi
+
+ . /etc/sysconfig/lm_sensors
+
+ ebegin "Loading lm_sensors modules"
+ eend $?
+ if ! [ -e /proc/sys/dev/sensors ] ; then
+ ebegin " Loading i2c-proc"
+ modprobe i2c-proc &>/dev/null
+ eend $?
+ fi
+ [ -e /proc/sys/dev/sensors ] || return 1
+
+ modules=`grep \^MODULE_ /etc/sysconfig/lm_sensors |wc -l`
+ i=1
+ while [ ${i} -le ${modules} ] ; do
+ module=`eval echo '$'MODULE_${i}`
+ ebegin " Loading ${module}"
+ modprobe ${module} &>/dev/null
+ eend $?
+ i=$((i+1))
+ done
+ return 0
+}
diff --git a/sys-apps/lm-sensors/lm-sensors-2.6.5.ebuild b/sys-apps/lm-sensors/lm-sensors-2.6.5.ebuild
new file mode 100644
index 000000000000..6beb57dc017b
--- /dev/null
+++ b/sys-apps/lm-sensors/lm-sensors-2.6.5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm-sensors/lm-sensors-2.6.5.ebuild,v 1.1 2003/05/29 09:13:03 seemant Exp $
+
+inherit flag-o-matic
+
+MY_P=${PN/-/_}-${PV}
+
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Hardware Sensors Monitoring by lm_sensors"
+SRC_URI="http://www2.lm-sensors.nu/~lm78/archive/${MY_P}.tar.gz"
+HOMEPAGE="http://www2.lm-sensors.nu/~lm78"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc"
+
+DEPEND="virtual/linux-sources"
+
+src_compile() {
+
+ filter-flags -fPIC
+
+ emake clean all || die "lm_sensors requires the source of a compatible kernel\nversion installed in /usr/src/linux and i2c support built as a modules"
+}
+
+src_install() {
+ emake DESTDIR=${D} PREFIX=/usr MANDIR=/usr/share/man install \
+ || die "Install failed"
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/rc_lm_sensors lm_sensors
+}
+
+pkg_postinst() {
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+
+ einfo
+ einfo "The lm_sensors hardware sensors package has been installed."
+ einfo
+ einfo "It is recommended that you read the lm_sensors documentation."
+ einfo "To enable lm_sensors you will need to compile i2c support in"
+ einfo "your kernel as a module and run /usr/sbin/sensors-detect to"
+ einfo "detect the hardware in your system."
+ einfo
+ einfo "Be warned, the probing of hardware in your system performed by"
+ einfo "sensors-detect could freeze your system. Also do not use"
+ einfo "lm_sensors on certain laptop models from IBM. See the lm_sensors"
+ einfo "documentation and website for more information."
+ einfo
+ einfo "IMPORTANT: When you merge this package it installs kernel modules"
+ einfo "that can only be used with the specific kernel version whose"
+ einfo "source is located in /usr/src/linux. If you upgrade to a new"
+ einfo "kernel, you will need to remerge the lm_sensors package to build"
+ einfo "new kernel modules."
+ einfo
+}
diff --git a/sys-apps/lm-sensors/lm-sensors-2.7.0.ebuild b/sys-apps/lm-sensors/lm-sensors-2.7.0.ebuild
new file mode 100644
index 000000000000..f10bcdd5915b
--- /dev/null
+++ b/sys-apps/lm-sensors/lm-sensors-2.7.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm-sensors/lm-sensors-2.7.0.ebuild,v 1.1 2003/05/29 09:13:03 seemant Exp $
+
+inherit flag-o-matic
+
+MY_P=${PN/-/_}-${PV}
+
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Hardware Sensors Monitoring by lm_sensors"
+SRC_URI="http://www2.lm-sensors.nu/~lm78/archive/${MY_P}.tar.gz"
+HOMEPAGE="http://www2.lm-sensors.nu/~lm78"
+
+SLOT="0"
+# gentoo-sources-2.4.20-r1 and xfs-sources-2.4.20-r1 will
+# have support for this package, do not change these to ~
+# until your arch has i2c-2.7.0 in it's kernel.
+KEYWORDS="~x86 -ppc -sparc"
+LICENSE="GPL-2"
+
+DEPEND="|| (
+ >=sys-apps/i2c-2.7.0
+ >=sys-kernel/gentoo-sources-2.4.20-r1
+ >=sys-kernel/lolo-sources-2.4.20.1
+ >=sys-kernel/xfs-sources-2.4.20_pre4
+ )"
+
+src_compile() {
+ check_KV
+
+ filter-flags -fPIC
+
+ emake clean all || die "lm_sensors requires the source of a compatible kernel\nversion installed in /usr/src/linux and >=i2c-2.7.0 support built as a modules this support is included in gentoo-sources as of 2.4.20-r1"
+}
+
+src_install() {
+ einstall DESTDIR=${D} PREFIX=/usr MANDIR=/usr/share/man || die "Install failed"
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/rc_lm_sensors lm_sensors
+}
+
+pkg_postinst() {
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+
+ einfo
+ einfo "The lm_sensors hardware sensors package has been installed."
+ einfo
+ einfo "It is recommended that you read the lm_sensors documentation."
+ einfo "To enable lm_sensors you will need to compile i2c support in"
+ einfo "your kernel as a module and run /usr/sbin/sensors-detect to"
+ einfo "detect the hardware in your system."
+ einfo
+ einfo "Be warned, the probing of hardware in your system performed by"
+ einfo "sensors-detect could freeze your system. Also do not use"
+ einfo "lm_sensors on certain laptop models from IBM. See the lm_sensors"
+ einfo "documentation and website for more information."
+ einfo
+ einfo "IMPORTANT: When you merge this package it installs kernel modules"
+ einfo "that can only be used with the specific kernel version whose"
+ einfo "source is located in /usr/src/linux. If you upgrade to a new"
+ einfo "kernel, you will need to remerge the lm_sensors package to build"
+ einfo "new kernel modules."
+ einfo
+}