summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-05-05 04:05:58 +0000
committerMike Frysinger <vapier@gentoo.org>2008-05-05 04:05:58 +0000
commit18c9b5f3f76ca48ec9488a47fa169c2808bdb291 (patch)
treed9334eb11c945a16cae0b289cf2b196f0f32b760 /sys-apps/microcode-ctl
parentold (diff)
downloadhistorical-18c9b5f3f76ca48ec9488a47fa169c2808bdb291.tar.gz
historical-18c9b5f3f76ca48ec9488a47fa169c2808bdb291.tar.bz2
historical-18c9b5f3f76ca48ec9488a47fa169c2808bdb291.zip
Convert init.d script to POSIX #219751 by yuen and split off microcode-data #194271 by Mike Nerone.
Package-Manager: portage-2.2_pre5
Diffstat (limited to 'sys-apps/microcode-ctl')
-rw-r--r--sys-apps/microcode-ctl/ChangeLog11
-rw-r--r--sys-apps/microcode-ctl/files/microcode_ctl.rc11
-rw-r--r--sys-apps/microcode-ctl/microcode-ctl-1.17-r1.ebuild42
3 files changed, 56 insertions, 8 deletions
diff --git a/sys-apps/microcode-ctl/ChangeLog b/sys-apps/microcode-ctl/ChangeLog
index 83f6abe20144..b308d099b45f 100644
--- a/sys-apps/microcode-ctl/ChangeLog
+++ b/sys-apps/microcode-ctl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/microcode-ctl
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-ctl/ChangeLog,v 1.28 2007/06/17 10:51:08 armin76 Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-ctl/ChangeLog,v 1.29 2008/05/05 04:05:57 vapier Exp $
+
+*microcode-ctl-1.17-r1 (05 May 2008)
+
+ 05 May 2008; Mike Frysinger <vapier@gentoo.org> files/microcode_ctl.rc,
+ +microcode-ctl-1.17-r1.ebuild:
+ Convert init.d script to POSIX #219751 by yuen and split off microcode-data
+ #194271 by Mike Nerone.
17 Jun 2007; Raúl Porcel <armin76@gentoo.org> microcode-ctl-1.17.ebuild:
x86 stable wrt #182263
diff --git a/sys-apps/microcode-ctl/files/microcode_ctl.rc b/sys-apps/microcode-ctl/files/microcode_ctl.rc
index f71e17d26b1a..8fdab815eb06 100644
--- a/sys-apps/microcode-ctl/files/microcode_ctl.rc
+++ b/sys-apps/microcode-ctl/files/microcode_ctl.rc
@@ -1,7 +1,7 @@
#!/sbin/runscript
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-ctl/files/microcode_ctl.rc,v 1.4 2005/12/26 21:01:37 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-ctl/files/microcode_ctl.rc,v 1.5 2008/05/05 04:05:58 vapier Exp $
depend() {
need localmount
@@ -12,15 +12,14 @@ start() {
# Make sure the kernel supports the microcode device ...
# if it doesnt, try to modprobe the kernel module
- grep -qo ' microcode$' /proc/misc || modprobe microcode >& /dev/null
+ grep -qs ' microcode$' /proc/misc || modprobe -q microcode
ebegin "Updating microcode"
- /usr/sbin/microcode_ctl -qu -d ${MICROCODE_DEV}
+ microcode_ctl -qu -d ${MICROCODE_DEV}
ret=$?
eend ${ret} "Failed to update microcode via '${MICROCODE_DEV}'"
- [[ ${MICROCODE_UNLOAD} == "1" || ${MICROCODE_UNLOAD} == "yes" ]] \
- && rmmod microcode >& /dev/null
+ [ "${MICROCODE_UNLOAD}" = "yes" ] && rmmod microcode >/dev/null 2>&1
return ${ret}
}
diff --git a/sys-apps/microcode-ctl/microcode-ctl-1.17-r1.ebuild b/sys-apps/microcode-ctl/microcode-ctl-1.17-r1.ebuild
new file mode 100644
index 000000000000..43d72493846a
--- /dev/null
+++ b/sys-apps/microcode-ctl/microcode-ctl-1.17-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-ctl/microcode-ctl-1.17-r1.ebuild,v 1.1 2008/05/05 04:05:57 vapier Exp $
+
+inherit toolchain-funcs
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Intel processor microcode update utility"
+HOMEPAGE="http://www.urbanmyth.org/microcode"
+SRC_URI="http://www.urbanmyth.org/microcode/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-apps/microcode-data"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} ${CPPFLAGS} ${LDFLAGS}" \
+ || die "compile problem"
+}
+
+src_install() {
+ dosbin microcode_ctl || die "dosbin"
+ doman microcode_ctl.8
+ dodoc Changelog README
+
+ newinitd "${FILESDIR}"/microcode_ctl.rc microcode_ctl
+ newconfd "${FILESDIR}"/microcode_ctl.conf.d microcode_ctl
+}
+
+pkg_postinst() {
+ ewarn "Your kernel must include microcode update support."
+ echo
+ einfo "Microcode updates will be lost at every reboot."
+ einfo "You can use the init.d script to update at boot time."
+}