summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-01-18 01:27:26 +0000
committerMike Frysinger <vapier@gentoo.org>2011-01-18 01:27:26 +0000
commitdf31819f6ed47485677f4a14a5003ffec52fdba4 (patch)
treecb7939c77a7e8e924f9e4eaff3afbd1b69e09e9c /sys-apps
parentold (diff)
downloadhistorical-df31819f6ed47485677f4a14a5003ffec52fdba4.tar.gz
historical-df31819f6ed47485677f4a14a5003ffec52fdba4.tar.bz2
historical-df31819f6ed47485677f4a14a5003ffec52fdba4.zip
Version bump.
Package-Manager: portage-2.2.0_alpha13/cvs/Linux x86_64
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/file/ChangeLog9
-rw-r--r--sys-apps/file/file-5.05.ebuild55
2 files changed, 62 insertions, 2 deletions
diff --git a/sys-apps/file/ChangeLog b/sys-apps/file/ChangeLog
index ad47f8a287c7..e7eefda856fa 100644
--- a/sys-apps/file/ChangeLog
+++ b/sys-apps/file/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/file
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.185 2010/11/28 17:19:18 ranger Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.186 2011/01/18 01:27:26 vapier Exp $
+
+*file-5.05 (18 Jan 2011)
+
+ 18 Jan 2011; Mike Frysinger <vapier@gentoo.org> +file-5.05.ebuild:
+ Version bump.
28 Nov 2010; Brent Baude <ranger@gentoo.org> file-5.04.ebuild:
stable ppc64, bug 340225
diff --git a/sys-apps/file/file-5.05.ebuild b/sys-apps/file/file-5.05.ebuild
new file mode 100644
index 000000000000..9f910e246ab2
--- /dev/null
+++ b/sys-apps/file/file-5.05.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-5.05.ebuild,v 1.1 2011/01/18 01:27:26 vapier Exp $
+
+PYTHON_DEPEND="python? 2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit eutils distutils libtool flag-o-matic
+
+DESCRIPTION="identify a file's format by scanning binary data for patterns"
+HOMEPAGE="ftp://ftp.astron.com/pub/file/"
+SRC_URI="ftp://ftp.astron.com/pub/file/${P}.tar.gz
+ ftp://ftp.gw.com/mirrors/pub/unix/file/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="python"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}"
+
+ elibtoolize
+ epunt_cxx
+
+ # dont let python README kill main README #60043
+ mv python/README{,.python}
+}
+
+src_compile() {
+ # file uses things like strndup() and wcwidth()
+ append-flags -D_GNU_SOURCE
+
+ econf || die
+ emake || die
+
+ use python && cd python && distutils_src_compile
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ChangeLog MAINT README
+
+ use python && cd python && distutils_src_install
+}
+
+pkg_postinst() {
+ use python && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use python && distutils_pkg_postrm
+}