summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2005-09-25 05:53:33 +0000
committerJoshua Kinard <kumba@gentoo.org>2005-09-25 05:53:33 +0000
commit2eb7848667f921dee5269590e1cd535a6aa17c59 (patch)
treeb0571442443fb0663ffec018995ecc75d46b5e4a /sys-boot/dvhtool/dvhtool-1.0.1-r1.ebuild
parentversion bump - bug #107136. 1.4.5 x86 stable - bug #107137. (diff)
downloadhistorical-2eb7848667f921dee5269590e1cd535a6aa17c59.tar.gz
historical-2eb7848667f921dee5269590e1cd535a6aa17c59.tar.bz2
historical-2eb7848667f921dee5269590e1cd535a6aa17c59.zip
Ebuild cleanups (use epatch), no longer provides virtual/bootloader, remove 22K debian patch and replace with smaller version, add in patch that lets dvhtool recognize RAID/LVM partitions.
Package-Manager: portage-2.0.52-r1
Diffstat (limited to 'sys-boot/dvhtool/dvhtool-1.0.1-r1.ebuild')
-rw-r--r--sys-boot/dvhtool/dvhtool-1.0.1-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-boot/dvhtool/dvhtool-1.0.1-r1.ebuild b/sys-boot/dvhtool/dvhtool-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..f01e1db378ba
--- /dev/null
+++ b/sys-boot/dvhtool/dvhtool-1.0.1-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/dvhtool/dvhtool-1.0.1-r1.ebuild,v 1.1 2005/09/25 05:53:33 kumba Exp $
+
+inherit eutils
+
+DESCRIPTION="Dvhtool is the tool responsible for writing MIPS kernel(s) into the SGI volume header"
+HOMEPAGE="http://packages.debian.org/unstable/utils/dvhtool.html"
+SRC_URI="http://ftp.debian.org/debian/pool/main/d/dvhtool/dvhtool_1.0.1.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~x86 mips"
+IUSE=""
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}.orig
+
+ # several applicable hunks from a debian patch
+ epatch ${FILESDIR}/${P}-debian.diff
+
+ # Allow dvhtool to recognize Linux RAID and Linux LVM partitions
+ epatch ${FILESDIR}/${P}-1.0.1-add-raid-lvm-parttypes.patch
+}
+
+src_compile() {
+ cd ${S}.orig
+ econf || die "econf failed"
+ emake || die "Failed to compile"
+}
+
+src_install() {
+ cd ${S}.orig
+ einstall
+}