summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-20 00:03:11 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-20 00:03:11 +0000
commit197d99fb8e53c2c44ee1466889fcdd421ac3b10c (patch)
tree7643a8e38d13c8e9d5bfeab52233b582354592b6 /sys-boot
parent+sys-boot/grub:custom-cflags (diff)
downloadhistorical-197d99fb8e53c2c44ee1466889fcdd421ac3b10c.tar.gz
historical-197d99fb8e53c2c44ee1466889fcdd421ac3b10c.tar.bz2
historical-197d99fb8e53c2c44ee1466889fcdd421ac3b10c.zip
Add support for USE=custom-cflags #72196 by basic.
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/grub/grub-0.96-r1.ebuild6
-rw-r--r--sys-boot/grub/grub-0.96-r2.ebuild6
-rw-r--r--sys-boot/grub/grub-0.96-r3.ebuild6
3 files changed, 9 insertions, 9 deletions
diff --git a/sys-boot/grub/grub-0.96-r1.ebuild b/sys-boot/grub/grub-0.96-r1.ebuild
index ab6f3764fd6e..a4c853aabab6 100644
--- a/sys-boot/grub/grub-0.96-r1.ebuild
+++ b/sys-boot/grub/grub-0.96-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.96-r1.ebuild,v 1.13 2005/07/28 17:53:38 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.96-r1.ebuild,v 1.14 2005/08/20 00:03:11 vapier Exp $
inherit mount-boot eutils flag-o-matic toolchain-funcs
@@ -17,7 +17,7 @@ SRC_URI="mirror://gentoo/${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="static netboot"
+IUSE="static netboot custom-cflags"
RDEPEND=">=sys-libs/ncurses-5.2-r5"
DEPEND="${RDEPEND}
@@ -69,7 +69,7 @@ src_compile() {
# CFLAGS has to be undefined running econf, else -fno-stack-protector detection fails.
# STAGE2_CFLAGS is not allowed to be used on emake command-line, it overwrites
# -fno-stack-protector detected by configure, removed from netboot's emake.
- unset CFLAGS
+ use custom-cflags || unset CFLAGS
export grub_cv_prog_objcopy_absolute=yes #79734
use static && append-ldflags -static
diff --git a/sys-boot/grub/grub-0.96-r2.ebuild b/sys-boot/grub/grub-0.96-r2.ebuild
index 74dc907c0f11..0b4de9c1c8fe 100644
--- a/sys-boot/grub/grub-0.96-r2.ebuild
+++ b/sys-boot/grub/grub-0.96-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.96-r2.ebuild,v 1.7 2005/08/01 10:34:39 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.96-r2.ebuild,v 1.8 2005/08/20 00:03:11 vapier Exp $
inherit mount-boot eutils flag-o-matic toolchain-funcs
@@ -17,7 +17,7 @@ SRC_URI="mirror://gentoo/${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="static netboot"
+IUSE="static netboot custom-cflags"
RDEPEND=">=sys-libs/ncurses-5.2-r5"
DEPEND="${RDEPEND}
@@ -69,7 +69,7 @@ src_compile() {
# CFLAGS has to be undefined running econf, else -fno-stack-protector detection fails.
# STAGE2_CFLAGS is not allowed to be used on emake command-line, it overwrites
# -fno-stack-protector detected by configure, removed from netboot's emake.
- unset CFLAGS
+ use custom-cflags || unset CFLAGS
export grub_cv_prog_objcopy_absolute=yes #79734
use static && append-ldflags -static
diff --git a/sys-boot/grub/grub-0.96-r3.ebuild b/sys-boot/grub/grub-0.96-r3.ebuild
index 981913b66750..cee42fba7382 100644
--- a/sys-boot/grub/grub-0.96-r3.ebuild
+++ b/sys-boot/grub/grub-0.96-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.96-r3.ebuild,v 1.1 2005/08/03 03:09:44 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.96-r3.ebuild,v 1.2 2005/08/20 00:03:11 vapier Exp $
inherit mount-boot eutils flag-o-matic toolchain-funcs
@@ -17,7 +17,7 @@ SRC_URI="mirror://gentoo/${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="static netboot"
+IUSE="static netboot custom-cflags"
RDEPEND=">=sys-libs/ncurses-5.2-r5"
DEPEND="${RDEPEND}
@@ -68,7 +68,7 @@ src_compile() {
# CFLAGS has to be undefined running econf, else -fno-stack-protector detection fails.
# STAGE2_CFLAGS is not allowed to be used on emake command-line, it overwrites
# -fno-stack-protector detected by configure, removed from netboot's emake.
- unset CFLAGS
+ use custom-cflags || unset CFLAGS
export grub_cv_prog_objcopy_absolute=yes #79734
use static && append-ldflags -static