summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2005-03-30 19:50:57 +0000
committerTim Yamin <plasmaroo@gentoo.org>2005-03-30 19:50:57 +0000
commit4eaacfd86e2d28058ff7f0e08d623f37e82fa133 (patch)
tree7d0017eba4fe4f164c9e4a11256c77589480c4c5 /sys-boot
parentAdd ~alpha keyword, bug 86602. (diff)
downloadhistorical-4eaacfd86e2d28058ff7f0e08d623f37e82fa133.tar.gz
historical-4eaacfd86e2d28058ff7f0e08d623f37e82fa133.tar.bz2
historical-4eaacfd86e2d28058ff7f0e08d623f37e82fa133.zip
Backport --efiboot fix for 2.6 kernels from Debian.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/elilo/ChangeLog7
-rw-r--r--sys-boot/elilo/Manifest6
-rw-r--r--sys-boot/elilo/elilo-3.4-r1.ebuild64
-rw-r--r--sys-boot/elilo/files/digest-elilo-3.4-r11
-rw-r--r--sys-boot/elilo/files/elilo-3.44
5 files changed, 77 insertions, 5 deletions
diff --git a/sys-boot/elilo/ChangeLog b/sys-boot/elilo/ChangeLog
index 5c8755d7ef43..a10bfec38ba9 100644
--- a/sys-boot/elilo/ChangeLog
+++ b/sys-boot/elilo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/elilo
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/elilo/ChangeLog,v 1.7 2005/01/22 13:29:32 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/elilo/ChangeLog,v 1.8 2005/03/30 19:50:57 plasmaroo Exp $
+
+*elilo-3.4-r1 (30 Mar 2005)
+
+ 30 Mar 2005; <plasmaroo@gentoo.org> +elilo-3.4-r1.ebuild, files/elilo-3.4:
+ Backport --efiboot fix for 2.6 kernels from Debian.
22 Jan 2005; <plasmaroo@gentoo.org> elilo-3.4.ebuild:
Fix total build breakage; inherit toolchain-funcs please...
diff --git a/sys-boot/elilo/Manifest b/sys-boot/elilo/Manifest
index c65ee23fc7da..b47607609962 100644
--- a/sys-boot/elilo/Manifest
+++ b/sys-boot/elilo/Manifest
@@ -1,9 +1,11 @@
-MD5 fe3468ea49f1e09e386788f29f333fd4 ChangeLog 959
+MD5 f454ea5f02df63b83aa3fa8c34053798 ChangeLog 1120
MD5 20991ffcb681a67b533700cafde1a6f9 elilo-3.4.ebuild 1779
+MD5 46b23f2a5ba4295b08bad2462a1f120e elilo-3.4-r1.ebuild 1782
MD5 a479f5334497679bd91ddc7181866f52 files/eliloalt.8-3.4 550
MD5 2b2d58955c4ad612fee3bcf9b977bc41 files/elilo-3.4-makefile.patch 338
+MD5 85650d47a2950be23774d73205b19e97 files/digest-elilo-3.4-r1 61
MD5 b8d17fae7a7884645a7f89b31129e3d0 files/elilo.conf.sample 161
MD5 5e611594843275c52c4b4921b89a23e4 files/elilo.8-3.4 3286
MD5 2640f713f5f00cf0a17e31d220c8242c files/elilo-3.3a-devscheme.patch 3571
-MD5 c41337651da1c5b597609856146438ec files/elilo-3.4 22707
+MD5 821c2877ad33567d7c7dc9598331e7f9 files/elilo-3.4 22782
MD5 85650d47a2950be23774d73205b19e97 files/digest-elilo-3.4 61
diff --git a/sys-boot/elilo/elilo-3.4-r1.ebuild b/sys-boot/elilo/elilo-3.4-r1.ebuild
new file mode 100644
index 000000000000..1f7132c082cf
--- /dev/null
+++ b/sys-boot/elilo/elilo-3.4-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/elilo/elilo-3.4-r1.ebuild,v 1.1 2005/03/30 19:50:57 plasmaroo Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Linux boot loader for EFI-based systems such as IA-64"
+HOMEPAGE="http://developer.intel.com/technology/efi"
+SRC_URI="ftp://ftp.hpl.hp.com/pub/linux-ia64/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="ia64"
+IUSE=""
+
+# gnu-efi contains only static libs, so there's no run-time dep on it
+DEPEND=">=sys-boot/gnu-efi-3.0"
+RDEPEND="sys-boot/efibootmgr
+ sys-fs/dosfstools"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/elilo-3.4-makefile.patch
+ epatch ${FILESDIR}/elilo-3.3a-devscheme.patch
+}
+
+src_compile() {
+ local iarch
+ case $ARCH in
+ ia64) iarch=ia64 ;;
+ x86) iarch=ia32 ;; # for cross-compiling?
+ *) die "unknown architecture: $ARCH" ;;
+ esac
+
+ # "prefix" on the next line specifies where to find gcc, as, ld,
+ # etc. It's not the usual meaning of "prefix". By blanking it we
+ # allow PATH to be searched.
+ emake -j1 prefix= CC="$(tc-getCC)" ARCH=${iarch} || die "emake failed"
+
+ # unversion the man-pages and Debian's elilo script
+ cp ${FILESDIR}/elilo.8-${PV} elilo.8
+ cp ${FILESDIR}/eliloalt.8-${PV} eliloalt.8
+ cp ${FILESDIR}/elilo-${PV} elilo
+}
+
+src_install() {
+ dodir /usr/lib/elilo /usr/sbin /etc
+
+ # install the efi executable in a known location
+ install -m755 elilo.efi ${D}/usr/lib/elilo || die
+
+ # install eliloalt
+ install -m755 tools/eliloalt ${D}/usr/sbin || die
+ doman eliloalt.8 || die
+
+ # text docs
+ dodoc docs/*
+
+ # install the debian elilo script
+ install -m755 elilo ${D}/usr/sbin || die
+ install -m644 ${FILESDIR}/elilo.conf.sample ${D}/etc || die
+ doman elilo.8 || die
+}
diff --git a/sys-boot/elilo/files/digest-elilo-3.4-r1 b/sys-boot/elilo/files/digest-elilo-3.4-r1
new file mode 100644
index 000000000000..6c9603e2135d
--- /dev/null
+++ b/sys-boot/elilo/files/digest-elilo-3.4-r1
@@ -0,0 +1 @@
+MD5 e7357929dfca29436d35ad6386fc051c elilo-3.4.tar.gz 316518
diff --git a/sys-boot/elilo/files/elilo-3.4 b/sys-boot/elilo/files/elilo-3.4
index 08bbb03527f4..f34a2fe75a54 100644
--- a/sys-boot/elilo/files/elilo-3.4
+++ b/sys-boot/elilo/files/elilo-3.4
@@ -269,8 +269,8 @@ checkconf()
local CONFERR=1
fi
- if [ ! -d /proc/efi/vars -a "$efiboot" = 1 ] ; then
- echo 1>&2 "$PRG: /proc/efi/vars not available, boot menu not updated"
+ if [ ! -d /proc/efi/vars ] && [ ! -d /sys/firmware/efi/vars ] && [ "$efiboot" = 1 ] && ! modprobe -q efivars; then
+ echo 1>&2 "$PRG: no efi/vars under /proc or /sys/firmware, boot menu not updated"
efiboot=0
fi