summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Zoffoli <xmerlin@gentoo.org>2008-03-23 16:23:12 +0000
committerChristian Zoffoli <xmerlin@gentoo.org>2008-03-23 16:23:12 +0000
commit67af7599a3f3072136b58113e9be343f23059f9a (patch)
tree7734e611d5414fdebd8d179c0402553a7343049e /sys-cluster/ccs
parentFixed typo in postrm, bug #214380, thank Denilson for report (diff)
downloadhistorical-67af7599a3f3072136b58113e9be343f23059f9a.tar.gz
historical-67af7599a3f3072136b58113e9be343f23059f9a.tar.bz2
historical-67af7599a3f3072136b58113e9be343f23059f9a.zip
Updated 2.02.00 to STABLE2 20080323.
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'sys-cluster/ccs')
-rw-r--r--sys-cluster/ccs/ChangeLog8
-rw-r--r--sys-cluster/ccs/ccs-2.02.00-r1.ebuild67
2 files changed, 74 insertions, 1 deletions
diff --git a/sys-cluster/ccs/ChangeLog b/sys-cluster/ccs/ChangeLog
index 60b64be4da15..529d566bd3dc 100644
--- a/sys-cluster/ccs/ChangeLog
+++ b/sys-cluster/ccs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/ccs
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ccs/ChangeLog,v 1.37 2008/03/17 16:31:39 xmerlin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ccs/ChangeLog,v 1.38 2008/03/23 16:07:33 xmerlin Exp $
+
+*ccs-2.02.00-r1 (23 Mar 2008)
+
+ 23 Mar 2008; Christian Zoffoli <xmerlin@gentoo.org>
+ +ccs-2.02.00-r1.ebuild:
+ Updated 2.02.00 to STABLE2 20080323.
*ccs-2.02.00 (17 Mar 2008)
diff --git a/sys-cluster/ccs/ccs-2.02.00-r1.ebuild b/sys-cluster/ccs/ccs-2.02.00-r1.ebuild
new file mode 100644
index 000000000000..4aa1f8505087
--- /dev/null
+++ b/sys-cluster/ccs/ccs-2.02.00-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ccs/ccs-2.02.00-r1.ebuild,v 1.1 2008/03/23 16:07:33 xmerlin Exp $
+
+inherit eutils versionator
+
+CVS_RELEASE="20080323"
+CLUSTER_RELEASE="${PV}"
+MY_P="cluster-${CLUSTER_RELEASE}"
+
+MAJ_PV="$(get_major_version)"
+MIN_PV="$(get_version_component_range 2).$(get_version_component_range 3)"
+
+DESCRIPTION="cluster configuration system to manage the cluster config file"
+HOMEPAGE="http://sources.redhat.com/cluster/"
+SRC_URI="ftp://sources.redhat.com/pub/cluster/releases/${MY_P}.tar.gz
+ mirror://gentoo/gfs-${PV}-${CVS_RELEASE}-cvs.patch.bz2
+ http://dev.gentoo.org/~xmerlin/gfs/gfs-${PV}-${CVS_RELEASE}-cvs.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="=sys-cluster/cman-lib-${CLUSTER_RELEASE}*"
+DEPEND="${RDEPEND}
+ dev-libs/libxml2
+ sys-libs/zlib"
+
+S="${WORKDIR}/${MY_P}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ (cd "${WORKDIR}"/${MY_P};
+ epatch "${WORKDIR}"/gfs-2.02.00-20080323-cvs.patch || die
+ )
+}
+
+src_compile() {
+ (cd "${WORKDIR}"/${MY_P};
+ ./configure \
+ --cc=$(tc-getCC) \
+ --cflags="-Wall" \
+ --disable_kernel_check \
+ --somajor="$MAJ_PV" \
+ --sominor="$MIN_PV" \
+ --cmanlibdir=/usr/lib \
+ --cmanincdir=/usr/include \
+ ) || die "configure problem"
+
+ # fix the manual pages have executable bit
+ sed -i -e '
+ /\tinstall -d/s/install/& -m 0755/; t
+ /\tinstall/s/install/& -m 0644/' \
+ man/Makefile
+
+ #rm -f "${S}"/lib/log.c || die
+
+ emake clean || die "clean problem"
+ emake || die "compile problem"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install problem"
+}