summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-10-07 16:17:50 +0000
committerMike Frysinger <vapier@gentoo.org>2010-10-07 16:17:50 +0000
commitb5ffc0e9196d37a2be83ec1a9e766930cb54ed0b (patch)
tree12c69d889255979e6e87e43630c83b8a8e428f93 /sys-fs/e2fsprogs
parentia64/s390/sh stable #337270 (diff)
downloadhistorical-b5ffc0e9196d37a2be83ec1a9e766930cb54ed0b.tar.gz
historical-b5ffc0e9196d37a2be83ec1a9e766930cb54ed0b.tar.bz2
historical-b5ffc0e9196d37a2be83ec1a9e766930cb54ed0b.zip
old
Diffstat (limited to 'sys-fs/e2fsprogs')
-rw-r--r--sys-fs/e2fsprogs/e2fsprogs-1.40.9.ebuild130
-rw-r--r--sys-fs/e2fsprogs/e2fsprogs-1.41.9.ebuild142
-rw-r--r--sys-fs/e2fsprogs/files/e2fsprogs-1.39-makefile.patch72
-rw-r--r--sys-fs/e2fsprogs/files/e2fsprogs-1.40.5-libintl.patch15
-rw-r--r--sys-fs/e2fsprogs/files/e2fsprogs-1.41.0-makefile.patch87
-rw-r--r--sys-fs/e2fsprogs/files/e2fsprogs-1.41.10-e2fsck-corruption.patch38
-rw-r--r--sys-fs/e2fsprogs/files/e2fsprogs-1.41.2-makefile.patch80
-rw-r--r--sys-fs/e2fsprogs/files/e2fsprogs-1.41.3-tune2fs-opt.patch99
8 files changed, 0 insertions, 663 deletions
diff --git a/sys-fs/e2fsprogs/e2fsprogs-1.40.9.ebuild b/sys-fs/e2fsprogs/e2fsprogs-1.40.9.ebuild
deleted file mode 100644
index 1a4a6f3f17e1..000000000000
--- a/sys-fs/e2fsprogs/e2fsprogs-1.40.9.ebuild
+++ /dev/null
@@ -1,130 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/e2fsprogs-1.40.9.ebuild,v 1.9 2009/12/01 04:47:34 vapier Exp $
-
-inherit eutils flag-o-matic toolchain-funcs multilib
-
-DESCRIPTION="Standard EXT2 and EXT3 filesystem utilities"
-HOMEPAGE="http://e2fsprogs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/e2fsprogs/${P}.tar.gz"
-
-LICENSE="GPL-2 BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="nls static elibc_FreeBSD"
-
-RDEPEND="~sys-libs/com_err-${PV}
- ~sys-libs/ss-${PV}
- nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- sys-apps/texinfo"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-1.38-tests-locale.patch #99766
- chmod u+w po/*.po # Userpriv fix #27348
- # Clean up makefile to suck less
- epatch "${FILESDIR}"/e2fsprogs-1.39-makefile.patch
- epatch "${FILESDIR}"/${PN}-1.40.5-libintl.patch #122368
- epatch "${FILESDIR}"/${PN}-1.40-fbsd.patch
-
- # kernel headers use the same defines as e2fsprogs and can cause issues #48829
- sed -i \
- -e 's:CONFIG_JBD_DEBUG:__CONFIG_JBD_DEBUG__E2FS:g' \
- $(grep -rl CONFIG_JBD_DEBUG *) \
- || die "sed jbd debug failed"
-
- # fake out files we forked into sep packages
- sed -i \
- -e '/^LIB_SUBDIRS/s:lib/et::' \
- -e '/^LIB_SUBDIRS/s:lib/ss::' \
- Makefile.in || die "remove subdirs"
-
- # since we've split out com_err/ss into their own ebuilds, we
- # need to fake out the local files. let the toolchain find them.
- echo "GROUP ( /usr/$(get_libdir)/libcom_err.a )" > lib/libcom_err.a
- echo "GROUP ( /usr/$(get_libdir)/libcom_err.so )" > lib/libcom_err.so
- echo "GROUP ( /usr/$(get_libdir)/libss.a )" > lib/libss.a
- echo "GROUP ( /usr/$(get_libdir)/libss.so )" > lib/libss.so
- echo '#include_next <ss/ss_err.h>' > lib/ss/ss_err.h
- ln -s /usr/bin/mk_cmds lib/ss/mk_cmds
-
- # sanity check for Bug 105304
- if [[ -z ${USERLAND} ]] ; then
- eerror "You just hit Bug 105304, please post your 'emerge info' here:"
- eerror "http://bugs.gentoo.org/105304"
- die "Aborting to prevent screwing your system"
- fi
-}
-
-src_compile() {
- # Keep the package from doing silly things
- export LDCONFIG=:
- export CC=$(tc-getCC)
- export STRIP=:
-
- econf \
- --bindir=/bin \
- --sbindir=/sbin \
- --enable-elf-shlibs \
- --with-ldopts="${LDFLAGS}" \
- $(use_enable !static dynamic-e2fsck) \
- $(tc-has-tls || echo --disable-tls) \
- --without-included-gettext \
- $(use_enable nls) \
- $(use_enable userland_GNU fsck) \
- || die
- if [[ ${CHOST} != *-uclibc ]] && grep -qs 'USE_INCLUDED_LIBINTL.*yes' config.{log,status} ; then
- eerror "INTL sanity check failed, aborting build."
- eerror "Please post your ${S}/config.log file as an"
- eerror "attachment to http://bugs.gentoo.org/show_bug.cgi?id=81096"
- die "Preventing included intl cruft from building"
- fi
- # Parallel make sometimes fails
- emake -j1 COMPILE_ET=compile_et || die
-
- # Build the FreeBSD helper
- if use elibc_FreeBSD ; then
- cp "${FILESDIR}"/fsck_ext2fs.c .
- emake fsck_ext2fs || die
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc README RELEASE-NOTES
-
- # Move shared libraries to /lib/, install static libraries to /usr/lib/,
- # and install linker scripts to /usr/lib/.
- dodir /$(get_libdir)
- mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)/
- dolib.a lib/*.a || die "dolib.a"
- rm -f "${D}"/usr/$(get_libdir)/lib{com_err,ss}.a #125146
- local x
- cd "${D}"/$(get_libdir)
- for x in *.so ; do
- gen_usr_ldscript ${x} || die "gen ldscript ${x}"
- done
-
- # move 'useless' stuff to /usr/
- dosbin "${D}"/sbin/mklost+found
- rm -f "${D}"/sbin/mklost+found
-
- if use elibc_FreeBSD ; then
- # Install helpers for us
- into /
- dosbin "${S}"/fsck_ext2fs || die
- doman "${FILESDIR}"/fsck_ext2fs.8
-
- # these manpages are already provided by FreeBSD libc
- # and filefrag is linux only
- rm -f \
- "${D}"/sbin/filefrag \
- "${D}"/usr/share/man/man8/filefrag.8 \
- "${D}"/bin/uuidgen \
- "${D}"/usr/share/man/man3/{uuid,uuid_compare}.3 \
- "${D}"/usr/share/man/man1/uuidgen.1 || die
- fi
-}
diff --git a/sys-fs/e2fsprogs/e2fsprogs-1.41.9.ebuild b/sys-fs/e2fsprogs/e2fsprogs-1.41.9.ebuild
deleted file mode 100644
index 650a8204a645..000000000000
--- a/sys-fs/e2fsprogs/e2fsprogs-1.41.9.ebuild
+++ /dev/null
@@ -1,142 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/e2fsprogs-1.41.9.ebuild,v 1.12 2009/12/07 11:11:31 ssuominen Exp $
-
-inherit eutils flag-o-matic toolchain-funcs multilib
-
-DESCRIPTION="Standard EXT2/EXT3/EXT4 filesystem utilities"
-HOMEPAGE="http://e2fsprogs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/e2fsprogs/${P}.tar.gz"
-
-LICENSE="GPL-2 BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 -x86-fbsd"
-IUSE="nls elibc_FreeBSD"
-
-RDEPEND="~sys-libs/${PN}-libs-${PV}
- >=sys-apps/util-linux-2.16
- nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- dev-util/pkgconfig
- sys-apps/texinfo"
-
-pkg_setup() {
- if [[ ! -e ${ROOT}/etc/mtab ]] ; then
- # add some crap to deal with missing /etc/mtab #217719
- ewarn "No /etc/mtab file, creating one temporarily"
- echo "${PN} crap for src_test" > "${ROOT}"/etc/mtab
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-1.38-tests-locale.patch #99766
- epatch "${FILESDIR}"/${PN}-1.41.8-makefile.patch
- epatch "${FILESDIR}"/${PN}-1.40-fbsd.patch
- # use symlinks rather than hardlinks
- sed -i \
- -e 's:$(LN) -f $(DESTDIR).*/:$(LN_S) -f :' \
- {e2fsck,misc}/Makefile.in || die
- # blargh ... trick e2fsprogs into using e2fsprogs-libs
- rm -rf doc
- sed -i -r \
- -e 's:@LIBINTL@:@LTLIBINTL@:' \
- -e '/^LIB(COM_ERR|SS)/s:[$][(]LIB[)]/lib([^@]*)@LIB_EXT@:-l\1:' \
- -e '/^DEPLIB(COM_ERR|SS)/s:=.*:=:' \
- MCONFIG.in || die "muck libs" #122368
- sed -i -r \
- -e '/^LIB_SUBDIRS/s:lib/(et|ss)::g' \
- Makefile.in || die "remove subdirs"
- # stupid configure script clobbers CC for us
- sed -i \
- -e '/if test -z "$CC" ; then CC=cc; fi/d' \
- configure || die "touching configure"
-
- # Avoid rebuild
- touch lib/ss/ss_err.h
-}
-
-src_compile() {
- # Keep the package from doing silly things #261411
- export VARTEXFONTS=${T}/fonts
-
- # We want to use the "bsd" libraries while building on Darwin, but while
- # building on other Gentoo/*BSD we prefer elf-naming scheme.
- local libtype
- case ${CHOST} in
- *-darwin*) libtype=bsd;;
- *) libtype=elf;;
- esac
-
- ac_cv_path_LDCONFIG=: \
- econf \
- --with-root-prefix=/ \
- --enable-${libtype}-shlibs \
- --with-ldopts="${LDFLAGS}" \
- $(tc-has-tls || echo --disable-tls) \
- --without-included-gettext \
- $(use_enable nls) \
- --disable-libblkid \
- --disable-libuuid \
- --disable-fsck \
- --disable-uuidd
- if [[ ${CHOST} != *-uclibc ]] && grep -qs 'USE_INCLUDED_LIBINTL.*yes' config.{log,status} ; then
- eerror "INTL sanity check failed, aborting build."
- eerror "Please post your ${S}/config.log file as an"
- eerror "attachment to http://bugs.gentoo.org/show_bug.cgi?id=81096"
- die "Preventing included intl cruft from building"
- fi
- emake COMPILE_ET=compile_et MK_CMDS=mk_cmds || die
-
- # Build the FreeBSD helper
- if use elibc_FreeBSD ; then
- cp "${FILESDIR}"/fsck_ext2fs.c .
- emake fsck_ext2fs || die
- fi
-}
-
-pkg_preinst() {
- if [[ -r ${ROOT}/etc/mtab ]] ; then
- if [[ $(<"${ROOT}"/etc/mtab) == "${PN} crap for src_test" ]] ; then
- rm -f "${ROOT}"/etc/mtab
- fi
- fi
-}
-
-src_install() {
- # need to set root_libdir= manually as any --libdir options in the
- # econf above (i.e. multilib) will screw up the default #276465
- emake \
- STRIP=: \
- root_libdir="/$(get_libdir)" \
- DESTDIR="${D}" \
- install install-libs || die
- dodoc README RELEASE-NOTES
-
- insinto /etc
- doins "${FILESDIR}"/e2fsck.conf || die
-
- # make sure symlinks are relative, not absolute, for cross-compiling
- cd "${D}"/usr/$(get_libdir)
- local x l
- for x in lib* ; do
- l=$(readlink "${x}")
- [[ ${l} == /* ]] || continue
- rm -f "${x}"
- ln -s "../..${l}" "${x}"
- done
-
- if use elibc_FreeBSD ; then
- # Install helpers for us
- into /
- dosbin "${S}"/fsck_ext2fs || die
- doman "${FILESDIR}"/fsck_ext2fs.8
-
- # filefrag is linux only
- rm \
- "${D}"/usr/sbin/filefrag \
- "${D}"/usr/share/man/man8/filefrag.8 || die
- fi
-}
diff --git a/sys-fs/e2fsprogs/files/e2fsprogs-1.39-makefile.patch b/sys-fs/e2fsprogs/files/e2fsprogs-1.39-makefile.patch
deleted file mode 100644
index 4eaebba15d23..000000000000
--- a/sys-fs/e2fsprogs/files/e2fsprogs-1.39-makefile.patch
+++ /dev/null
@@ -1,72 +0,0 @@
---- Makefile.in
-+++ Makefile.in
-@@ -48,3 +48,3 @@
- install-shlibs-libs-recursive install-doc-libs
-- if test ! -d e2fsck && test ! -d debugfs && test ! -d misc && test ! -d ext2ed ; then $(MAKE) install-libs ; fi
-+ $(MAKE) install-libs
-
---- e2fsck/Makefile.in
-+++ e2fsck/Makefile.in
-@@ -163,6 +163,6 @@
- @echo " LINK $(root_sbindir)/fsck.ext2"
-- @$(LN) -f $(DESTDIR)$(root_sbindir)/e2fsck \
-+ @$(LN_S) -f e2fsck \
- $(DESTDIR)$(root_sbindir)/fsck.ext2
- @echo " LINK $(root_sbindir)/fsck.ext3"
-- @$(LN) -f $(DESTDIR)$(root_sbindir)/e2fsck \
-+ @$(LN_S) -f e2fsck \
- $(DESTDIR)$(root_sbindir)/fsck.ext3
-@@ -176,6 +176,6 @@
- @echo " LINK $(man8dir)/fsck.ext2.8"
-- @$(LN) -f $(DESTDIR)$(man8dir)/e2fsck.8 \
-+ @$(LN_S) -f e2fsck.8 \
- $(DESTDIR)$(man8dir)/fsck.ext2.8
- @echo " LINK $(man8dir)/fsck.ext3.8"
-- @$(LN) -f $(DESTDIR)$(man8dir)/e2fsck.8 \
-+ @$(LN_S) -f e2fsck.8 \
- $(DESTDIR)$(man8dir)/fsck.ext3.8
---- misc/Makefile.in
-+++ misc/Makefile.in
-@@ -228,12 +228,12 @@
- @echo " LINK $(root_sbindir)/mkfs.ext2"
-- @$(LN) -f $(DESTDIR)$(root_sbindir)/mke2fs \
-+ @$(LN_S) -f mke2fs \
- $(DESTDIR)$(root_sbindir)/mkfs.ext2
- @echo " LINK $(root_sbindir)/mkfs.ext3"
-- @$(LN) -f $(DESTDIR)$(root_sbindir)/mke2fs \
-+ @$(LN_S) -f mke2fs \
- $(DESTDIR)$(root_sbindir)/mkfs.ext3
- @echo " LINK $(root_sbindir)/e2label"
-- @$(LN) -f $(DESTDIR)$(root_sbindir)/tune2fs \
-+ @$(LN_S) -f tune2fs \
- $(DESTDIR)$(root_sbindir)/e2label
- @echo " LINK $(root_sbindir)/findfs"
-- @$(LN) -f $(DESTDIR)$(root_sbindir)/tune2fs \
-+ @$(LN_S) -f tune2fs \
- $(DESTDIR)$(root_sbindir)/findfs
-@@ -257,6 +257,6 @@
- @echo " LINK mkfs.ext2.8"
-- @$(LN) -f $(DESTDIR)$(man8dir)/mke2fs.8 \
-+ @$(LN_S) -f mke2fs.8 \
- $(DESTDIR)$(man8dir)/mkfs.ext2.8
- @echo " LINK mkfs.ext3.8"
-- @$(LN) -f $(DESTDIR)$(man8dir)/mke2fs.8 \
-+ @$(LN_S) -f mke2fs.8 \
- $(DESTDIR)$(man8dir)/mkfs.ext3.8
---- lib/uuid/Makefile.in
-+++ lib/uuid/Makefile.in
-@@ -148,5 +148,5 @@
- @echo " LINK $(man3dir)/uuid_generate_random.3"
-- @$(LN) -f $(DESTDIR)$(man3dir)/uuid_generate.3 $(DESTDIR)$(man3dir)/uuid_generate_random.3
-+ @$(LN_S) -f uuid_generate.3 $(DESTDIR)$(man3dir)/uuid_generate_random.3
- @echo " LINK $(man3dir)/uuid_generate_time.3"
-- @$(LN) -f $(DESTDIR)$(man3dir)/uuid_generate.3 $(DESTDIR)$(man3dir)/uuid_generate_time.3
-+ @$(LN_S) -f uuid_generate.3 $(DESTDIR)$(man3dir)/uuid_generate_time.3
- @echo " INSTALL_DATA $(libdir)/pkgconfig/uuid.pc"
---- lib/Makefile.elf-lib
-+++ lib/Makefile.elf-lib
-@@ -49,3 +49,3 @@
- @echo " SYMLINK $(libdir)/$(ELF_IMAGE).so"
-- @$(LN_S) -f $(ELF_INSTALL_DIR)/$(ELF_SONAME) \
-+ @$(LN_S) -f $(ELF_SONAME) \
- $(DESTDIR)$(libdir)/$(ELF_IMAGE).so
diff --git a/sys-fs/e2fsprogs/files/e2fsprogs-1.40.5-libintl.patch b/sys-fs/e2fsprogs/files/e2fsprogs-1.40.5-libintl.patch
deleted file mode 100644
index 272807368cff..000000000000
--- a/sys-fs/e2fsprogs/files/e2fsprogs-1.40.5-libintl.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Fixes libintl handling on non-glibc
-
-http://bugs.gentoo.org/122368
-
---- e2fsprogs-1.40/MCONFIG.in
-+++ e2fsprogs-1.40/MCONFIG.in
-@@ -71,7 +71,7 @@
- LIBEXT2FS = $(LIB)/libext2fs@LIB_EXT@
- LIBUUID = $(LIB)/libuuid@LIB_EXT@ @SOCKET_LIB@
- LIBBLKID = $(LIB)/libblkid@LIB_EXT@ @STATIC_BLKID_DEVMAPPER_LIBS@
--LIBINTL = @LIBINTL@
-+LIBINTL = @LTLIBINTL@
- DEPLIBUUID = $(LIB)/libuuid@LIB_EXT@
- DEPLIBBLKID = $(LIB)/libblkid@LIB_EXT@
-
diff --git a/sys-fs/e2fsprogs/files/e2fsprogs-1.41.0-makefile.patch b/sys-fs/e2fsprogs/files/e2fsprogs-1.41.0-makefile.patch
deleted file mode 100644
index f4c95e14dbd0..000000000000
--- a/sys-fs/e2fsprogs/files/e2fsprogs-1.41.0-makefile.patch
+++ /dev/null
@@ -1,87 +0,0 @@
---- e2fsck/Makefile.in
-+++ e2fsck/Makefile.in
-@@ -199,12 +199,12 @@
- @echo " LINK $(root_sbindir)/fsck.ext2"
-- @$(LN) -f $(DESTDIR)$(root_sbindir)/e2fsck \
-+ @$(LN_S) -f e2fsck \
- $(DESTDIR)$(root_sbindir)/fsck.ext2
- @echo " LINK $(root_sbindir)/fsck.ext3"
-- @$(LN) -f $(DESTDIR)$(root_sbindir)/e2fsck \
-+ @$(LN_S) -f e2fsck \
- $(DESTDIR)$(root_sbindir)/fsck.ext3
- @echo " LINK $(root_sbindir)/fsck.ext4"
-- @$(LN) -f $(DESTDIR)$(root_sbindir)/e2fsck \
-+ @$(LN_S) -f e2fsck \
- $(DESTDIR)$(root_sbindir)/fsck.ext4
- @echo " LINK $(root_sbindir)/fsck.ext4dev"
-- @$(LN) -f $(DESTDIR)$(root_sbindir)/e2fsck \
-+ @$(LN_S) -f e2fsck \
- $(DESTDIR)$(root_sbindir)/fsck.ext4dev
-@@ -225,12 +225,12 @@
- @echo " LINK $(man8dir)/fsck.ext2.8"
-- @$(LN) -f $(DESTDIR)$(man8dir)/e2fsck.8 \
-+ @$(LN_S) -f e2fsck.8 \
- $(DESTDIR)$(man8dir)/fsck.ext2.8
- @echo " LINK $(man8dir)/fsck.ext3.8"
-- @$(LN) -f $(DESTDIR)$(man8dir)/e2fsck.8 \
-+ @$(LN_S) -f e2fsck.8 \
- $(DESTDIR)$(man8dir)/fsck.ext3.8
- @echo " LINK $(man8dir)/fsck.ext4.8"
-- @$(LN) -f $(DESTDIR)$(man8dir)/e2fsck.8 \
-+ @$(LN_S) -f e2fsck.8 \
- $(DESTDIR)$(man8dir)/fsck.ext4.8
- @echo " LINK $(man8dir)/fsck.ext4.8"
-- @$(LN) -f $(DESTDIR)$(man8dir)/e2fsck.8 \
-+ @$(LN_S) -f e2fsck.8 \
- $(DESTDIR)$(man8dir)/fsck.ext4dev.8
---- misc/Makefile.in
-+++ misc/Makefile.in
-@@ -279,18 +279,18 @@
- @echo " LINK $(root_sbindir)/mkfs.ext2"
-- @$(LN) -f $(DESTDIR)$(root_sbindir)/mke2fs \
-+ @$(LN_S) -f mke2fs \
- $(DESTDIR)$(root_sbindir)/mkfs.ext2
- @echo " LINK $(root_sbindir)/mkfs.ext3"
-- @$(LN) -f $(DESTDIR)$(root_sbindir)/mke2fs \
-+ @$(LN_S) -f mke2fs \
- $(DESTDIR)$(root_sbindir)/mkfs.ext3
- @echo " LINK $(root_sbindir)/mkfs.ext4"
-- @$(LN) -f $(DESTDIR)$(root_sbindir)/mke2fs \
-+ @$(LN_S) -f mke2fs \
- $(DESTDIR)$(root_sbindir)/mkfs.ext4
- @echo " LINK $(root_sbindir)/mkfs.ext4dev"
-- @$(LN) -f $(DESTDIR)$(root_sbindir)/mke2fs \
-+ @$(LN_S) -f mke2fs \
- $(DESTDIR)$(root_sbindir)/mkfs.ext4dev
- @echo " LINK $(root_sbindir)/e2label"
-- @$(LN) -f $(DESTDIR)$(root_sbindir)/tune2fs \
-+ @$(LN_S) -f tune2fs \
- $(DESTDIR)$(root_sbindir)/e2label
- @echo " LINK $(root_sbindir)/findfs"
-- @$(LN) -f $(DESTDIR)$(root_sbindir)/tune2fs \
-+ @$(LN_S) -f tune2fs \
- $(DESTDIR)$(root_sbindir)/findfs
-@@ -314,12 +314,12 @@
- @echo " LINK mkfs.ext2.8"
-- @$(LN) -f $(DESTDIR)$(man8dir)/mke2fs.8 \
-+ @$(LN_S) -f mke2fs.8 \
- $(DESTDIR)$(man8dir)/mkfs.ext2.8
- @echo " LINK mkfs.ext3.8"
-- @$(LN) -f $(DESTDIR)$(man8dir)/mke2fs.8 \
-+ @$(LN_S) -f mke2fs.8 \
- $(DESTDIR)$(man8dir)/mkfs.ext3.8
- @echo " LINK mkfs.ext4.8"
-- @$(LN) -f $(DESTDIR)$(man8dir)/mke2fs.8 \
-+ @$(LN_S) -f mke2fs.8 \
- $(DESTDIR)$(man8dir)/mkfs.ext4.8
- @echo " LINK mkfs.ext4dev.8"
-- @$(LN) -f $(DESTDIR)$(man8dir)/mke2fs.8 \
-+ @$(LN_S) -f mke2fs.8 \
- $(DESTDIR)$(man8dir)/mkfs.ext4dev.8
---- lib/Makefile.elf-lib
-+++ lib/Makefile.elf-lib
-@@ -49,3 +49,3 @@
- @echo " SYMLINK $(libdir)/$(ELF_IMAGE).so"
-- @$(LN_S) -f $(ELF_INSTALL_DIR)/$(ELF_SONAME) \
-+ @$(LN_S) -f $(ELF_SONAME) \
- $(DESTDIR)$(libdir)/$(ELF_IMAGE).so
diff --git a/sys-fs/e2fsprogs/files/e2fsprogs-1.41.10-e2fsck-corruption.patch b/sys-fs/e2fsprogs/files/e2fsprogs-1.41.10-e2fsck-corruption.patch
deleted file mode 100644
index 4f24b9ada8cc..000000000000
--- a/sys-fs/e2fsprogs/files/e2fsprogs-1.41.10-e2fsck-corruption.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From: Theodore Ts'o <tytso@mit.edu>
-Date: Tue, 23 Feb 2010 04:51:26 +0000 (-0500)
-Subject: e2fsck: Fix bug which can cause e2fsck -fD to corrupt non-indexed directories
-X-Git-Url: http://git.kernel.org/?p=fs%2Fext2%2Fe2fsprogs.git;a=commitdiff_plain;h=53fbfb2bc3490d0ff317666322dd077c08116e0c
-
-e2fsck: Fix bug which can cause e2fsck -fD to corrupt non-indexed directories
-
-E2fsprogs 1.41.10 introduced a regression (in commit b71e018) where
-e2fsck -fD can corrupt non-indexed directories when are exists one or
-more file names which alphabetically sort before ".". This can happen
-with ext2 filesystems or for small directories (take less than a
-block) which contain filenames that begin with a space or some other
-punctuation mark.
-
-Fix this by making sure we never reorder the '.' or '..' entry in the
-directory, since they must be first.
-
-Signed-off-by: "Theodore Ts'o" <tytso@mit.edu>
----
-
-diff --git a/e2fsck/rehash.c b/e2fsck/rehash.c
-index 780742e..ceb8543 100644
---- a/e2fsck/rehash.c
-+++ b/e2fsck/rehash.c
-@@ -763,7 +763,12 @@ retry_nohash:
-
- /* Sort the list */
- resort:
-- qsort(fd.harray, fd.num_array, sizeof(struct hash_entry), hash_cmp);
-+ if (fd.compress)
-+ qsort(fd.harray+2, fd.num_array-2, sizeof(struct hash_entry),
-+ hash_cmp);
-+ else
-+ qsort(fd.harray, fd.num_array, sizeof(struct hash_entry),
-+ hash_cmp);
-
- /*
- * Look for duplicates
diff --git a/sys-fs/e2fsprogs/files/e2fsprogs-1.41.2-makefile.patch b/sys-fs/e2fsprogs/files/e2fsprogs-1.41.2-makefile.patch
deleted file mode 100644
index 1704b7ce3730..000000000000
--- a/sys-fs/e2fsprogs/files/e2fsprogs-1.41.2-makefile.patch
+++ /dev/null
@@ -1,80 +0,0 @@
---- e2fsck/Makefile.in
-+++ e2fsck/Makefile.in
-@@ -199,12 +199,12 @@
- @echo " LINK $(root_sbindir)/fsck.ext2"
-- @$(LN) -f $(DESTDIR)$(root_sbindir)/e2fsck \
-+ @$(LN_S) -f e2fsck \
- $(DESTDIR)$(root_sbindir)/fsck.ext2
- @echo " LINK $(root_sbindir)/fsck.ext3"
-- @$(LN) -f $(DESTDIR)$(root_sbindir)/e2fsck \
-+ @$(LN_S) -f e2fsck \
- $(DESTDIR)$(root_sbindir)/fsck.ext3
- @echo " LINK $(root_sbindir)/fsck.ext4"
-- @$(LN) -f $(DESTDIR)$(root_sbindir)/e2fsck \
-+ @$(LN_S) -f e2fsck \
- $(DESTDIR)$(root_sbindir)/fsck.ext4
- @echo " LINK $(root_sbindir)/fsck.ext4dev"
-- @$(LN) -f $(DESTDIR)$(root_sbindir)/e2fsck \
-+ @$(LN_S) -f e2fsck \
- $(DESTDIR)$(root_sbindir)/fsck.ext4dev
-@@ -225,12 +225,12 @@
- @echo " LINK $(man8dir)/fsck.ext2.8"
-- @$(LN) -f $(DESTDIR)$(man8dir)/e2fsck.8 \
-+ @$(LN_S) -f e2fsck.8 \
- $(DESTDIR)$(man8dir)/fsck.ext2.8
- @echo " LINK $(man8dir)/fsck.ext3.8"
-- @$(LN) -f $(DESTDIR)$(man8dir)/e2fsck.8 \
-+ @$(LN_S) -f e2fsck.8 \
- $(DESTDIR)$(man8dir)/fsck.ext3.8
- @echo " LINK $(man8dir)/fsck.ext4.8"
-- @$(LN) -f $(DESTDIR)$(man8dir)/e2fsck.8 \
-+ @$(LN_S) -f e2fsck.8 \
- $(DESTDIR)$(man8dir)/fsck.ext4.8
- @echo " LINK $(man8dir)/fsck.ext4.8"
-- @$(LN) -f $(DESTDIR)$(man8dir)/e2fsck.8 \
-+ @$(LN_S) -f e2fsck.8 \
- $(DESTDIR)$(man8dir)/fsck.ext4dev.8
---- misc/Makefile.in
-+++ misc/Makefile.in
-@@ -279,18 +279,18 @@
- @echo " LINK $(root_sbindir)/mkfs.ext2"
-- @$(LN) -f $(DESTDIR)$(root_sbindir)/mke2fs \
-+ @$(LN_S) -f mke2fs \
- $(DESTDIR)$(root_sbindir)/mkfs.ext2
- @echo " LINK $(root_sbindir)/mkfs.ext3"
-- @$(LN) -f $(DESTDIR)$(root_sbindir)/mke2fs \
-+ @$(LN_S) -f mke2fs \
- $(DESTDIR)$(root_sbindir)/mkfs.ext3
- @echo " LINK $(root_sbindir)/mkfs.ext4"
-- @$(LN) -f $(DESTDIR)$(root_sbindir)/mke2fs \
-+ @$(LN_S) -f mke2fs \
- $(DESTDIR)$(root_sbindir)/mkfs.ext4
- @echo " LINK $(root_sbindir)/mkfs.ext4dev"
-- @$(LN) -f $(DESTDIR)$(root_sbindir)/mke2fs \
-+ @$(LN_S) -f mke2fs \
- $(DESTDIR)$(root_sbindir)/mkfs.ext4dev
- @echo " LINK $(root_sbindir)/e2label"
-- @$(LN) -f $(DESTDIR)$(root_sbindir)/tune2fs \
-+ @$(LN_S) -f tune2fs \
- $(DESTDIR)$(root_sbindir)/e2label
- @echo " LINK $(root_sbindir)/findfs"
-- @$(LN) -f $(DESTDIR)$(root_sbindir)/tune2fs \
-+ @$(LN_S) -f tune2fs \
- $(DESTDIR)$(root_sbindir)/findfs
-@@ -314,12 +314,12 @@
- @echo " LINK mkfs.ext2.8"
-- @$(LN) -f $(DESTDIR)$(man8dir)/mke2fs.8 \
-+ @$(LN_S) -f mke2fs.8 \
- $(DESTDIR)$(man8dir)/mkfs.ext2.8
- @echo " LINK mkfs.ext3.8"
-- @$(LN) -f $(DESTDIR)$(man8dir)/mke2fs.8 \
-+ @$(LN_S) -f mke2fs.8 \
- $(DESTDIR)$(man8dir)/mkfs.ext3.8
- @echo " LINK mkfs.ext4.8"
-- @$(LN) -f $(DESTDIR)$(man8dir)/mke2fs.8 \
-+ @$(LN_S) -f mke2fs.8 \
- $(DESTDIR)$(man8dir)/mkfs.ext4.8
- @echo " LINK mkfs.ext4dev.8"
-- @$(LN) -f $(DESTDIR)$(man8dir)/mke2fs.8 \
-+ @$(LN_S) -f mke2fs.8 \
- $(DESTDIR)$(man8dir)/mkfs.ext4dev.8
diff --git a/sys-fs/e2fsprogs/files/e2fsprogs-1.41.3-tune2fs-opt.patch b/sys-fs/e2fsprogs/files/e2fsprogs-1.41.3-tune2fs-opt.patch
deleted file mode 100644
index 35e8a57fa3a4..000000000000
--- a/sys-fs/e2fsprogs/files/e2fsprogs-1.41.3-tune2fs-opt.patch
+++ /dev/null
@@ -1,99 +0,0 @@
-http://bugs.gentoo.org/253162
-
-From 27c6de45a4187a348ec0960472d4a113ee6ea425 Mon Sep 17 00:00:00 2001
-From: Theodore Ts'o <tytso@mit.edu>
-Date: Sat, 15 Nov 2008 00:32:39 -0500
-Subject: [PATCH] tune2fs: Fix inefficient O(n**2) algorithms when expanding the inode size
-
-When running "tune2fs -I 256" on moderate to large filesystems, the
-time required to run tune2fs can take many hours (20+ before some
-users gave up in disgust). This was due to some O(n**2) and O(n*m)
-algorithms in move_block() and inode_scan_and_fix(), respectively.
-
-Signed-off-by: "Theodore Ts'o" <tytso@mit.edu>
----
- misc/tune2fs.c | 25 +++++++++++++------------
- 1 files changed, 13 insertions(+), 12 deletions(-)
-
-diff --git a/misc/tune2fs.c b/misc/tune2fs.c
-index b29b344..e72518a 100644
---- a/misc/tune2fs.c
-+++ b/misc/tune2fs.c
-@@ -1011,13 +1011,13 @@ static int move_block(ext2_filsys fs, ext2fs_block_bitmap bmap)
- if (retval)
- return retval;
-
-- for (blk = fs->super->s_first_data_block;
-- blk < fs->super->s_blocks_count; blk++) {
-+ for (new_blk = blk = fs->super->s_first_data_block;
-+ blk < fs->super->s_blocks_count; blk++) {
-
- if (!ext2fs_test_block_bitmap(bmap, blk))
- continue;
-
-- retval = ext2fs_new_block(fs, blk, NULL, &new_blk);
-+ retval = ext2fs_new_block(fs, new_blk, NULL, &new_blk);
- if (retval)
- goto err_out;
-
-@@ -1068,12 +1068,14 @@ static int process_block(ext2_filsys fs EXT2FS_ATTR((unused)),
- e2_blkcnt_t blockcnt EXT2FS_ATTR((unused)),
- blk_t ref_block EXT2FS_ATTR((unused)),
- int ref_offset EXT2FS_ATTR((unused)),
-- void *priv_data EXT2FS_ATTR((unused)))
-+ void *priv_data)
- {
- int ret = 0;
- blk_t new_blk;
-+ ext2fs_block_bitmap bmap = (ext2fs_block_bitmap) priv_data;
-
--
-+ if (!ext2fs_test_block_bitmap(bmap, *block_nr))
-+ return 0;
- new_blk = transalate_block(*block_nr);
- if (new_blk) {
- *block_nr = new_blk;
-@@ -1086,7 +1088,7 @@ static int process_block(ext2_filsys fs EXT2FS_ATTR((unused)),
- return ret;
- }
-
--static int inode_scan_and_fix(ext2_filsys fs)
-+static int inode_scan_and_fix(ext2_filsys fs, ext2fs_block_bitmap bmap)
- {
- errcode_t retval = 0;
- ext2_ino_t ino;
-@@ -1122,8 +1124,8 @@ static int inode_scan_and_fix(ext2_filsys fs)
- * Do we need to fix this ??
- */
-
-- if (inode.i_file_acl) {
--
-+ if (inode.i_file_acl &&
-+ ext2fs_test_block_bitmap(bmap, inode.i_file_acl)) {
- blk = transalate_block(inode.i_file_acl);
- if (!blk)
- continue;
-@@ -1142,9 +1144,8 @@ static int inode_scan_and_fix(ext2_filsys fs)
- if (!ext2fs_inode_has_valid_blocks(&inode))
- continue;
-
-- retval = ext2fs_block_iterate2(fs, ino, 0,
-- block_buf, process_block,
-- 0);
-+ retval = ext2fs_block_iterate2(fs, ino, 0, block_buf,
-+ process_block, bmap);
- if (retval)
- goto err_out;
-
-@@ -1344,7 +1345,7 @@ static int resize_inode(ext2_filsys fs, unsigned long new_size)
- if (retval)
- goto err_out;
-
-- retval = inode_scan_and_fix(fs);
-+ retval = inode_scan_and_fix(fs, bmap);
- if (retval)
- goto err_out;
-
---
-1.6.0.6
-