summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-06-07 07:06:25 +0000
committerTravis Tilley <lv@gentoo.org>2004-06-07 07:06:25 +0000
commitd27ed0921c8a6498a5ea955be9e7eb35ce735727 (patch)
tree7ce11e21107ae5c177e92a38400b0052120c54f4 /sys-libs
parentx86 stable.QA fixes. (diff)
downloadhistorical-d27ed0921c8a6498a5ea955be9e7eb35ce735727.tar.gz
historical-d27ed0921c8a6498a5ea955be9e7eb35ce735727.tar.bz2
historical-d27ed0921c8a6498a5ea955be9e7eb35ce735727.zip
dont check use in global context, and move flag filtering to src_compile
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/Manifest2
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20040605.ebuild10
2 files changed, 6 insertions, 6 deletions
diff --git a/sys-libs/glibc/Manifest b/sys-libs/glibc/Manifest
index 62cfd7e381fe..00b04703f5b5 100644
--- a/sys-libs/glibc/Manifest
+++ b/sys-libs/glibc/Manifest
@@ -4,7 +4,7 @@ MD5 40b73d3cb79e611b0b6a3385f1601e32 glibc-2.3.3_pre20040207.ebuild 19594
MD5 c09629c691d99b48b52e8ee8083cd1da glibc-2.3.3_pre20031210.ebuild 19015
MD5 22883a9b4254ad4c7a81e88dbb8afacb glibc-2.3.3_pre20040529.ebuild 21580
MD5 081030d4ac6e9b8879727089b52b28fd glibc-2.3.2-r10.ebuild 19418
-MD5 bfaea497a8b7e3c0250ce860c5a1e7dd glibc-2.3.4.20040605.ebuild 16290
+MD5 454b1e65ede41df9bf69fcdf1cc25aab glibc-2.3.4.20040605.ebuild 16275
MD5 03c72a7da4b62b7c73dbb67b70252a20 glibc-2.3.3_pre20040117.ebuild 18526
MD5 6ae51bfd7e5cc6af9b1ea678354a8760 glibc-2.3.2-r2.ebuild 17968
MD5 c1f9466ec8250dd47beb7a71f7c536fe glibc-2.3.1-r5.ebuild 10719
diff --git a/sys-libs/glibc/glibc-2.3.4.20040605.ebuild b/sys-libs/glibc/glibc-2.3.4.20040605.ebuild
index a36ab355e80e..cc872e4ad26f 100644
--- a/sys-libs/glibc/glibc-2.3.4.20040605.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20040605.ebuild
@@ -1,16 +1,13 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040605.ebuild,v 1.4 2004/06/07 06:58:14 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040605.ebuild,v 1.5 2004/06/07 07:06:25 lv Exp $
IUSE="nls pic build nptl erandom hardened makecheck multilib"
inherit eutils flag-o-matic gcc
-filter-flags "-fomit-frame-pointer -malign-double"
-filter-ldflags "-pie"
-
# make check will fail if sandbox is enabled
-use makecheck && export SANDBOX_DISABLED="1"
+export SANDBOX_DISABLED="1"
# Recently there has been a lot of stability problem in Gentoo-land. Many
# things can be the cause to this, but I believe that it is due to gcc3
@@ -356,6 +353,9 @@ src_unpack() {
src_compile() {
setup_flags
+ filter-flags "-fomit-frame-pointer -malign-double"
+ filter-ldflags "-pie"
+
# These should not be set, else the
# zoneinfo do not always get installed ...