summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2004-08-30 09:31:26 +0000
committerRenat Lumpau <rl03@gentoo.org>2004-08-30 09:31:26 +0000
commitc52fe5678bcd4d4b1384e276e2b260a27b85f595 (patch)
tree8ee716be9ee49ef27909a607dbb7c8cf20ae987e /www-apps
parentversion bump (diff)
downloadhistorical-c52fe5678bcd4d4b1384e276e2b260a27b85f595.tar.gz
historical-c52fe5678bcd4d4b1384e276e2b260a27b85f595.tar.bz2
historical-c52fe5678bcd4d4b1384e276e2b260a27b85f595.zip
Initial ebuild (by swegener). Closes #27161
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/mantisbt/ChangeLog11
-rw-r--r--www-apps/mantisbt/Manifest5
-rw-r--r--www-apps/mantisbt/files/digest-mantisbt-0.18.31
-rw-r--r--www-apps/mantisbt/files/postinstall-en.txt13
-rw-r--r--www-apps/mantisbt/mantisbt-0.18.3.ebuild42
-rw-r--r--www-apps/mantisbt/metadata.xml5
6 files changed, 77 insertions, 0 deletions
diff --git a/www-apps/mantisbt/ChangeLog b/www-apps/mantisbt/ChangeLog
new file mode 100644
index 000000000000..db27bd1c682b
--- /dev/null
+++ b/www-apps/mantisbt/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for www-apps/mantisbt
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mantisbt/ChangeLog,v 1.1 2004/08/30 09:31:26 rl03 Exp $
+
+*mantisbt-0.18.3 (30 Aug 2004)
+
+ 30 Aug 2004; Renat Lumpau <rl03@gentoo.org> +metadata.xml,
+ +files/postinstall-en.txt, +mantisbt-0.18.3.ebuild:
+ Initial ebuild (by swegener, really). Thanks to blubber, Jacob Smullyan
+ <smulloni@smullyan.org>, and swegener for their work. Closes #27161.
+
diff --git a/www-apps/mantisbt/Manifest b/www-apps/mantisbt/Manifest
new file mode 100644
index 000000000000..39eae6ad2ed2
--- /dev/null
+++ b/www-apps/mantisbt/Manifest
@@ -0,0 +1,5 @@
+MD5 c40b4dbf528af94816a0d3ff98ba673b ChangeLog 498
+MD5 f61bfa064e3acdfcd826e4a38b121196 metadata.xml 161
+MD5 f3aebab785809c807abd76b04abfd21d mantisbt-0.18.3.ebuild 1060
+MD5 cc4d1c5d3bb40662950d32111d027dad files/postinstall-en.txt 537
+MD5 4553a6ae29bae20c13ffa21fdb20281b files/digest-mantisbt-0.18.3 67
diff --git a/www-apps/mantisbt/files/digest-mantisbt-0.18.3 b/www-apps/mantisbt/files/digest-mantisbt-0.18.3
new file mode 100644
index 000000000000..10ab99d4dc0d
--- /dev/null
+++ b/www-apps/mantisbt/files/digest-mantisbt-0.18.3
@@ -0,0 +1 @@
+MD5 a0695e6d562778f8728d8f7ac963d8dd mantisbt-0.18.3.tar.gz 568773
diff --git a/www-apps/mantisbt/files/postinstall-en.txt b/www-apps/mantisbt/files/postinstall-en.txt
new file mode 100644
index 000000000000..b49a956f2e65
--- /dev/null
+++ b/www-apps/mantisbt/files/postinstall-en.txt
@@ -0,0 +1,13 @@
+Please edit ${MY_INSTALLDIR}/config_inc.php to configure Mantis for your
+system.
+
+If this a first time install, you must create the mantis database and then
+execute ${MY_SQLSCRIPTSDIR}/mysql/${PVR}_create.sql
+via mysql to create the tables. If you are upgrading from an earlier version
+you can use the upgrade scripts at admin/ to execute the pending database
+updates.
+
+Check your installation: http://${VHOST_HOSTNAME}/${PN}/admin
+Then log in: administrator/root.
+
+After you've finished these steps, please delete the admin/ directory.
diff --git a/www-apps/mantisbt/mantisbt-0.18.3.ebuild b/www-apps/mantisbt/mantisbt-0.18.3.ebuild
new file mode 100644
index 000000000000..e92e3b7f1c0b
--- /dev/null
+++ b/www-apps/mantisbt/mantisbt-0.18.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mantisbt/mantisbt-0.18.3.ebuild,v 1.1 2004/08/30 09:31:26 rl03 Exp $
+
+inherit webapp
+
+IUSE=""
+
+DESCRIPTION="PHP/MySQL/Web based bugtracking system"
+HOMEPAGE="http://www.mantisbt.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+KEYWORDS="~x86"
+
+DEPEND="$DEPEND"
+RDEPEND="
+ ${DEPEND}
+ >=dev-db/mysql-3.23.32
+ >=net-www/apache-1.3
+ >=dev-php/mod_php-4.0.6
+"
+
+LICENSE="GPL-2"
+
+src_unpack() {
+ unpack ${A}
+ find ${S} -name .cvsignore -exec rm {} \;
+}
+
+src_install() {
+ webapp_src_preinst
+ dohtml doc/*.{html,css}
+ dodoc doc/{CREDITS,CUSTOMIZATION,ChangeLog,LICENSE,README,TROUBLESHOOTING,UPGRADING}
+
+ cp -R *.php admin core css graphs images lang ${D}/${MY_HTDOCSDIR}
+ cp config_inc.php.sample ${D}/${MY_HTDOCSDIR}/config_inc.php
+
+ webapp_configfile ${MY_HTDOCSDIR}/config_inc.php
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+ webapp_sqlscript mysql ${S}/sql/db_generate.sql
+ webapp_src_install
+}
diff --git a/www-apps/mantisbt/metadata.xml b/www-apps/mantisbt/metadata.xml
new file mode 100644
index 000000000000..95c06f0095bb
--- /dev/null
+++ b/www-apps/mantisbt/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>web-apps</herd>
+</pkgmetadata>