summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-06-29 13:17:59 +0000
committerPeter Volkov <pva@gentoo.org>2010-06-29 13:17:59 +0000
commit5b397a6c7e94c821a3d17936c77d3a4761b86a04 (patch)
tree48fab36c1d2dd7cab7519b0461517789536c9784 /www-misc
parentStable on amd64 wrt bug #326139 (diff)
downloadhistorical-5b397a6c7e94c821a3d17936c77d3a4761b86a04.tar.gz
historical-5b397a6c7e94c821a3d17936c77d3a4761b86a04.tar.bz2
historical-5b397a6c7e94c821a3d17936c77d3a4761b86a04.zip
Initial import, bug #325413, thank Nikoli for this job.
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'www-misc')
-rw-r--r--www-misc/fcgiwrap/ChangeLog11
-rw-r--r--www-misc/fcgiwrap/Manifest5
-rw-r--r--www-misc/fcgiwrap/fcgiwrap-1.0.2-r1.ebuild47
-rw-r--r--www-misc/fcgiwrap/fcgiwrap-9999.ebuild47
-rw-r--r--www-misc/fcgiwrap/metadata.xml19
5 files changed, 129 insertions, 0 deletions
diff --git a/www-misc/fcgiwrap/ChangeLog b/www-misc/fcgiwrap/ChangeLog
new file mode 100644
index 000000000000..feb3224fa7f8
--- /dev/null
+++ b/www-misc/fcgiwrap/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for www-misc/fcgiwrap
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-misc/fcgiwrap/ChangeLog,v 1.1 2010/06/29 13:17:59 pva Exp $
+
+*fcgiwrap-9999 (29 Jun 2010)
+*fcgiwrap-1.0.2-r1 (29 Jun 2010)
+
+ 29 Jun 2010; Peter Volkov <pva@gentoo.org> +fcgiwrap-1.0.2-r1.ebuild,
+ +fcgiwrap-9999.ebuild, +metadata.xml:
+ Initial import, bug #325413, thank Nikoli for this job.
+
diff --git a/www-misc/fcgiwrap/Manifest b/www-misc/fcgiwrap/Manifest
new file mode 100644
index 000000000000..e90aebbc64c0
--- /dev/null
+++ b/www-misc/fcgiwrap/Manifest
@@ -0,0 +1,5 @@
+DIST fcgiwrap-1.0.2.tar.gz 8828 RMD160 73765cc8f99a922d4ebed5a758a0cb11ecaa446c SHA1 f62722efd637aea8ce4e6325c85614cfe2345d8d SHA256 676015dd1e834fba76fba92ead512f9b13e73fde631cf6aaef6a207d600d6edf
+EBUILD fcgiwrap-1.0.2-r1.ebuild 1087 RMD160 7299a9f3a4adf779579741e6d4315b4eeded2510 SHA1 9b751519f262741d3d5d4ce3366c4303d8461114 SHA256 0b2dfca78ec64f563454e99acf1c80c1b3a5dcb479106ce689021546f267d2d2
+EBUILD fcgiwrap-9999.ebuild 1083 RMD160 1aaad4675037a69130f44cdb7bd8d2a5f6081dd1 SHA1 2f3f0009b87e30c7926afae0facddc5f363684b9 SHA256 cb6cb600d9ce28db6a5b59d9b585dce37821fda1f4cb6ce82afaa7b53b231264
+MISC ChangeLog 438 RMD160 98130c4bfe83df089b0fa9f5dcae10d28df7d3bc SHA1 68b91cef82c86e9a98f554e0318938e0fc272f13 SHA256 5e8f1fffe79bc9a9e3bc372a38318773d6cc90450cca430d64c66bef3c9e5e2c
+MISC metadata.xml 529 RMD160 506c4a6a133d33430db5b7333290ec91491878f1 SHA1 855a78b97d072d1266b25698014f7e8f9532cd15 SHA256 8664a38a25f48c60578f9fea3f3354463686c54879f456217e842ed342dfcbd1
diff --git a/www-misc/fcgiwrap/fcgiwrap-1.0.2-r1.ebuild b/www-misc/fcgiwrap/fcgiwrap-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..6ec6cf862ae6
--- /dev/null
+++ b/www-misc/fcgiwrap/fcgiwrap-1.0.2-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-misc/fcgiwrap/fcgiwrap-1.0.2-r1.ebuild,v 1.1 2010/06/29 13:17:59 pva Exp $
+
+EAPI="3"
+
+[[ ${PV} = *9999* ]] && VCS_ECLASS="git" || VCS_ECLASS=""
+inherit autotools ${VCS_ECLASS}
+
+DESCRIPTION="Simple FastCGI wrapper for CGI scripts (CGI support for nginx)"
+HOMEPAGE="http://nginx.localdomain.pl/wiki/FcgiWrap"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="git://github.com/gnosek/${PN}.git"
+
+ KEYWORDS=""
+else
+ MY_REV="2e301c8"
+ SRC_URI="http://download.github.com/gnosek-${PN}-v${PV}-1-g${MY_REV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/gnosek-${PN}-${MY_REV}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DEPEND="dev-libs/fcgi"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -e '/man8dir = $(DESTDIR)/s/@prefix@//' \
+ -i Makefile.in || die "sed failed"
+
+ eautoreconf
+}
+
+src_install() {
+ einstall DESTDIR="${D}"
+
+ dodoc README.rst
+}
+
+pkg_postinst() {
+ einfo 'You may want to install www-servers/spawn-fcgi to use with fcgiwrap.'
+}
diff --git a/www-misc/fcgiwrap/fcgiwrap-9999.ebuild b/www-misc/fcgiwrap/fcgiwrap-9999.ebuild
new file mode 100644
index 000000000000..c63083e2a121
--- /dev/null
+++ b/www-misc/fcgiwrap/fcgiwrap-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-misc/fcgiwrap/fcgiwrap-9999.ebuild,v 1.1 2010/06/29 13:17:59 pva Exp $
+
+EAPI="3"
+
+[[ ${PV} = *9999* ]] && VCS_ECLASS="git" || VCS_ECLASS=""
+inherit autotools ${VCS_ECLASS}
+
+DESCRIPTION="Simple FastCGI wrapper for CGI scripts (CGI support for nginx)"
+HOMEPAGE="http://nginx.localdomain.pl/wiki/FcgiWrap"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="git://github.com/gnosek/${PN}.git"
+
+ KEYWORDS=""
+else
+ MY_REV="2e301c8"
+ SRC_URI="http://download.github.com/gnosek-${PN}-v${PV}-1-g${MY_REV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/gnosek-${PN}-${MY_REV}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DEPEND="dev-libs/fcgi"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -e '/man8dir = $(DESTDIR)/s/@prefix@//' \
+ -i Makefile.in || die "sed failed"
+
+ eautoreconf
+}
+
+src_install() {
+ einstall DESTDIR="${D}"
+
+ dodoc README.rst
+}
+
+pkg_postinst() {
+ einfo 'You may want to install www-servers/spawn-fcgi to use with fcgiwrap.'
+}
diff --git a/www-misc/fcgiwrap/metadata.xml b/www-misc/fcgiwrap/metadata.xml
new file mode 100644
index 000000000000..c9a01cb144a2
--- /dev/null
+++ b/www-misc/fcgiwrap/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd></herd>
+<maintainer>
+<email>pva@gentoo.org</email>
+<name>Peter Volkov</name>
+</maintainer>
+<maintainer>
+<email>nikoli@lavabit.com</email>
+<name>Nikoli</name>
+</maintainer>
+<longdescription lang="en">
+ fcgiwrap is a simple server for running CGI applications over FastCGI. It
+ hopes to provide clean CGI support to Nginx (and other web servers that may
+ need it).
+</longdescription>
+</pkgmetadata>
+